Sonoff zigbee button SNZB-01 issue (only in cloud mode)

Tags: #<Tag:0x00007f73992214b0> #<Tag:0x00007f7399221370> #<Tag:0x00007f7399221208> #<Tag:0x00007f73992210c8>

Guys, do you know if Sonoff zigbee sensors can trigger Sonoff zigbee switches without Wi-fi / cloud ?

Do you mean LAN?
Yes they can!
But you have to activate it un the app.
Actually on LAN mode its quicker!

No. I mean “no LAN” and “no Wi-fi”.
I don’t get the point of Sonoff zigbee (except low power) if I need Wi-fi or Ewelink cloud.
Why is not possible to have “zigbee scenes” inside zigbee bridge?

1 Like

I guess the closest thing now is LAN and a router, without internet, but somehow WIFI technology is involved

Sonoff only has one Zigbee switch : the SONOFF BASICZBR3 Zigbee. In theory, you should be able to bind your Sonoff Zigbee sensor to the Sonoff Basiczbr3. How to do it depends on your Zigbee integration.

Thanks. It looks like is not working without Internet and using Scenes from Ewelink.
Scenes works only in cloud but zigbee binding is not possible through application.

Ok, I think you use the Sonoff ZbBridge with the native software ? You could flash it with Tasmota and use ZHA.

Should I flash both the Bridge and Sensors/Switches or just the bridge?
Is this working OTA?
Is ZHA cloud capable?

Thanks!

Just the bridge. ZHA is local only, if you want cloud you need to access your HA instance remotely.

I’ve just got my ZBBridge working with the SNZB-01 switches. Had all sorts of difficulties with flashing original to Tasmota so bought another and left with Sonoff firmware. (I think I may have got a dud first time around but don’t want to take the risk of buggering this one up).

I used SonoffLAN integration https://github.com/AlexxIT/SonoffLAN/blob/master/README.md#install-with-hacs and the key is a single press registers a state of off and a double click registers a state of on.

I have automations working immediately on either a single or double-click.

Hopefully this helps?

Hi Jim, I would be thrilled to use this in Node-RED, but when I paste your flow in, 4 of the six nodes show up as unknown: the server-events node and the 3 api-call-service nodes. Any idea why this might be happening? Do I need to import these into NR from someplace?

  • Steve

@steve2020
The 4 nodes that you say are unknown are ‘Home Assistant’ nodes. Are you running Node-Red from ‘Home Assistant’? If you are you should have the nodes in your NR palette, but I would think that you could import the from the ‘Manage Palette’ menu.
Jim

I am NOT running NR from within HA. Do I need to be to use these? I did manage to locate and import the nodes into my installation. I used this:

https://flows.nodered.org/node/node-red-contrib-home-assistant-websocket

Is this the correct set of nodes? There are several on nodered.org, but this one was the most recently updated. But I’ve been unable to connect the nodes/flows to my HA instance.

Hmmm…I haven’t done anything to connect NR with HA…is there a large step that I’m missing?

@steve2020
Why don’t you install the Node-Red integration in Home Assistant? It’s what I did and it works fine.

I’m guessing that if you want a ‘pure’ standalone Node-Red set-up without HA, that you’ll have to use MQTT enabled lights and publish/subscribe payloads to get it working. I know very little about MQTT and am a beginner with HA and Node-Red.
Jim