Sonoff Zigbee Mini (zbmini) not found after power outage

I have a few sonoff zbmini, they seem to work great with my tasmotized sonoff zigbee bridge, configured to use ZHA. I had a power outage and my other zigbee sensors slowly came back on-line on ZHA, but my zbminis did not. Will I have to open my switch box to press the little button to make they on-line again? If I have to do that every time I have a power outage, these zbmini are useless… Not sure this is a hardware or a configuration issue, though. Anybody knows a workaround this situation? Thanks.

Try to power cycle the ones not working, I have 5 of these if one looses its connection I just power cycle it and it comes back.

It only happend twice in my system, but than again we don’t have power outages here.
I am also using ZHA but than with a Conbee 2 stick.

I have the same problem. I had to disassemble my socket to bind the device again.
Maybe there is a way how to do it differently?

Turning the light circuit breaker off and on again doesn’t seem to get my zbminis back online. They don’t even seem to be in pairing mode again.

I red the manuals, but there is no information. Tasmotized sonoffs, when they are turned off and on 5 times fast, they reset to the default configuration and disconnect from the wi-fi. I think the zbminis behave similarly. Maybe, power ciclyng the devices a few times will bring them back to pairing mode, alowing pairing without disassemble of the sockets, but the manuals says nothing.

As it is not uncommon to have power surges where I live, I bought (I haven’t received yet) this device to try to prevent this:

I found a solution to my problem, but this is unlikely to suit you.
I used the CC2538 and as it turned out it could not reconnect with the devices after a power outage.
I took CC2652 for the test and it works great.

Finally I had had time to open my switch box to pair my devices. The green light was blinking, I pressed the button for 5 seconds but I couldn’t add the device again in ZHA because no device was found.

I took out the phase wire to turn off the device, I noticed that the device took several seconds to turn off. Turning on the device again, I was able to add the device to ZHA again.

Long story short, one does not need to open the switch box. Turn off the circuit breaker for your light, for a minute or so, and the zbminis will be in pairing mode again.

PS: I made some tests after pairing the devices again, turning off the circuit breaker and on again to see if the devices would come back to ZHA. They automaticaly come back, no problem. The power outage did something to the devices that made the devices to lose their configurations. My final thoughts are that theses little devices are great.


Is this the same issue you were having? :
Zbmini not pairing

From what I can gather from the solutions here, I need to switch it off and on again relatively quickly a few times from the fuse box, or switch it off for 60secs to reset? I’ve tried turning it off overnight and then back on again in the morning but the same thing happens. I’m not sure if I got a refurbed one that had not been reset to factory settings off amazon so the box is looking for a WiFi that isn’t there.

@jamo81, Zbmini does not use Wifi! You will need a zigbee hub for it to work. If you want to use wifi, you should buy a Sonoff Mini, that is defferent from a Sonoff Zigbee Mini.

Thanks! I totally had not realised that. Luckily, I saw last night that it had paired with my philips hue Bridge so all is good and I had a warm towel this morning!! Might get the hub for better functionality if I need it in the future. Thank you for your help.

Weird… not the same behaviour with my ZBMINI’s. I tried different intervals of power “outages” but needed to get it all open to reach the button on the device anyway. No way it went into pairing just by power cuts.
Perhaps a good thing regarding security, depending on what you use the ZBMINI’s for.
Maybe they changed it over time in the firmware.

I had tried almost everything, like powering off the device by cutting the power supply.

But taking out one wire (phase I guess) while keeping the rest of wires and power supply with no changes… worked!!! Somehow, the device could truly reset, doing that.

Thanks so much.


1 Like

I installed a new ZBMini at the front door and wasn’t sure how to pair it. I tried pressing the button, it was blinking green, I tried restarting home assistant, nothing worked. Not even logs for new devices.
After reading your post, I turned off the switch at the fuse box for the downstairs light for one minute and back on,
Then went back to my PC and it was already configured :smiley:
Thank you very much!