Sonoff Zigbee USB Dongle not working with IKEA Tradfri buttons

Hi all,

I’ve decided to swap my dongle for one with larger range and opted for the Sonoff Zigbee 3.0 plus usb dongle.

Out of 3 Ikea Tradfri shortcut buttons only one seems to work and I can’t figure out why. Would you be able to help please?

This is what I know and tried:

  • all buttons pair “correctly” but when used in automations only 1 of the buttons triggers anything the other 2 do nothing. I’m assuming not a range or battery issue.
  • In ZHA > devices, trying the “reconfigure device” always fails.
  • Deleting the device and readding it does not help.

I’ve used this guide (Easy Sonoff Zigbee CC2652 Firmware Upgrades! + Other Ethernet / USB - YouTube) to get the latest zigbee2mqtt firmware on the dongle and rebooted but the behavior is the same.

My setup:
Homeassistant latest version
Sonoff Zigbee 3.0 usb dongle
Ikea Tradfri shortcut buttons

This is, of course, incredibly frustrating :smiley:

Thanks for any help!

1 Like

Yeah, I have the same problem. So… you’re not alone in your frustration, at least!


Thanks for sharing!

Since I posted I changed two things and it’s now working flawlessly.:

  • swapped the batteries on the shortcut buttons. It’s weird as one of them was brand new in the box so I discarded the option of battery problems. It still didn’t play well for some reason.
  • replaced zha with zigbee2mqtt

Works fine now.

I might play some with the batteries. There’s other posts indicating a problem with batteries getting drained really fast (possibly with the Sonoff controller especially, but maybe wider than that?).

And if that doesn’t work, I guess maybe time to bite the bullet and go to zigbee2mqtt.

1 Like

Soooo, I replaced the Sonoff dongle with one of the tubesZB ones (partly to see if this would work better, and partly because it’s cool to support / benefit from an individual hardware hacker). Updated that to the latest firmware, and to my excitement two Ikea Shortcut buttons paired and just worked. But then the third (and fourth, fifth, sixth!) all did not — same symptom as before: no battery info. (Not to mention, of course, not seeming to do anything.)

New batteries did nothing. @jumpifzero, is everything still working for you with zigbee2mqtt?

I kind of wonder if something is causing problems with having too many of the same type of button? The were relatively cheap and seemed so handy that I scooped up a handful, but… maybe I shouldn’t have.

So sonoff dongle and tube’s would both exhibit similar problem? Well, come to think of it, they should. These CC2652x coordinators do share similar toolkits and flashing methods, and even firmware, after all.

Regardless of ZHA or zigbee2mqtt, results are inconsistent either, it seems.

So this looks more and more like an issue from how IKEA implemented their buttons…?
Is the solution for IKEA to release fixes? Or maybe ZHA or zigbee2mqtt would handle the issue?


Looks like there’s another thread on the same battery issue. And based on reports in this one and this one and this one (… plus the follow up from OP 9 days ago), the combination of Sonoff's 3.0 USB Dongle Plus along with zigbee2mqtt yields promising results…?

Does anyone see different results? It would be interesting to know.

I had some E1743 either not pairing, or pairing and then nothing. One took me over 10 attempts but is now fine.

I think what ended up working was delete device, restart everything, enable pairing mode and leave it next to the dongle for the whole 254 seconds.

Or try different things :wink: it’s a bit of a mess. Make sure to do OTA asap, and clicking them to wake them during the OTA check.

Perhaps the combination of these cc2652 dongles, IKEA buttons and zha causes a weird edge case where they don’t always pair correctly and then drain their battery really fast so you’re then hopeless to get them to pair again. Or perhaps it’s down to button firmware version so it’s a gamble when you buy them.

Since my last post 9days ago it still all works solidly after swapping the batteries in the buttons and using zigbee2mqtt instead of zha. I had only 1 instance where the buttons stopped working but a reboot to the pi fixed it. Other that that it’s been solid. But this is a really tiny network.

1 Like

I guess zigbee2mqtt is my project for the weekend! Thanks for the updates.

1 Like

Running into exactly the same problem as others here.

I used to use the SONOFF ZBBridge Smart Zigbee Bridge (Wifi) and was able to pair all my Ikea remotes successfully, but replaced it with the Sonoff Zigbee 3.0 Dongle Plus and no matter what I do the shortcut and on/off switch won’t always pair correctly.

Most of the time it would be detected and paired, but I’d receive no zha_event. As well, it seems to always be stuck for a long time on the configuring stage before finishing. Really frustrating to say the least.

1 Like

FWIW… I thought I said this somewhere, but apparently not here. Switching to zigbee2mqtt has resolved all of my issues with the Ikea buttons. No problems in the last three weeks.


Yes thanks Matt, I remember seeing this suggestion somewhere, in this thread or in another one.

It maybe my last resort type of solution. Right now I have all my Ikea remotes setup on ZHA and it’s going to be a pain to transition over to Zigbee2Mqtt.

On the other hand, I was able to follow the procedure from Antonio and get some progress:

  • Pair Ikea remote, place remote next to Zigbee coordinator USB stick
  • Test to see if HA sees the events on click
  • If not, delete the device, restart Home Assistant, and try again

A further 3 remotes programmed this way and once it works, it stays working. Still one more to go but this one is really stubborn.

I was able to pair the final Ikea remote with ZHA.

By my rough estimate, it seems like it takes 5 tries (add/test/remove/restart) cycles per Ikea remote to get it to pair successfully.

In case someone could troubleshoot it better than I can, I am attaching my homeassistant.log (parts taht relate to zha or zigbee). It feels like some sort of race condition, but I don’t know enough about the hardware or the protocol to tell if that’s the case or not.

I flashed my Sonoff Zigbee 3.0 USB stick by following this guide:

I used firmware version:

So… the bad news with ZHA is I had some of mine paired just fine but then two days latter they dropped off, and some of the ones which had worked right away initially became “stubborn”. With zigbee2mqtt no such problem.

I’ve got the same dongle and interested in getting frytur blinds. I have also read various forums with same issues and that’s unstable with sonoff zigbee 3.0 plus.
Has anyone had any experience with conbee 2? apparently it’s better?

How exacally do you remove them? Do you mean the red REMOVE DEVICE button or should I be doing something else? everytime I re-add a button it seems to already know the automation I added to it before I removed it.
I was thinking surely it should delete all old info about the button that it has?

Also being new to this and as you are using the same zigbee dongle as me. Is it supposed to sometimes toggle things on/off instantly and other times take a few secconds? I don’t get it.
sometimes its instant and sometimes it struggles but I’m not sending any other requests. The pi/dongle shouldn’t be struggling or is it just how zigbee is?
my wifi bulbs that i trigger with my working ikea shortcut button always work instantly.

It should be instantly every time.

This setup is working very reliably for me:

  • Sonoff dongle
  • Pi4 4 GB installed on a external SSD with a sata2usb adapter
  • Homeassistant os for the pi
  • Zigbee2mqtt (zha did not work well with this dongle)
  • IKEA trädfri shortcut buttons
  • tplink WiFi power plugs kp105

The buttons work instantly every time and never had to reboot the pi due to a malfunction.

1 Like

Thank you.
My setup is the same as yours apart from I’m using ZHA and the device I’m triggering is the sonoff ZBMINI-L no neutral switch.
I have some WiFi bulbs LIFX that always work instantly.

I’ll switch from ZHA and see what happens but maybe it’s the device I’m trying to trigger just being asleep?? I live in the uk and can’t seem to find an alternative to the ZBMINI-L for my lights

I will try to answer a couple of your questions:

everytime I re-add a button it seems to already know the automation I added to it before I removed it.
I was thinking surely it should delete all old info about the button that it has?

The “info” (device, entities) - yes. The automations - no, they do not get deleted. And if you re-add the device with the same entity names, the automations will continue working after re-adding.

maybe it’s the device I’m trying to trigger just being asleep??

A mains-powered zigbee device should not normally sleep. It should always be awake, so it should respond instantly (or, at least, very quickly).
[ Edit, thanks to @robertklep - this is not an absolute rule, and there are exceptions to it. And yes, the ZBMINI-L is one of the exceptions ]

I am using the same setup as jumpifzero, with the exception of the OS (I am running raspbian with zigbee2mqtt inside a Docker container - everything else, including HAss and MQTT server, are on other machines). I have tested Ikea shortcut buttons, dimmers, Styrbar remotes, and they all work properly (even though sometimes it does take a few tries to pair them or to get an OTA firmware update to start).

A lot of no-neutral mains powered devices are end devices because they are limited in the amount of power they can consume when “off”.