Speedtest Integration No longer loading

Oh shh. I thought jq was a cmd for .sh. Didn’t realized it was a package. Got it working now. Thanks.

1 Like

Hi all, bringing an oldie back to life as it seems the speedtest integration is broken again. Happened sometime on Core 2022.8.1 and still persisted after 8.4, reloaded, removed, re-added same result:

image

Hitting Configure throws this error:

image

When I do this, the systemlog contains this item, consistent with the integration:

Is anybody else experiencing this behavior as of Aug 2022?
Thanks,
Max

1 Like

I’m have the same exact issue Config flow could not be loaded: undefined

Got the same problem here… reloaded the speedtest… and it came up with the same error

Same for me :frowning:

I had exactly the same error after updating to 2022.8.5 earlier today, but now it’s started working again.

The SpeedTest integration seems fragile generally - mine sometimes stops working and is fixed by changing the Test Server to one or other, waiting a few minutes and then changing it back to ‘Auto Detect’. Does anyone else see this and know of a better way to fix it?

yep … i was having same issues as ian… speed test would work for about a week or so… then suddenly stop… error would be server unreachable… selecting different server or reloading usually fixes the problem… but not this time… this time after reload… whole speedtest thing has gone down…

Same issue for me. Upgraded to 2022.8.4 yesterday, same errors as @MaxVonEvil reported above. TBH I’ve never had much luck with Speedtest, it works for a random period of days/weeks then stops and needs a restart.

This integration has been shit for years starting and stopping continually. My script never misses a beat. Using the official speedtest CLI and MQTT to get the data into HA.

2 Likes

SO strange: Now it’s working again…
image

I do not seem to recall it being this unstable.
Could it be Ookla does not liking automated queries as HA does (I run at the default 60 min interval)

That said, anyone aware of any alternative integrations for fast.com or similar?

Hello David, I was wondering if you could share your config/script?

I found it, thanks for this :slight_smile:

See Speedtest Integration No longer loading - #42 by DavidFW1960

1 Like

I’ve now switched to the speedtest CLI on RPi4 (without MQTT) - Add the official speedtest cli - #40 by Britespark.

Seems to be working nicely, but will need a few more hours/days to be certain.

The reason I’m using MQTT is because it’s persistent across restarts without waiting for it to run again

I’m using MQTT for SONOFF devices without really understanding how it works…will have to put that on my learning roadmap :slight_smile: !

2 Likes

Thanks for sharing @DavidFW1960 - had a few hiccups setting it up but soon resolved and looks like a beautiful solution. So far has been solid which the integration sadly is proving not to be! Thanks again

1 Like

I’m finding that since the last update that I’m getting a permissions error in the Mosquitto logs - have you seen this?

2022-10-03 17:23:14: New connection from 172.30.33.0:41926 on port 1883.

and the following when I run the shell script manually

Error: The connection was refused.

No issues with the broker or errors for me

Thanks David - something else to go and bang my head against…

I’ve seen some people complaining about mqtt with latest update in another thread but it’s rock solid here.

1 Like

I restarted Mosquitto a few times and it’s working again :man_facepalming:t3:

No idea what was wrong with it

2 Likes