SPIRIT Z-Wave Plus

Hi

Anyone has SPIRIT Z-Wave Plus ?

https://www.eurotronic.org/produkte/spirit-z-wave-plus.html

I want to start zwave impletmentation at home and was thinking about this thermostat and Aeotec Z-WAVE Z-STICK GEN5 ZW090.

It this a good idea?

Hi,

I’m just trying to install such exact setup… I’ll let you know if everything works out, for now I’m having trouble to include the Spirit device into the z-wave network.

Thanks. Hopefully it will work.

I do have that setup running, but it required some work.

Mainly I had to move to the OpenZwave Dev branch, because the required changes were only merged to Dev.

Once you get it running these thermostats work just great in combination with Heaty.

I created this docker container (https://hub.docker.com/r/roflmao/docker-ha-eurotronic/) which just basically inherits the newest HA and adds its own branch of OZW with Eurotronic Spirit support.

You need to remove the node from your network before adding it with this image.

2 Likes

Thanks for confirmation.

I have 2 of these thermostats and would like to update my Hass.io system on RP3 with this docker package, but I am a bit of a beginner on Docker and understanding of how HA with Hass.io works.
Can someone help with instructions on what I need to do?

My HA is version 0.60.1; host os hassio version 1.1

Thanks!

Great to hear that your setup is running. I’m new to Home Assistant and I have just bought a SPIRIT Z-Wave Plus and a Aeotec Z-WAVE Z-STICK GEN5.

I have set-up a test installation of Home Assistant on my Laptop (ubuntu 17.10) in a virtual env (libopenzwave is on version 1.5).

The thermostat gets detected an I can switch between “Off”, “Econ” and “Heat”. Also the current temperature is displayed. However, I cannot set any new temperature values. Was this the same with your setup before upgrading to OpenZwave Dev branch?

Can you give me a hint how to go forward? Get the code from https://github.com/OpenZWave/open-zwave/tree/Dev and do ‘make install’? Do I also need another version of python-openzwave?

Thank you very much in advance.

Thanks for providing the docker file. I tried it with my own installation and can confirm that it works. :slight_smile:

At first I tried to mount my existing config to avoid removing the node from my network but this did not work. The behavior was actually the same than with my original installation. Then I tried it again with a plain config and it worked.

Since it took me some time to find out (how docker works and) how to run the container properly, here the command that I used:

docker run -v $HOME/HomeAssistent/config:/config -v /etc/localtime:/etc/localtime:ro --device="/dev/ttyACM0" -p 8123:8123 roflmao/docker-ha-eurotronic

However, it confuses me that my (single) thermostat is displayed as six different devices. Apparently each “device” represents one setpoint – 22°C (heat), 18°C (Econ), 28°C (?), 8°C (?), etc. Also I’m not quite sure whether the displayed current temperature is actually updated (regularly). I will have to keep an eye on that.

One last question. Why does the docker file clones https://github.com/tobiasgraf/ rather than, e.g., from https://github.com/OpenZWave?

I belive, because this is still not merged with the devbranch of openzwave as you can see here: Eurotronic Spirit Z by tobiasgraf · Pull Request #1387 · OpenZWave/open-zwave · GitHub

Anyone has a educated guess about how long this will need to end up in the master and then in official HA?
I’d like to know, because I don’t know if it is worth the hassle of installing the docker or just wait.

It seems to be merged into Dev by now

1 Like

Hi I’ve managed to create a docker image with the dev branch of open zwave .

I’m still testing around, but controlling the spirit seems to work fine. I can change temperatures and the spirit reacts almost instantly.
I’m not quite confident with the untested zwave version but until now it behaves as expected.

Ultimately, I want to deploy 10 spirits and manage them with the heaty component.

I’m using the zwave dev branch but haven’t been able to directly control the valve by setting the mode to “Manufacturer Specific”. Has anyone managed this ? Also, interested if anyone knows how to pair the unit with a z-wave temperature sensor so you can heat the room based on a centrally located sensor. The docs suggest both of these things are possible. The first would be great to allow direct HA control whereas the second provides more of a standalone solution.

Are you willing to share your docker image, I am in a similar camp; I have chosen to run with HaaS.io as i learn this platform. My plan is to replace an EvoHome installation which has 38 HR92 heads but is suffering some major issues with range, resulting in heating been demanded when its not needed, and in some cases, turning on and off my boiler after just 9 seconds of demand!

Heaty combined with some control logic for pumps and boiler will make a perfect fit, but the z-Wave portion is critical. Based on your docker file, I would like to see if i can customise a fork of the main Hass.IO image

thanks
Damain

Hi,
my docker file looks like this:

FROM homeassistant/raspberrypi2-homeassistant:latest

RUN apk update && apk add git make g++ coreutils linux-headers eudev-dev python3-dev python-dev cython python3 py-pip py3-pip build-base yaml-dev
RUN pip3 install --no-cache-dir python_openzwave==0.4.4 --upgrade --no-deps --force-reinstall --install-option="--flavor=ozwdev" -b /tmp/pyozwbuild
RUN sed -i s/python_openzwave==0.4.3/python_openzwave==0.4.4/ /usr/lib/python3.6/site-packages/homeassistant/components/zwave/__init__.py

There is room for improvement, e.g. the dependencies needed to build openzwave probably can be removed after upgrading openzwave.
So, far it seems to work.

Just to follow up here,
I did get the Docker option working, but with hotfix releases appearing quickly, this turned into a cat and mouse saga.

The solution i have adopted, and confirmed its working perfectly is posted here:

Thank you for sharing, Much respect
Damian

Yeah I know what you mean. have not upgraded HA since my last post :slightly_smiling_face:

The solution you mentioned is also more stable as it does not use other potentially unstable code from the dev branch. Although I have to say that I did not have any issues with Zwave despite this. I’ve probably been lucky…

Hi guys

I have just bought a spirit z-wave plus which has the same issue unable to set the temperature. I am running hassio using a raspberry pi 3b+ and raspbian stretch light. https://github.com/dale3h/hassio-installer/

I’m not really sure how to implement the fix you’ve done. Any chance you could help out a noob?

Do you have to update the trv firmware or is just replacing files in hassio?

Just need to add files to hass.io as I described above.

If you need a shadow find me on discord and I can host a share session to help. I’m in Ireland (GMT) and positive that 10 minutes during the day would sort you out

Damian

1 Like

thanks Damian

offer and help is appreciated.

ok I think I have followed your instructions correctly. However after reboot of hassio spirit still not working as expected.

when you say eject trv in your closing comment do you mean factory reset and re pair with hassio as this something I haven’t tried yet?. All I did is select remove node in hassio and then reboot.