Spotcast - custom component to start playback on an idle chromecast device

thanks, dirty trick makes it work again :ok_hand:

Can you please share the full file with the dirty fix? I was not able to change the original one…
Thanks in advance…

I believe you already got the file via the Github thread, correct?

Yes, correct… thanks anyway…

I just updated to new HA version I get a different error

Logger: homeassistant.components.hassio
Source: components/hassio/
Integration: Home Assistant Supervisor (documentation, issues)
First occurred: 9:13:20 (1 occurrences)
Last logged: 9:13:20

Component error: spotcast - cannot import name ‘KNOWN_CHROMECAST_INFO_KEY’ from ‘homeassistant.components.cast.media_player’ (/usr/src/homeassistant/homeassistant/components/cast/


Same here with me. Updated to 2021.4.0

Setup failed for spotcast: Unable to import component: cannot import name ‘KNOWN_CHROMECAST_INFO_KEY’ from ‘homeassistant.components.cast.media_player’ (/usr/src/homeassistant/homeassistant/components/cast/

Tried to find Spotcast in HACS to see if can reinstall but could not locate Spotcast nor it would allow me to add the repository saying it is already in the catalog.


I’m also seeing this exact same issue. I’ve tried uninstalling, reinstalling, etc.

It prevents HA from being restarted.


same for me…

same issue here.

Pychromecast has been updated to 9.0 with latest HA according to the changelog. Since spotcast depends on that, perhaps it needs to be updated too.

I don’t use spotcast anymore, so I’m not of any help, but wanted to drop this information.

Whenever a custom component has an issue, it’s worth checking on Github to see if it’s been reported, and follow the discussion there:

It’s pointless just adding ‘me too’ posts to clutter up this thread. And if you do go on Github, please just give a thumbs up to bug report unless you have something substantial to add.

For what it’s worth, the creator of the component is aware of the issues, but has quite understandably stated that other commitments prevent him from addressing them currently.


This fixed my issue. There are other fixes I didn’t try.

Cut and paste over the existing files in the custom components folder:

1 Like

The creator is very absent here too i think, its been long since he replied here… no offence though
Private life is more important

You uninstalled fondbergs version then? and installed this one?
What exactly did you cut and paste?

No, I overwrote the files from the HACS install with the new files in this repository. There is one new one, and all the existing ones.

from the github beta issue:

fondberg commented 4 days ago

Hello everybody.

Open source is great and free which in the case of just one person going the work (me) can lead to situations where during periods of sick leave or pressing matters elsewhere (work) thiings piles up.

I would urge you to put efforts into trying to help out by fixing things through pull requests rather than say something is broken several times and come up with arbitrary non version controlled patches.

I too noticed this is broken and if no one chips in i will try and fix it when i have time


You copied the .vscode folder too?

Probalaly not the best way, but thisis how I do it:

I use the visual studio addon.

open the file in github using the browser, select raw mode, ctrl-a, ctrl-c, switch to HA VS studio, edit the file, ctrl-a, ctrl-v

for new files, right click the folder, create new file, and type in the filenamme. Repeat as above.

check configuration (should show clear) then restart server.

sorry, I’m not good at explaining.

only copy the custom_components/spotcast directory from github to your HA .config/custom_components/spotcast directory

Worked ! thx mate !

1 Like