Spotify UI Configuration "Aborted"

I was setting my Spotify integration back up in a relatively new install but when I go to activate the integration via the UI I immediately get “Aborted”, that’s it.
I do have my Spotify API details in the config file like in the example

# Example configuration.yaml entry
  client_id: YOUR_CLIENT_ID
  client_secret: YOUR_CLIENT_SECRET

and the callback URL set to
This happens regardless if the details I entered are correct or not. Also I setup a fresh container and it seemed to work fine in that case.
Are there any other ways I can debug this or has anyone else had similar issues?

The translation for that error is missing, but in short it tell you to look here

Thank you, that got me much further. Spotify opens and I allow the application to connect but when it returns to Home Assistant I get a

500 Internal Server Error
Server got itself in trouble 

and in the logs:

Traceback (most recent call last):
  File "/usr/local/lib/python3.8/site-packages/aiohttp/", line 418, in start
    resp = await task
  File "/usr/local/lib/python3.8/site-packages/aiohttp/", line 458, in _handle
    resp = await handler(request)
  File "/usr/local/lib/python3.8/site-packages/aiohttp/", line 119, in impl
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 18, in request_context_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 72, in ban_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 127, in auth_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 129, in handle
    result = await result
  File "/usr/src/homeassistant/homeassistant/components/config/", line 160, in get
    return await super().get(request, flow_id)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 92, in get
    result = await self._flow_mgr.async_configure(flow_id)
  File "/usr/src/homeassistant/homeassistant/", line 156, in async_configure
    result = await self._async_handle_step(flow, cur_step["step_id"], user_input)
  File "/usr/src/homeassistant/homeassistant/", line 204, in _async_handle_step
    result: Dict = await getattr(flow, method)(user_input)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 270, in async_step_creation
    token = await self.flow_impl.async_resolve_external_data(self.external_data)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 149, in async_resolve_external_data
    return await self._token_request(
  File "/usr/src/homeassistant/homeassistant/helpers/", line 178, in _token_request
  File "/usr/local/lib/python3.8/site-packages/aiohttp/", line 941, in raise_for_status
    raise ClientResponseError(
aiohttp.client_exceptions.ClientResponseError: 400, message='Bad Request', url=URL('')

Any idea why that may be? I tried the solution to this topic, setting my internal URL also to the external but that does not appear to have worked.

For other readers both navigating to Home Assistant through my local IP and adding the external URL in Configuration > General fixed the initial error.

Resetting my client secret in the Spotify dashboard solved the latter issue.

1 Like