Ssh installed but not showing a config tab to change settings

New user to HA. Installed 2023.3.1 and official ssh add-on. ssh logs show that it is disabled but the Configuration tab for ssh says:

This add-on does not expose configuration for you to mess with…

So how do I change the default ssh port of 22 to say 622 so that it can start up?
Terminal is installed and works but shows really small font so hard to read.


Try this addon instead:

Tried community add-on and it won’t start or show me the config tab - logs says this:

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service base-addon-banner: starting
 Add-on: SSH & Web Terminal
 SSH & Web Terminal access to your Home Assistant instance
 Add-on version: 13.0.3
 You are running the latest version of this add-on.
 System: Home Assistant OS 9.5  (aarch64 / raspberrypi4-64)
 Home Assistant Core: 2023.3.1
 Home Assistant Supervisor: 2023.01.1
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
s6-rc: info: service base-addon-banner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service base-addon-log-level: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service base-addon-log-level successfully started
s6-rc: info: service legacy-cont-init: starting
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service init-user: starting
s6-rc: info: service init-ssh: starting
s6-rc: info: service init-mysql: starting
s6-rc: info: service init-mosquitto: starting
s6-rc: info: service init-docker: starting
s6-rc: info: service init-docker successfully started
s6-rc: info: service init-mosquitto successfully started
s6-rc: info: service init-mysql successfully started
[16:32:44] NOTICE: Session sharing has been disabled!
s6-rc: info: service init-user successfully started
s6-rc: info: service ttyd: starting
s6-rc: info: service ttyd successfully started
[16:32:44] FATAL: 
[16:32:44] FATAL: Configuration of this add-on is incomplete.
[16:32:44] FATAL: 
[16:32:44] FATAL: Please be sure to set at least an SSH password
[16:32:44] FATAL: or at least one authorized key!
[16:32:44] INFO: Starting the ttyd daemon...
[16:32:44] FATAL: 
[16:32:44] FATAL: You can configure this using the "ssh.password"
[16:32:44] FATAL: or the "ssh.authorized_keys" option in the
[16:32:44] FATAL: add-on configuration.
[16:32:44] FATAL: 
s6-rc: warning: unable to start service init-ssh: command exited 1
/run/s6/basedir/scripts/rc.init: warning: s6-rc failed to properly bring all the services up! Check your logs (in /run/uncaught-logs/current if you have in-container logging) for more information.
/run/s6/basedir/scripts/rc.init: fatal: stopping the container.

Came back to it today and the community add on is now showing as installed and now I can configure it so problem went away.