Stuck on "onboarding.html"

I’m trying to install onto Hyper-v and for some reason it just keeps getting stuck on the onboarding.html page, i have deleted and reinstalled several times but it stays the same. I have googled looking for an answer but just cant find any solution that fixes the issue.
I have also used numinous browsers and have cleared out cache

Has anyone know how to resolve the issue

Same here, different environment (fresh Debian + custom Python 3.10).

I moved forward by editing file .storage/onboarding: Added “integration” after “analytics” in “done” array


Fair play that did the trick… thanks a million

I’m facing the same problem since yesterday. I’ve install several times, try different configs, but without any changes. Please someone can help us? :frowning:

That worked for me too, thanks! Just curious, how did you figure that out?

Looks like the integration step is crashing in the browser. I am unable to reproduce this locally. If someone runs into this, please open the browser console (right click on the page → inspect element, click on console). There should be errors there that would help us out.

hi and thanks. please how can i edit this file? im beginner and install HAOS 10.x on HyperV

That’s the Error info from Edge broswer console

    at industrial.js:1:11558
    at 297d (industrial.js:1:11866)
    at n (industrial.js:1:110)
    at 3 (industrial.js:1:13701)
    at n (industrial.js:1:110)
    at industrial.js:1:903
    at industrial.js:1:912

Just a beginner myself…but will give a shot at describing what i did.

  1. CLI mode type: login
  2. Navigate to the storage folder. Below is where mine is
  3. cd mnt/data/supervisor/homeassistant/.storage/
  4. Then you need to know how to edit the file I used vi
  5. might be best just to create a backup cp onboarding onboarding.old
  6. vi onboarding and add in “integration” after “analytics” remember you need add a , after “analytics”

then restart Home Assistant

Thats what i did and it works


After registering an account, /config/. storage/onboarding file will be generated,image|551x283

Finally, add integration to the array and restart the service

Thank you!

@balloob - There is VERY little in the console that seems like it will help. After login, this is the complete content of the console:

Sending {type: 'frontend/get_translations', language: 'en', category: 'title', integration: undefined, config_flow: true}
connection-mixin.ts:139 Sending {type: 'usb/scan'}
connection-mixin.ts:147 Received {resources: {…}}
connection-mixin.ts:147 Received null
app.js:59 SyntaxError: Unexpected token 'H', "Home Assis"... is not valid JSON
    at JSON.parse (<anonymous>)
    at window.onload (app.js:59:731)

This is when running in Edge. The same behavior occurs in Safari, but the last SyntaxError in the console doesn’t show up, so I think it might be a red herring?

I’m running fresh clones (as of this morning) of both the Core and Frontend repos, and I’m running them both in a DevContainer Container Volume. For reference for others trying to do the manual workaround, the onboarding file for me was located in [root]/config/.storage/onboarding.

In my case I tried Chrome and Firefox. I had no JS errors, the websocket was open and seemed to be processing messages, but the page was static with just a header and background animation like on the screenshot above. No log appeared in hass log, nor with debug logging. Strange.

Something is probably wrong with the integration step of onboarding. By adding the string “integration” we are skipping this step.

We’ve identified the issue and it will be fixed in 2023.5.2. Thanks for the responses!

1 Like