Suddenly fail to connect to Android app

Hi there,
I suddenly lost the ability to connect to home assistant from the Android App on my tablet (Samsung Galaxy Tab S2 - Android 7.0). App version 2021.6.2-full, downloaded from the play store.
It used to work perfectly until a few days ago but now I receive a message during the connection:

Unable to connect to Home Assistant.
There was an error loading Home Assistant, please review the connection settings and try again. We will attempt to try another provided URL when you click on Refresh
OK

I tried to clear the cache, data, uninstall the app, restart the phone, reinstall from scratch, but I have the same issues.

The address of my HA instance and the credentials are correct - I tripled checked.
The same tablet can access the HA instance from the chrome browser without any issue.
Two other smartphone can access the HA instance from the Android app without any issue …

Edit: the error logs were irrelevant. I actually received them after intentionally typing wrong credentials for testing purposes. I actually don’t receive any notificaiton and there is no log entry when I receive the error on the Android app.

In the logs, here is the error I find:
> Logger: homeassistant.components.http.ban
> Source: components/http/ban.py:124
> Integration: HTTP (documentation, issues)
> First occurred: 19:04:11 (20 occurrences)
> Last logged: 19:39:56
> Login attempt or request with invalid authentication from xxx.xxx.xxx.xxx.blabla.net (xx.xx.xxx.xxx). (Mozilla/5.0 (Linux; Android 7.0; SM-T813 Build/NRD90M; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/91.0.4472.164 Safari/537.36)
This is actually my public IP address, but I never had any issue with that before.
The error also refers to a banned IP, but I don’t remember setting that. Especially since it used to work perfectly for months before that…

Any idea ?
Thanks !

Same problem. APP 2021.6.2-full installed on android 10 and it works. On two android 7 devices it does not work. Do you have any suggestions?

Same problem as of this morning.

I think it might involve Nabu Casa. I visited that site to verify that my trial account was still active. Once I logged in there from my PC, the app on my phone started working again.

No, it’s not related to Nabu Casa. I don’t have any subscription to this service. Your issue and mine can’t be the same

I actually restored a snapshot from two weeks ago and it fixed the issue

Sorry but you solved it by reloading a snapshot of Home Assistant or reinstalling the app. It still doesn’t work for me, despite several attempts.

Reinstalling the Android app never helped. I made several attempts at reloading a snapshot, and finally a one-month old snapshot worked. Newer ones didn’t work.
For your two android 7 devices, did it ever work and then suddenly stopped ?
Have you checked if you have an ip_ban.yaml file (or similar naming) at the root of your config file ?

I always get this in Home Assistant. Only with android 7, with recent versions of Android everything works.

Logger: homeassistant.components.http.ban
Source: components/http/ban.py:124
Integration: HTTP (documentation, issues)
First occurred: 19:08:42 (1 occurrences)
Last logged: 19:08:42

Login attempt or request with invalid authentication from xxxxxxx.lan (192.168.x.xxx). (Mozilla/5.0 (Linux; Android 7.0; HUAWEI VNS-L31 Build/HUAWEIVNS-L31; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/92.0.4515.115 Mobile Safari/537.36)

I also received such notifications, but as I edited in the first post, they appeared only when I actually typed a wrong password. Are you absolutely sure of your login credentials ?
Do you have IP restrictions set in the http component ?

With the same account I regularly open H.A. from pc. Until recently everything worked and then suddenly the app stopped connecting with both android7 devices while with android 10 it works.

For me it is a mystery. Maybe the aPP developers can give some answers.

It’s actually a mystery to me as well. My android 7 also suddenly stopped connecting without any obvious reason. I don’t understand why restoring an older snapshot helped. I would recommend to create a snapshot of your system now and try to restore an old one. You should also contact the app developers if that solution does not work - they would be able to give you more infos.

Could you tell me on which site or link to contact the developers? thank you

You can try on the official Android app thread : About the Home Assistant Companion for Android category
Alternatively, you can also raise an issue on the app’s github repository.