Supervisor 249 update makes my system unsupported

Tags: #<Tag:0x00007f3274635198> #<Tag:0x00007f3274635080>

Hi All,

Running HA for weeks without any issues of “You are running an unsupported installation” but since the update of Supervisor 249 from today… my system is a “You are running an unsupported installation” ???

How is this possible? I update my HA from different versions without any problem and since now im not supported anymore…

Problem is Network Manager:

20-10-21 11:06:47 ERROR (MainThread) [supervisor.core] NetworkManager is not correctly configured

The release notes explain why and how to fix it. You were running an unsupported installation before you just did not know it.

If you run Home Assistant Supervised, the system can get marked as unsupported if the host system does not have all the required services running. It was hard to find the reason why a system is marked as unsupported. It is written to the logs during startup, but the logs that you find in the UI do not go back that far. To make it more accessible, the message that your system is unsupported will now allow you to open a new dialog.

This dialog will list all the reasons why the system is marked as unsupported. Clicking on the links in that dialog will take you to a documentation page that describes the issue, and there will be a solution you can use to make your installation compliant with ADR-0014 and ADR-0015.

Unsupported does not mean non-functional.

3 Likes

Estou com o mesmo problema, vou aguardar respostas…

Bem-vindo ao fórum, por favor use o inglês, pois este é um fórum em inglês.

The instructions on your first post are correct, you should follow those and your system will be supported again:

The main reason is that the supervisor will now allow IP configuration through the UI, and for that it needs to be able to manage the network:

Well this is great but to install Network Manager you need a GUI and i am running Debian buster server.
So how do install Network Manager from SSH?

EDIT: Found it.

Run as root (sudo su):

curl -Lo installer.sh https://raw.githubusercontent.com/home-assistant/supervised-installer/master/installer.sh
bash installer.sh

Bit this will install the Supervisor only?

sudo apt-get update
sudo apt-get install network-manager

and then correct things as show above:

/etc/NetworkManager/NetworkManager.conf :

[main]
dns=default
plugins=keyfile
autoconnect-retries-default=0
rc-manager=file

[keyfile]
unmanaged-devices=type:bridge;type:tun;type:veth

[logging]
backend=journal

/etc/NetworkManager/system-connections/default :

[ipv4]
method=auto

[ipv6]
addr-gen-mode=stable-privacy
method=auto

/etc/network/interfaces :

source /etc/network/interfaces.d/*

auto lo
iface lo inet loopback

Did this fixed the issue unsupported installation?
Have same problem. I wanna enable network manager on wlan but its disabled in ncmi or something like that :frowning:

I Did this and it screwed my system up

I cant get to my HomeAssistant supervised and any of my dockers (Portainer , Node red).

Sorted it by doing this…

Yep same here.
I just restored my configured img to my USB SSD Disk, so everything is up and running again. Gonna check it out later.
Maybe someone else fixed the problem and is willing to share a howto? :smiley:

Ok i fixed my problem, this is how (for if anyone has same problem)
My problem whas (in new supervisor >= 249) i had no managed network interface(s)… but since 249 you need at least one.

Fix what worked for me:

sudo nano /etc/NetworkManager/NetworkManager.conf

And paste this:

[main]
dns=default
plugins=keyfile
autoconnect-retries-default=0
rc-manager=file

[keyfile]
unmanaged-devices=type:bridge;type:tun;type:veth

[logging]
backend=journal

Then (in my case had to connect it temporary using utp cable instead of using wifi):

sudo systemctl disable dhcpcd
sudo systemctl stop dhcpcd
sudo reboot
nmcli dev show wlan0
nmcli device wifi list
sudo nmcli device wifi con "YOUR SSID" password "PASSWORD"

But sill have a question… whats (the benefit of using) NetworkManager?

Im running HA in a docker on Debain 10 64B(beta). Running great for months now.
I’m little scare to to these steps… Don’t want screw my system and it become unreachable.

My system is running on WiFi. Here my config now of NetworkManager:

/etc/NetworkManager/NetworkManager.conf

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

/etc/NetworkManager/system-connections/default

doest not exist

/etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

/etc/network/interfaces.d

is empty

Then I read this: When it is installed, you need to make sure it manages at least one interface see the documentation for the network manager.

Checked the link but don’t understand how to do it for WiFi.

I never do anything with NetworkManager so its untouched then I read this: If you haven’t done anything manually with the network on the host, you should just re-run the convenience installation script.

So I can do the installer again but do I still need the at least one interface part be done?

Can someone assist me with this?

I’m also running Debian GNU/Linux 10 (buster) x64 on my RPI 4.
For me the only thing was to fix this i had to:

sudo systemctl disable dhcpcd
sudo systemctl stop dhcpcd

And then i lost my wifi connection… so in order to configure NetworkManager i had to temporary connect it using utp cable.

After that i could see my wifi networks:

nmcli device wifi list

And connect to the wifi using:

sudo nmcli device wifi con "YOUR SSID" password "PASSWORD"

Then rebooted my pi and disconnected utp cable…
And everything came up and running again :slight_smile:

thanks. I will try that on a moment I have the whole day… :slight_smile:

Its not possible to do it this way:

sudo nmcli device wifi con “SSID" password “PASSWORD"

sudo systemctl disable dhcpcd 

sudo systemctl stop dhcpcd

Then nmcli have already the wifi settings and when you disable dhcpcd the wifi will connected again correct?

Haha lol
That’s a good one… Let me know if that works please :smile:

Yeah i had yesterday a home assistent Day :stuck_out_tongue:

1 Like

I’ll let you know…

Or if someone tell us this will work or not :smiley:

There’s another related thread here: Supervisor 249: Resolution center, Stability & Private container registries

Following, as I just received this same ‘warning message’.

Personally trying to ascertain if it’s in the “If it ain’t broke don’t fix it” boat, or if it’s something I need to mess with…

What I don’t understand is why Network Manager is labelled as a required service? Being able to change the IP address from HA is a toy and definitely not required. I would never want to change the IP of my host from HA. So why is the supervisor bothering me with this stuff?

4 Likes

It is not a required service and your system is working normally, it just means the system is unsupported.

Why is it unsupported? Because the current supervisor is able to manage the network card which is really useful in default installation of Home Assistant OS and will use that acess to reference IP address for add-ons developers.

In short, it’s simple and not required, unless some new add-on pops up and use this new and supported way to get the IP for your HA installation.

More details here: https://www.home-assistant.io/blog/2020/10/21/supervisor-249/

1 Like

Does not work. Network-Manager must see the ssid and it do not show in NM until dhcpcd is stopped and rebooted the pi.

1 Like