Supervisor is unable to start because it can't download the Audio plugin docker image

Hi guys,

A couple of days ago I faced an issue with my Home Assistant. It suddenly stopped working. I tried to restart it a couple of times (sometimes it helped) but the result is the same. Supervisor can not be started and I can see the error on HA CLI saying “System is not ready with state: setup”

I checked the logs from supervisor docker container and it says that it can’t install the Audio plugin (can’t download the audio plugin docker image).
[supervisor.docker.interface] Can't install https://ghcr.io/home-assistant/aarch64-hassio-audio:2023.04.1: 500 Server Error for http+docker://localhost/v1.41/images/ghcr.io/home-assistant/aarch64-hassio-audio:2023.04.1/json: Internal Server Error ("layer does not exist").

I tried to remove the supervisor container, and changed the router DNS configuration (set DNS to Google ones, reverted it, tried couple more…).
I cleaned up the logs and temporary files to get some more space… Nothing helped.
I tried to run banner and supervisor repair commands. Still no luck.

Can anyone help me to resolve this issue? I don’t want to do a fresh installation because I’m not sure if everything is backed up properly.

I’m running Home Assistant on Raspberry Pi 4 model B.

There are 4 containers running:
aarc64-hassio-dns:2022.04.1
aarc64-hassio-cli:2022.11.0
aarc64-hassio-supervisor:latest
aarc64-hassio-observer:2021.10.0

I’ve tried to manually run the hassio-audio image there but I can’t do this since Docker returns same error. However, the latest image of hassio-audio can be successfully pulled and run. I tried to prune all the dangling images but the result is the same. When I try to pull hassio-audio 2023.04.1 Docker says that’s up to date but docker images doesn’t show it in the list of images…

Finally, I managed to fix this issue.

The issue was in a broken image data locally.
I did the following:

  • Tried to docker rmi https://ghcr.io/home-assistant/aarch64-hassio-audio:2023.04.1 - it failed but said it’s sha256
  • I used that sha256 and did the search of files and directories in /var/lib/docker. Removed image metadata by its sha256 hash
  • Then I ran docker pull https://ghcr.io/home-assistant/aarch64-hassio-audio:2023.04.1 it failed at the layer copying step (since the layer folder existed already). I removed that folder and then re-ran the command.
  • After that docker downloaded all of the layers of the audio image.
  • Supervisor was able to start after that right away.

Be careful with files and directories deletion :smiley:

Hi,
I think I am having exactly the same issue (see this question. Can you perhaps tell me how to recreate your solution from the CLI?
Sorry if this is a newbie question, I did not mess around with HA from the command line too much.

Best,
Phil