Supervisor November beta issue impacting users on Home Assistant beta/dev channels

Tell me where and we’re to report supervisor beta issues? I would think 2022.11.0 is not a beta?

In the supervisor github repo

Sorry, didn’t see this. IIRC it is.

Supervisor beta lasts a long time usually.

as dumb as this sounds after running the curl command and they system doing the download how should it react if it worked?

The direct keyboard and monitor connection method worked for me too…


Actually you can disable supervisor auto updates now. That’s why this fr is marked solved:

1 Like

Spent several hours earlier today trying to make it work with USB method with no result (re-formatted it several times, made sure I used Linux line endings and ANSI encoding - to no avail). Only direct keyboard and TV attached seem to have worked.

One thing I am still left confused about - since I joined a beta channel a few months ago (after another major issue with ZWave), I was under a strong impression that I still had the last say in what gets updated. I am 99% sure I rejected any and all updates over the last 2 weeks as I simply was way too busy with work stuff. If I was NOT a part of a beta channel, would this issue still have occurred? I was hoping I finally got everything up and running in a stable way and this one was certainly not what I expected…

Supervisor auto updates by default. You can turn that off if you want, see the thread in my post right above yours. But it’s on by default, the ability to turn auto updates for it off is a recent addition.

No. Stable channel wasn’t affected.

ok i might sound stupid for asking this it is asking for login and password when i use login command . is this HA login ID and passwordScreenshot 2022-11-22 at 6.35.44 PM

You appear to be doing this from the terminal in the VSCode addon. That won’t work, that terminal does not have docker access. Please follow the directions here to get access to a terminal which does have docker access to run this fix.

Just fixed it with monitor and keyboard attached to pi, no problem, just don´t forget to login first

what user ID and password do you use with this

There’s no username and password required for any of this. If you’re seeing a username and password prompt then you mustve done something wrong or be in the wrong place. Please follow the directions at the top.

1 Like

ok finally managed to get terminal access. but it was a lot of pain. I know some beta versions may get bugs but i think HA guys need to figure out an easier way to iron out a bug and not let a user specially who are beginners go through all this hassle. anyways opted myself out from beta tester. Although paul acknowledged the problem the solution should have been easier. lesson learnt: "Get the right Terminal integration into HA :stuck_out_tongue:

+1 - the observer was really unhelpful with this unfortunately; it feels like this should be where it shines!

1 Like

Thanks much,This worked great for me, I didn’t have a full backup so I used the script. All Fixed!!!

I used the curl command, it extracts and works fine but I stil can’t update the system. Add ons are not starting. The system is still a mess automations run poorly. And I did’nt install any beta, just 2022.11.0.
This is really frustrating…

That is the beta

Maybe this shows how big a problem not labeling the version number with a “b”? Another user bit but this.

1 Like

Disabled protection mode and the script worked a treat - many thanks.