Supervisor update 2021.06.8 to 2021.08.1 Failing

I’m being offered the update from supervisor 6.8 to 8.1, but if I click on it, it sits there spinning the blue circle over the update for a few minutes and then pops up this box:

If I try and access the listed URL directly in a web browser I get

{"errors":[{"code":"UNAUTHORIZED","message":"authentication required"}]}

Set-up is a Raspberry Pi4 running core-2021.8.8 under Home Assistant OS.

Aside from this error everything seems to be running correctly, and there’s nothing unusual in the log except this:

Logger: homeassistant.components.hassio
Source: components/hassio/
Integration: Home Assistant Supervisor (documentation, issues)
First occurred: 8:50:28 AM (1 occurrences)
Last logged: 8:50:28 AM

Failed to to call /supervisor/update - Update of Supervisor failed: Can't install 500 Server Error for http+docker://localhost/v1.41/images/create?tag=2021.08.1& Internal Server Error ("Get "": net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)")

which mirrors what’s on the pop-up. Is this just an issue with the remote server being unavailable, or something wrong at the local end?

Try restarting Home Assistant and update again. If the issue still persist, try clearing your browser cache.

Neither helped. Now getting a slightly different message that appears immediately:

Update Failed

Normally you don’t have to update supervisor, it updates itself.


I’ve always had to do it via the notifications in the supervisor dashboard, same as for Core etc… And it’s offering me the update that way as normal, see the background of the image on the first post.

It’s always worked flawlessly up to now for updating. Just this problem which started last night and is still ongoing. I’m still wondering if it’s an issue at the remote server end (or a DNS issue perhaps), given it’s a time-out etc.

My 3 running HA instances had supervisor updated last night, without me doing anything.

There is even a feature request

Check your DNS settings.

This is what I see with ha dns info

~ $ ha dns info
- dns://
- dns://
- dns://
- dns://
update_available: false
version: 2021.06.0
version_latest: 2021.06.0 is my pihole server, and i just added the server 0.200 (my router) plus the other two to give options and did a restart. Still the same error immediately…

And if I ping it seems to be resolving and working:

~ $ ping
PING ( 56 data bytes
64 bytes from seq=0 ttl=55 time=19.168 ms
64 bytes from seq=1 ttl=55 time=17.859 ms
64 bytes from seq=2 ttl=55 time=18.202 ms
64 bytes from seq=3 ttl=55 time=17.752 ms
64 bytes from seq=4 ttl=55 time=18.668 ms
--- ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 17.752/18.329/19.168 ms

Also just checked a couple of repos in HACS, and can install stuff from there.

I also confirmed on the PiHole, and the is a permitted site there (and indeed HA seems to be the main thing going through there):


Still enough diskspace ?

37% used, 17 GB free…

and if you do in a ssh shell

ha supervisor update --version 2021.8.1

Same error:

~ $ ha supervisor update --version 2021.8.1
Processing... Done.

Error: Update of Supervisor failed: Can't install 500 Server Error for http+docker://localhost/v1.41/images/createtag=2021.08.1& Internal Server Error ("Get "": dial tcp: lookup no such host")

I don’t know if it will work if you run HA OS, but maybe first :

docker pull homeassistant/armv7-hassio-supervisor:2021.08.1

If I add the DNS entry specifically into PiHole as a local address, it ends up with a 404 error instead

~ $ ha supervisor update --version 2021.8.1
Processing... Done.

Error: Update of Supervisor failed: Can't install 404 Client Error for http+docker://localhost/v1.41/images/ Not Found ("no such image: No such image:")

Nope, doesn’t work:

~ $ docker pull homeassistant/armv7-hassio-supervisor:2021.08.1
-bash: docker: command not found

But if I do ’ wget Package armv7-hassio-supervisor · GitHub’ , that works and downloads a file…

But it won’t probably put it in the correct place.

For docker pull to work you will need access to the host

I was meaning more that the file does actually exist and I can access it from the server, although I had to remove a : from the end of what was in the error message for it to work.

That SSH looks a bit complicated - will look at it after dinner. I’m wondering though if a backup and reinstall might be an easier route.

Just tried it, and I can’t get it to work. The server (HASS Pi) refuses the key.

That’s with a NTFS formatted USB stick with keys made with Puttygen, and the file authorized_keys formatted as ANSI and unix LF using Notepad++ containing the public key (with the private key used with port 22222 in Putty to access).

hassio su repair