Supervisor won't start in Virtualbox VM

This problem has been mentioned before.

Windows 11, Home Assistant v8.4, Virtualbox 6.1.30. I also tried the latest version of VirtualBox, same error.

Does anyone know how to troubleshoot this? I’m following the directions in the docs and the VM boots up and gets on the network just fine. But HA never starts, and the command line is pretty useless without that it seems.

Where does one begin troubleshooting something like this?

Try with ICH9, and two cpu

Screenshot_20220807-101540_Microsoft Remote Desktop

Tried ICH9, no luck. Still stays stuck at “Docker Application Container Engine”. It’s going on 22 minutes now…

Does anyone have the latest VDI image (8.4) working in VirtualBox? This doesn’t seem like it’s been tested very much judging by the flurry of help requests in the forums…

Ok I managed to fix this. The storage device had to be set to solid state drive in order to work.


but now there’s another problem. The home assistant observer page is loading fine. I assume this is some kind of health check/status page:

But port 8123 is not listening; I get a connection refused every time I try to connect. Nmap proves that the port is closed, but that network access to the host is fine:

❯ nmap -p 8123,4357
Starting Nmap 7.80 ( ) at 2022-08-07 14:04 CDT
Nmap scan report for homeassistant.lan (
Host is up (0.0030s latency).

4357/tcp open   qsnet-cond
8123/tcp closed polipo

Give it some time.
It is probably downloading stuff from GitHub and the like, which takes time.

How much time? I’ve let this thing run for over 20 minutes…

Rolling back to version 8.2 has fixed the issue. I have reported the bug for HyperV and VirtualBox here:

I’m not sure if this is the same issue, I just tried updating a VirtualBox VM from OS 8.1 to OS 8.4 and it now hangs on boot when trying to start docker and some other processes.

I’m running VirtualBox 6.1.30 on Windows 10. The VM was working fine at OS 8.1.

I see a kernel trace back but it scrolls off the screen, so I can’t see the anything but the partial traceback.

Any advice on recovering from this appreciated.

1 Like

I’m sticking with 8.2 until they get these issues resolved for virtual machine users…

I just tried v8.2, v8.4 and v8.5 and all run fine on Hyper-V (Windows 10 Pro) for me. I didn’t try VirtualBox.

I’m on Windows 11 and couldn’t get anything newer than 8.2 to boot up. I wonder if something changed between Win10 and Win11…

Please note that I used clean vhdx images for testing (so for example).

Can anyone tell he how to force a rollback to Hass OS 8.1?

I’m not coming up with anything useful via Google.

With HassOS 8.4, it seems like the docker engine never finishes starting up. It now gets stuck at Starting Docker Application Container Engine – says a start job has been running for 20 minutes.

Is it possible to force a rollback if the containers never finish starting up?

Can’t access the supervisor (4357), ssh, etc.

I can get a prompt on the 2nd virtual console (ALT+F2) - trying to do a docker ps hangs.

Note: I’m still running VirtualBox 6.1.30, because the Hass OS VM wouldn’t boot with 6.1.32, 6.1.34, due to a VBox bug.

Some screenshots until I can get logs off the VM:

Last boot messages

Last messages from docker.service and just journalctl -n

Was able to catch an “Oops” from the kernel during boot:

Ok - so I figured out how to during boot select the other kernel/os slot to fall back to HassOS 8.1.

I found the info about the backup kernel/OS in this page - Partitioning | Home Assistant Developer Docs.

It is a bit of a race doing a reset on VirtualBox and getting a keypress in on the boot loader before the system boots.

I also found out I could see which OS slot was booted by looking at /proc/cmdline and looking at runc.slot to see which one I was currently on when booting failed.

(I used the virtual console (ALT+F2) to get the login prompt so I could interact with the system, since none of the containers were running (so no ssh add on to ssh into).

I haven’t completed the steps to try to get ssh running on port 22222 per the OS debugging page.

Under VirtualBox when I try to use the device pass through to add the USB stick named CONFIG to enable ssh, I get an error from VBox about no USB ports for the VM. The VM config does have a USB controller.

Maybe I need to create a virtual disk under VirtualBox to emulate the USB stick named CONFIG

Ok, there was definitely some weirdness with HaOs 8.x and VirtualBox (win10, hyper-v enabled).

I was occasionally able to get HaOS 8.1 and 8.5 to boot, but it wasn’t reliable. If I told VirtualBox to just close the VM (no shutdown) and then start the VM from virtualbox it would come up, without the Kernel oops mentioned above and everything would start. Once it was running if I told the VM to reboot, it wouldn’t come back up, (kernel oops, dockerd wouldn’t finish starting).

Eventually I tried creating a new VM in VirtualBox, but reattaching my old VDI to it. All seems fine now. The default hardware configuration is different for the VM then when I created this VM. SATA controller is now the default, the old VM was using IDE.