Support for Aeotec Siren 6

How about first you read the whole thread, and then start asking questions, like the rest of us?

That is an excellent idea, thank you very much for that!
Did that and zwave2mqtt is not mentioned anywhere. What is it I am supposed to do to communicate with my zwave network via mqtt? “Use the MQTT api” - some api in OZW, how? @MarkoMarjamaa we are not all on the same level here - are you here to help?

scaarup, you were much more polite than many would have been!

I just got the siren assuming that since it was z-wave, it could be used with HA. I am so unfamiliar with any coding other than Fortran or Visual Basic, I really have no clue how to proceed with trying to use the siren\doorbell. I thought that Home Assistant was going to be much easier since it has a GUI. Didn’t realize you had to open up config files and make modifications to get things to work! I don’t mind learning some new things but I have spent $250 or more on sensors, a hub and a siren and spent 15 hours or more trying to get them all to connect with all the features they are supposed to provide and I still do not have a working alarm system! Very frustrating!

I did but altogether took me a week

Siren devices are not yet supported by HA.

New platform for siren/chime devices · Issue #375 · home-assistant/architecture (github.com)

I have now migrated from legazy z-wave to zwavejs2mqtt. Without me doing anything more, the siren was activated every time one of my door sensors were activated - pretty annoying, but still counts as some form of progress I guess :slight_smile:

So it seems like some of you have a working setup - maybe you have created an mqtt switch to turn on/off the siren? Could you please share?

I set up full support with ZwaveJS 2 MQTT. This NodeRed flow handles it all and you can use the self-turning-off switches in automations.

You’ll need to set your Siren ID and MQTT. You can then adjust your volumes and set your preferred sounds. This is my Node Red flow. https://pastebin.adamoutler.com/WNjkYsTAmi1QPZ1K

How to use:

  1. Set your MQTT login information in the pinkish-purple box on the far right.
  2. Set your Siren ID in the furthest right yellow box.
  3. do happy dance while you flip switches that work like buttons in Home Assitant.


    How to get your siren ID:
  4. Get your prefix from Z-Wave JS to MQTT settings
  5. Get/set your location and name from the Z-Wave JS 2 MQTT Control Panel.
  6. Your Siren ID for the purposes of this flow is : <prefix>/<room>/<name>/121
    eg. My Siren ID is zwave/Main_Entrance/Siren/121
5 Likes

I just implemented this solution and it worked like a treat! Thank you so much for this solution!

1 Like

Dude…this was such a helpful post! I tinkered around today learning MQTT and finally got triggers from HA to work. Woohoo!

Couple of questions:

  1. What is the easiest way to get a tone to play in a loop? Build out the loop in NR or is there a value that can be set in the flow to play in a loop?

  2. What is the best way to trigger an entity thought an automation?

Thanks again!

Jason

1 Like

The easiest way is to set the number of repeat tones in ZwaveJS 2 MQTT. Check the mfg specific settings. Alternatively, the emergency/security/environmental alarms operate on repeat.

Also, gimme a heart if you liked it. I love those things. :smiling_face_with_three_hearts:

1 Like

Done! Finally got the base config for my alarm setup using tonal pulse (28) on repeat and then siren for a triggered state.

As sirens aren’t supported, how have people implemented alarms in the past?

1 Like

I’m not sure. This sound switch is a new concept. I have a network-based beeper device that is tucked away on a board in a box in a closet as a part of my door/window sensors. I know there are zwave sirens that work. I don’t know how they work though. This isn’t just a siren, it’s a sound switch which is an entirely new class of device, and that’s why the community is struggling to figure out how to use it.

Although I’m pretty sure the intended use is a set of 8 switches that send payload 255(default) to the designated siren endpoint. This would place the configuration tucked away in configuration settings where it belongs and allow people to use a simple set of switches.

It has been fun to get reacquainted with NR and to learn MQTT. Now to figure out a constant crashing issue…

Thank you for your help!

Jason

1 Like

First of all, thanks a lot for sharing this, looks very promising. I’ll try it.

Questions:

  1. is the 121 value in your example specific to your installation? So we need to replace that with the specific id of the Aeotec Siren in our specific installation? Mine is 2 because it’s the only zwave device I’m using, besides the controller.

  2. Are the Switches automatically created or should we customize something to see them?

Thanks a lot.

  1. No. That’s the official zwave Sound Switch Command (0x00 0x79, aka decimal 121) from the Sound Switch specs, not the Node ID. It would have made sense to put it elsewhere in the flow, but it’s the one common thing to every interaction here so rather than duplicate it, I put it in the SirenID

  2. They are created from within Node Red. You need the Node Red integration.

Ok, I have the switches under the node red integration. They are all turned on by default. Is that ok?

I thought turning on the switch would execute the action on the siren and then turn it off. Tried it on “Single Tone” but it didn’t work.

How can I test if the integration is working?

Why are you showing me that instead of the actual lovelace switches? Once they’re working, they will turn off after switching on. If you have everything set up, then you will hear sounds. Make sure to set the MQTT login info. Make sure you’re using zwavejs to MQTT.

I showed you those just to tell you that I found the switches. Before configuring them in lovelace I wanted to test them.

It’s working fine now, I didn’t notice there was a default user/pw in MQTT auth, since I don’t use mqtt auth, I disabled it and it immediately worked.

Question: I noticed that the switch names don’t have any prefix, if I wanted to add one (the siren name would be ideal) should I change the two Name fields of the 13 entity nodes on the left of the flow (screenshot below) or is there a proper/cleaner way to do it? (e.g. switch.environment_siren would become switch.siren1.environment_siren). I would like to do it both for having the switches grouped together and to recognize them immediately from the names and also in case I wanted to install a second siren, to distinguish the switches among the two.

Thanks again for sharing this, finally I can put the Siren to work.

@adamoutler thanks for sharing your approach, heart given!

I’m new to homeassistant and mqtt/node-red. Just setup mqtt and node-red (addon as well as the integration), and now the default lovelace shows the siren switches. But when I turn on the switches nothing happens (except immediately turning off, with the exception of “browse siren” which remains on). I’ve tried to check the node-red debug window, the mqtt logs, and zwavejs2mqtt debug windows, but I didn’t find anything interesting. Any hints as to how to debug? In node-red the purple box shows connected, and since the node-red integration is able to find the siren, I suppose my mqtt login and the siren id are both correct.

Cheers!

1 Like

Sounds like the problem is your siren ID.

There’s a program I use called MQTT Explorer. Connect it to your MQTT and then restart your ZwaveJS 2 MQTT and see if your siren matches the path you typed.

Here’s mine after sending the browse sound. You’ll need to surf around and see if the values match or not. You should be able to find a 121/1 within one of the items on your Zwave network.

Note in MQTT Explorer, I’m looking at the set value, which changed the toneId value. You won’t have Main_Entrance/Siren/121/1. yours is somewhere else. Use MQTT Explorer to find it. It’s a big forest.

If you can make your siren ding from within ZwaveJS 2 MQTT, you can follow the flashing on turn-on and turn-off to find it.

1 Like