Support for GE Appliances (SmartHQ)

I own a GE Profile Electric Range and have been looking around for an Integration for Home Assistant but there seems to be none. There is some excellent work being done here: ajmarks/gekitchen: Python SDK for GE smart appliances (github.com) but it seems there some entity types missing.

I think that SmartHQ Home (smarthqsolutions.com) covers some others sub-brands so it would be a good integration to have.

Hi there! I’ve actually forked Andrew’s repository and a new version can be found here: GitHub - simbaja/ha_components: Custom components for Home Assistant. We’ve added a bunch of new entity types (dishwashers, washer/dryer, additional oven controls) and are working on filling in more right now (e.g. Advantium).

Hope that this helps you, and feel free to submit new feature requests over on the github project. We hope to ultimately merge things together, but haven’t figured that out fully yet.

3 Likes

I’m new to HA (Installed it today) and I’m unclear how I add your code into HA. Can you point me in the right direction? FYI, I’m running HA in docker.

You may want to use HACS and install the above link as a custom repository. Alternatively, you can copy the custom component directly into your custom_components folder in the config directory. You can then add the integration through the integrations screen using the normal methods.

1 Like

Ok cool. I’m running HA in docker. I assume it will work?

Thank you for the HACS idea. I was able to get it installed. I have a GE Cafe stove that’s connected to my network. Will HA automatically recognize the device?

I’ve been following along and had the same questions! After I installed with HACS, I wasn’t sure what next either. I was able to get my washer and dryer working last night.

This link should actually take you to your own integration and start adding it

OR

Manually - you can navigate to “Configuration > Integrations”, then click “Add Configuration,” search for “GE Home” then add the integration and input your sign in credentials for SmartHQ / GE.

The integration was able to pick up both devices automatically like most other integrations.

1 Like

I was able to get it working. Once I installed HACS, I started it hitting buttons at random and found where to add the ge appliance repo I wanted to use. From there I was able to see the ge repo in integrations. It fired up and recognized everything. There are some errors, but everything seems to work. The key is to click the 3 dots in the top right of the hacs screen and choose “custom repositories”. Then you can paste the git hub repo URL into there and bingo. From there, that repo should show up in the integrations screen.

Hi guys,
Thanks for sharing this. I was able to install it using HACS and it discovered my washer and dryer automatically, and all theirs entities.
The only thing is an “Failed to Set up / Check the logs” error showing in red on it’s card at integration page. Besides of that, everything being working fine.
Screen Shot 2021-07-05 at 2.26.12 PM

Somebody got the same error?

Screen Shot 2021-07-05 at 2.31.04 PM

I have a general electric conditioner and works with smarthq, but is a very very bad app.

How can i integrate in home assistant?

https://products.geappliances.com/appliance/gea-support-search-content?contentId=37108

Say that homekit is supported but home assistant never discover my conditioners

Only some GE window AC units support homekit. If yours does there will be a sticker on (I believe) the right side of the unit with the following info:

  • network name
  • password
  • mac id
  • homekit code (if supported)

i have this product NIG25IN-20 and every ge air conditioner, not only windows unit, are homekit supported, in according to Smart Air Conditioners - Apple HomeKit

Infact if i reload homekit plugin in Home Assistant, i can see homekit code and qr code

I tried to associate it in homekit, and stuck on add devices.

maybe device need to be on i guess?

I have this one unit and i bought a wifi pen.

Senza titolo-1 copia

This issue has been fixed in later versions. We’re revamping some of the washer/dryer support so hopefully will have more features soon.

The last screenshot is the one that confirms that this device will work with the framework we’re developing. If you have a little time, we’d appreciate your help over at GitHub - simbaja/gehome: Python SDK for GE smart appliances to get started with supporting these devices. Basically, the first step is to run the SDK and get the list of options the device is presenting. Once we have those, we can work through interpreting them and then integrate them into HA.

2 Likes

Hi,

I love it! Yeah of course, now i’m going into github and learn how to help you

Hopefully we’ll see you over on the github project! In general, the GE appliances work through reading/writing “ERD” values that correspond to properties of the device. We’ve got the framework built such that we can read all ERD values even for unknown devices, so basically if people with devices can get the simbaja/gehome project working on their local machine, we can see all the properties we have to figure out from the debug log that’s generated. From there its a bit of trial-and-error until we get things right.

I have installed pip install gehomesdk in my home assistant, just i didn’t understand now, how to proceeded

I have installed the GE Home plugin VIA HACS and the integrations tab. Entered credentials and got the “Success” note. However I also am getting the “Failed to Setup. Check the Logs” on the integrations card. Never found any of my appliances or devices.