Support for Mysa thermostat

In this blogpost, Mysa claims to be compatible with several home automation devices.


I just got mine, and I really like it. (I’ve got the ye’ olde timey forced-fan in-wall heaters - so this is pretty much my only option). It integrates with Alexa and Google home easily.
As far as integration goes, I emailed them, (5-13-18) and they have no plans to support it. Although, on their product roadmap they plan to support IFTTT in May 2018 and Smartthings in June 2018. I’m using the Smartthings MQTT bridge, so I’m going to give that a try.
They’ve got a release timeline in a blog post, but as of this posting it’s a few months out of date, so I’m not sure how accurate it is:

Did you had success with the Smartthings MQTT Bridge ?

The Smartthings integration has been delayed. The Mysa devs had the integration ready months ago, but they got hung up on waiting for Smarrthings to approve the integration. Smartthings is changing the integration approval process because they just launched the v3 hub. Smarthings will be rolling out their new approval process at the Smartthings developer convention, which is November 7th and 8th, 2018. (yep -that’s today!) Once the Mysa people know what the new approval process is, they can put together a new estimate for Smartthings integration rollout timeline. Here’s where I’m getting my information:
A developer for Mysa left a comment in a Smartthings thread.
Mysa released a revised roadmap. The ST delay is mentioned by a developer in the comments.

Have you heard anything more? I just saw the Smartthings integration is live.

The Mysa Smartthings integration was approved for the New Smartthings App! It’s important to note, there are actually two Smartthings apps, the New Smartthings app and the Smartthings classic app. Currently, only Smartthings Classic integrates with, and that’s done using the MQTT Bridge. Mysa has no plans to support the Smartthings Classic app. (I don’t think they could even if they wanted too - because Smartthings doesn’t appear to be approving new devices for the Classic app)
However, I just got wind of a component that supports integrating the new app.. I think that component is slated for the next release - but I’m not certain. Reading the docs on that page, it requires remote access to your instance - but you can’t use a self-signed certificate. I think the standard duckdns config uses a self signed certificate, so it looks like it’ll be a pain to setup, at least initially. (I could be wrong on that - if i am, please let me know!). It also only supports fan, light, switch, and binary sensor at the moment, but I expect that support list will grow.

Would also be interested in a component for Mysa

It looks like the new Smartthings component that launched yesterday is for the Classic app. There’s still no way to connect Mysa to

I’ve got Mysa working through the Homekit Controller component. It displays the current temp, and allows you to set a new temp, but I can’t figure out how to get it to display the current set temp.

1 Like

I also have a bunch of Mysa’s, and am very interested in getting them working in any Home Automation Software. Ideally, it would be nice if they just gave us a Direct API to use.

That said, a couple months ago I did try to Homekit Controller component, and was able to add them to It didn’t feel like the cleanest solution, but it did show the current temp and I was able to set the temperature. It did feel buggy though, and not “smooth” (maybe all thermostats fell like that in HA?)

What it didn’t do, was give access to the Humidity Sensor, or the Light Sensor (brightness of the panel). Or the DisplaySetTemp. Unsure if all those are even shown through the normal Apple Homekit integration.

Anyone have better luck with integration? Or perhaps some other software that they integrate better with? Would be appreciated. Else maybe fiddling/improving the Homekit Component to support humidity sensor and light sensor for a thermostat object may improve things with HA & Mysas.

We have to find a way to put pressure on Mysa or connect…

I’ve been fussing with Mysas since they launched, and despite the initial complaints, I’m super happy with them now. I used to have 3 Mysas connected via the Smartthings integration. The Smartthings integration wouldn’t let me change setpoints, it only gave me sensor data, so it wasn’t very helpful.

When started detecting the Mysas as a Homekit integration, I tried pairing them that way. (I had to unpair them from Smartthings, reset the thermostats, remove them from the mysa app, then re-add them to the Mysa app to get the Homekit Hassio integration to pair properly). If you don’t have to un-pair your Mysas from another system, the initial setup should be easy. The Homekit integration auto-detects new devices, so you don’t even need to modify configuration.yaml to have the system see these, everything is done through the integrations page. During setup, adding the dashes to the Homekit pairing code caused me some trouble - but I think they have a format example on the integration setup page now.
Once I got them connected via Homekit, they’ve been fantastic.

When you integrate via Homekit, it creates 2 entities, one is climate.<name of your mysa> the other is light.<name of your mysa>_light. The light entity lets you turn on/off the display, and set brightness. This is controlled like any other light.

The climate sensor is the part that deals with heating. You can pull the temp, humidity, and setpoint data from the entity. When you initially add the thermostats, they don’t create separate sensors, but the data is there. (You can see that this data appears as entity attributes when you look at the Mysas at developer-tools/state).

Here’s what my entities look like for my office thermostat:
11 AM

Here’s what I’ve got in sensors.yaml to setup that climate data as individual sensors:

# Mysa thermostats   
  - platform: template
        friendly_name: "Office Temperature"
        unit_of_measurement: "°F"
        value_template: "{{ state_attr('climate.office_thermostat', 'current_temperature') }}"
  - platform: template
        friendly_name: "Office Humidity"
        unit_of_measurement: "%"
        value_template: "{{ state_attr('climate.office_thermostat', 'current_humidity') }}"   
  - platform: template
        friendly_name: "Office Setpoint"
        unit_of_measurement: "°F"
        value_template: "{{ state_attr('climate.office_thermostat', 'temperature') }}" 

You can use automation to change the setpoint. Here’s an automation I use to turn down the temperature when I leave the house:

- id: '1572982291659'
  alias: Heaters off when everybody leaves
  description: 'If all people are away, set the office thermostat to 64 degrees'
  - entity_id: input_boolean.present_mode
    from: 'on'
    platform: state
    to: 'off'
  condition: []
  - data:
      entity_id: climate.office_thermostat
      temperature: 64
    service: climate.set_temperature

I use the lovelace climate card to add the thermostat to the frontend:

At this point, I think we’ve got full Mysa integration. If anything, they need to put up a blog post about integration so people don’t have to muck about trying to figure out the best way to integrate.


Since it uses HomeKit, do I need a Apple product? I don’t own any.


This is fantastic information! Thank you so much for taking the time to write up everything. I’m going to grab a few thermostats and try it out as well.

Good question - you definitely do not need an apple product to use the hassio homekit integration. I don’t have homekit configured on any of my apple devices, the Mysa integration in Hassio is the only place in my home that I’m use the homekit features.

Awesome! Yea with the HomeKit integration, the Mysa’s are “almost” perfectly supported by Home-Assistant now! Be nice if it automatically set the right HVAC modes, but that’s fine. Very exciting.

Some small issues, but the main one I have right now, is that sometimes the Mysa Thermostat (in HA) will “hang”. It kinda locks its state and doesn’t change. The Mysa still works fine, and shows the right temperature on the wall. It just won’t update the state in HA. If you look in the temperature graph, you will see the other mysas going up and down, but the “hung” mysa will just be the same temperature (straight line). I assume this is some HomeKit error which get hung up on some update value and freezes or loops. I notice this happens more regularly if I change the Mysa manually on the wall (or through the Mysa App), while if you just change it through HA, it won’t get into this “hung” state often, where HA still shows the entity, but doesn’t update or can’t control it.

Anyway, not a big issue, it’s easily detectable (if the temperature has been the EXACT same temperature for 1 hour, it’s likely in this state). And to fix it, I just go to INTEGRATIONS > DEVICE > and then I “Disable” the climate.mysa device. Wait 1 min, then I re-enabled it, and it’ll update and HA can control it again.

I can do this through the GUI fine. But my issue is I can’t seem to find where I can Disable / Re-enable an entity within an Automation… anyone know how I can do this? I see no service or anything which allows me to disable an entity (even though I can do it through the GUI fine…).

I just want a way where I can disable/enable the entity automatically, so I don’t have to go through the GUI every day disabling/reenabling all my hung Myas’s.

Just an FYI I have 5 of these thermostats and received the 5th for Christmas. Thew new version shows a v1.1 compared to 1 on the previous. I am able to add the climate.mysadevice, however the light.mysadevice does not show up via HomeKit anymore. Wondering if anyone else has a new Thermostat that is seeing the same

Has anyone been able to get the energy usage feature integrated?

I am trying to add my Mysa and you mentioned

During setup, adding the dashes to the Homekit pairing code caused me some trouble - but I think they have a format example on the integration setup page now.

I can’t figure this out!! My QR reader shows the following:


Can you give an example what the “pairing code” should look like?


Figured it out… I was reading the QR Code but it’s the ACTUAL NUMBERS printed beside the QR Code… (faceplant) I’m done for tonight, but I suspect I may have more questions :stuck_out_tongue:

I’m doing a full write-up BTW, but it’s a WIP ATM.

1 Like

Thew new version shows a v1.1 compared to 1 on the previous. I am able to add the climate.mysadevice, however the light.mysadevice does not show up via HomeKit anymore. Wondering if anyone else has a new Thermostat that is seeing the same

I am showing/having same thing. No light option.