↔️ Swipe Navigation

thanks this is great! it does conflict a bit with the custom:plotly-graph card, where swiping is used to scroll left and right on the graph. Is there any way around that?

@mayker So, I see this repo is archived. Does that mean it’s been integrated into HA core or was shut down for some reason and will no longer be maintained?


Means maykar has lost interest in it

1 Like

Quite the opposite actually, there is nothing I enjoy more than making and improving these projects. But I am currently unable to devote the time and attention needed to keep them going on my own. I haven’t updated any of my projects in about a year and I’d rather it be apparent that they aren’t being worked on so that other’s may fork, improve, fix, etc. I didn’t want them to just fill up with issues and pull requests that I am not currently able to attend to.


So, do I need to just remove this from my HA until someone else picks it up or just keep using it (as long as it works for me) and just live with these notices in HACS?

If you have your own GitHub(or make one), fork this repo, add your fork to HACS as custom repository, delete the previous one, install the one from your fork. Did this last night to just get rid of the notification and it worked perfectly.


Thanks! Worked like a champ!

1 Like

Or just click on show then ignore

1 Like

just remove from HACS and install manually.

That’s sad to hear - and totally understandable at the same time.

I hope to see someone picking up this great project and bringing it back to HACS. Seems there are already more than 30 forks. So with a bit of luck someone steps up, hopefully by posting in this topic.

Until then, Lovelace Swipe Navigation - #180 by afxefx seems to be a proper temporary workaround.

Is this a permanent “solution” or will those warning come back?

If you want, I forked the project and fixed almost all issues and pull requests in the original repo. :tada:
Feel free to test it and drop a :star: on GitHub.

I’m waiting to be added to the official HACS “store”. It will be ready as soon as this pull request is merged.

I’ll try to continue developing it as much as I can, even if I don’t have much spare time.

And thank you very much @mayker for all your amazing work. It was easy to understand the code and modify it. If you’ll ever want to continue the development, just contact me.


Awesome! Thanks so much for picking this up, I very much appreciate it and I’m sure many others will as well. Looks like it’s in good hands, nice work. I also must apologize for the spaghetti code.

There is one feature that I never got around to adding that may save you time in the future:

A config option for adding exception tagnames and classes. This way if anyone finds or creates another element that this interferes with, they can just add the exception themselves and not have to worry about it being added to the project right away or at all.


wow, thanks @Zanna_37 amazing effort indeed!

(almost dare not ask, but did you also have a look at Kiosk mode…? ) :wink:

no offense Ryan, glad to see you around!


Not at the moment, I might consider it in case an home assistant update breaks things, or in case I find ways to have more free time. :wink:

I use kiosk mode myself, so I don’t rule out the possibility of maintaining it.
However, time is always scarce in life and for now kiosk mode is working decently for me. I decided to revive swipe navigation because there were some issues that needed to be addressed.

Home Assistant Swipe Navigation is now officially available through HACS.
Give it a go! :wink:


I get the thing about not having the time, but I’m hoping you or anyone can fix this kiosk mode error:

/kiosk-mode/kiosk-mode.js?v=1.2.1:13:44 Uncaught TypeError: Cannot read properties of null (reading ‘shadowRoot’)

Hello everyone. In my case I have the dashboards configured in an unusual way. When I want to integrate these lines it says: “Integration error: swipe_nav - Integration ‘swipe_nav’ not found.”

When I check if the js is loaded I see that it is ok. I really don’t know if I’m doing something wrong.

I did the installation by hacs and add the js in configuration.yaml

Thank you

  wrap: false
  animate: swipe
  skip_tabs: 5,6,7,8
  prevent_default: true
  swipe_amount: 30
      mode: yaml
      title: Tablet_10_PRO
      icon: mdi:city
      show_in_sidebar: true
      filename: ui-lovelace.yaml

      mode: yaml
      title: Ipad-Mini
      icon: mdi:fish
      show_in_sidebar: true
      filename: ui-lovelace-acuario.yaml

Swipe_nav config should be in those two ui-lovelace.yaml files, not configuration.yaml

Okay. But I don’t understand then if this does what I want. Would I have to put this code in all the yml? Because each dashboard that I have is in different files.