Kiosk mode

I just redownloaded it from hacs and it work fine after that for me.

1 Like

firs of all excuse my english.

I´m trying it but i can´t do. i have installed in www the .jsn archivo from github. the location of www is at config/www.

after this i have followed the instructión of Servicexp but i don´t konw if the url where i am trying to intall it is the correct. Any help?

1 Like

Does anybody know what happened? Kiosk Mode is an extremely useful front end add on. I did re-add it manually, I’m just afraid it will now break over time…@maykar, what happened?


Hi Andy,

I’m also using kiosker in combination with the above wallpaper kiosk script. Somehow, after adding the configuration, I receive the wallpaper etc, but my sidebar is still displayed. Do you know where I should look ?



In the settings (Profile) of the logged in user you can hide sidebar elements or the complete sidebar.

Please don’t tag people, if you don’t have any specific request (meaning you could have found the answer by simply searching) or are advised to. It just ruins the tagging feature. :slight_smile: Thanks a lot.

And here is your answer, found be searching for the last post @mayker made a few weeks ago, in answer to why his repos are all archived:


Is there an option to specify a user like Kiosk Mode? I don’t want my sidebars & headers hidden for all my users, just my wall tablet users.

1 Like

Thanks @anon94216691, but we can’t hide the ACCESS to the the sidebar, right ? When I hide the sidebar, people can ‘expand’ the 3-lines and view, change, delete



Hi, Sireone. Thanks for pointing this out. I just got this up and running. It seems to work well, but requires a tap to the screen to bring it to life. Have you got this working with motion detection? Seems like a near-perfect solution.

It was actually simpler that. I use WallPanel for the tablets. In the URL, I simply add ?kiosk at the end and the sidebar/header is removed for that user only.

i use walpanel for android with the kiosk mode from hacs, works out of the box.

walpanel can be the home app on android devices. its menue can be code locked.

it supports video streams, but that does not work reliably. it handles post and mqtt commands, can speakt and for screensafer it can dim, pcitures websites or off and motion or face detection to trigger it to start again.

this in combination with the kiosk mode with the kiosk true setting is about what i want as a kiosk panel.

if you dont know the code, its almost impossible to brake out of that. even if you know, you may make it to the android settings, and such, but you cant open other apps or change stuff in ha.

one thing, both apps are not activly maintained right now. but as long as it works, i dont care.

Is this integration still active? It appears the new 23.04.01 has broken it on my setup. Anyone else experiencing the same thing? I could switch over to browser mod, but I prefer this implementation much better.

1 Like

As you can see, the last update is from Oct 2021 (GitHub - maykar/kiosk-mode: 🙈 Hides the Home Assistant header and/or sidebar)

With Browser_mod you can hide the header and sidebar.

I’m also experiencing problem after upgrading to 2023.04.x. I see the following error message in the logs that might be of any help, for a trained eye.

ERROR (MainThread) [frontend.js.latest.202304061] Uncaught TypeError: Cannot read properties of null (reading 'querySelector')

Acording to a discution under:
Hide title bar / black bar at top (That also links to this solution with Kiosk mode)

The post from [diamonddrake] posted 6. April, has a link to a temporary fix for a updated kiosk-mode.js file:

Tried to replace my kiosk-mode.js, but I seem to still have the same problem…


Got it to work for me.

After updating my kiosk-mode.js in my www folder, I had to go to “Configuration/[Lovelace ]Dashboards”. In the top right corner, click the “…”, and choose Recourses. I found my old kiosk-mode.js line, and updated it with the version number I found in the new kiosk-mode.js to image


Well done. This worked for me as well.

Thank you.

good find. thank you!

I had an issue as well since the new update, but all i had to do was uninstall kiosk mode and re isntalle it again and voila!!!
Thank you Guys!