Switchbot Curtain

@elevate377 , no, I don’t have any other “cover” entry; Anyway I did remove it, restarted like you suggested, but the error re-appears once I added it back.

Maybe I put the files in a wrong place?


Try all high caps for your mac address. Remove the ( ) in name entry.

mac: DB:A5:E7:66:B4:C9
name: Brinquedoteca

Anybody else running HA on a NUC? I’m at a loss here… :frowning:

I have the same message, but the integration works with my system. So maybe try to open the cover?

EDIT: Solved! Just had to re-enable the ‘Wifi’ setting on PC Bios ( I didn’t realize the same board does Wifi AND Bluetooth). All working now! Thank you all for your support!

@upzidedown , @duceduc, thanks a lot, I applied what you suggested, and I think the integration now loads, as I could add the new entities to the dashboard. But something looks wrong with the bluetooth setup in my Hass server.

I’m now getting this:

and this:

@alextud , do I have to install any specific bluetooth libraries? I don’t use HassOS, this is Home Assistant Supervised install on my Debian server…

bluetoothd service is running at least:

There is an outstanding set of commits for this project that stem from this fork:

Do yourself a favour and switch over to that branch. It gives you battery life and current position as well being able to add the devices from the GUI Integrations section. It also has way better reliability.

I’m hoping @alextud pushes the commits so they can update through HACS soon.

FYI, you will have to delete your manual configuration.yaml entries before you do the setup in the GUI

1 Like

Hello guys! I’ve bought a pair of this “tuya switchbot curtain”:

Any idea if this integration works or if there is another alternative to integrate them to HA?

Anybody else running HA on a NUC? I’m at a loss here. I really don’t know how to troubleshoot my setup… :frowning:

Quick summary: Everything seems to work just fine right after a fresh start of my HA. But if the system has been up for a while (I really can’t tell when that starts to happen), this integration is unable to trigger my switchbots…

Any idea?

Use the original one, not ReinerM26’s repo. Seems there’s a bug in there or it’s just doesn’t play nice with NUC (have the same issue). The original one’s (well, you have to use it with a commit from early March) is just works well (only downside: it won’t report the battery status and I think it’s not possible to set position - not a problem for me as I only use it for opening and closing the curtain).

Hopefully the NUC bug will be fixed someday.

1 Like

Hi there @Lukacs_Attila and thanks for this valuable information. Could you please point me in the right direction? What should I do in my HACS then, replace the repository only?

I opened an issue in GitHub. Maybe this way I get some attention to this problem that way.

Thanks a lot again!

It’s super easy. Remove ReinerM26’s integration, and install Alextud’s version (it’s available on HACS). Then go to alex’s github and download this commit: GitHub - alextud/ha-switchbot-curtain at f31b68788c65d891afb0ea22807c1bd40adba35e (click the green download code icon).

Then you have to copy and overwrite the integration’s files with the downloaded ones (it’s best to delete everything in the custom_compononents/switchbot-curtain folder.

Thanks! I will test this next weekend! Awesome!

@Lukacs_Attila I finally managed to find some time and get to this. However, before I start and break something, I thought I would check in with you first. The integration that I have installed in HACS is this one:

Screen Shot 2021-07-25 at 09.28.44

I would say that I’m already on the version that you are suggesting for me to move to. Correct?
Also, if I follow your link the intallation information seems to suggest that this packet needs to be desployed on the configuration folder and not through HACS, right?

Sorry again but I really want to make sure I don’t ruin my installation. In the mean time I went ahead and opened a new issue in Github


Yes, exactly. Just follow the link I sent you and replace the content you find in the config folder with those you download from the link. Restart HA and you’re set (don’t forget to set the bot’s MAC address in the configuration.yaml).

Hi @Lukacs_Attila , after (hopefully) following all the steps above and leaving my NUC for 3 days on, I’m afraid I can’t report any success with my integration between curtainbots and HA. I just tried to close my drapes now and nothing happened. I then went ahead and restarted HA, clicked on the button, and voilà, the curtainbot started closing the drape immediatelly upon clicking the button.

I have not seen any activity yet in the issue that I created a couple of weeks ago in Github. I’m at a loss. It would be greate if somebody could help me troubleshoot what is going on. Any idea on how to debug what is going on at a “wire” level?

Thanks in advance!

I am not getting any communication with the curtain bot from my Nuc :frowning:

Have you enabled bluetooth at all in the BIOS?

1 Like

Yes. I just tried this fix above for adding an earlier version, and now it is connecting. I saw that there is a pr in review for changes too. Will try those later as well.

yeah, that’s my fix. As for the PR in review, I had no luck with that.

1 Like

Hi, I installed this commit and a single curtain works fine, open close and stop. But I have a double curtain that opens to the middle (two switchbot curtain bots linked together) opening and closing works fine, but stopping only stops the left curtain. Is there anything to do about this?