Switches not sending power-state (neither actively, nor polling

Hi all,

I’ve got a setup that was working sort of fine under domoticz, and running shadow (i.e. mqtt passing through states) to HA for some months -> now switching over to a complete fresh HASS setup on a different PI and different zwave controller. Just to make sure - as it might be in my configuration - the domoticz-with-razberry used to be primary, is now secondary to the other pi with hass. Most of my switches/smoke sensors are fine - except that power on/off state is not communicated back from the power switches when triggered manually.

Running ozwcp, clicking on their button, they instantly show state change and the logging likewise. When running HASS no such joy (the smoke detectos every now and then do announce state). The power switches are greenwaves from some deal a while ago, working fine in ozwcp on the new PI and never had issues with them on the old pi/domo.

I can ‘get’ the manual power to show in HASS when I click their (lets call it) b-button shortly, but they never announce themselves. Am I overlooking something? (Statement that HASS doesn’t see 'm is backed up by running HASS in debug, specifiying zwave as debug and double-checking the ozw log).

@ih8gates so regarding your question in the other topic:

It’s the ‘white’ greenwave single power module (or the 6-outlet bar). They keep ‘chiming’ green for network loss (despite setting it to 255) as well. That might be a hint as well, running ozwcp they don’t act up like that and also immediately return status. The attached zwcfg snippet is the one generated by ozwcp.

Nothing fancy on the configuration yamls regarding these switches

Just tested again, in ozwcp, when clicking the manual override it updates right away, in hass nothing happens until i click the inclusion (ergo, also polling doesn’t work? since that has been 8 hours now)

usb_path: /dev/ttyACM0
config_path: /srv/hass/src/python-openzwave/openzwave/config
polling_interval: 60000

(in customization.yaml)
friendly_name: Losse GW4

In the other thread, I took “instant status” to mean info from a typical switch. If the info is coming through to OZW, that’s a good thing. It sounds like someone needs to support the callback in a component.

If I’m not mistaken, I think your best bet is to open an issue and document the info that’s being returned to OZW and how you’d expect HASS to reflect the change.

Opening the issue isn’t the problem, but the strangest thing is it doesn’t return anything while HASS is running. I could however diff HASS response from one of the smoke sensors and one of the switches between HASS and OZW?

Any clues/ideas? As said … opening the ozw log while hass is running doesn’t show statusupdates (besides the occasional one on power usage, but not the desired switch state(s)).