Switching from Zwave 1.4 (Deprecated) to ZWave JS UI (formerly ZwaveJS2MQTT)

Thanks for confirming - seems like I needed to wait about an hour for the performance to go back to normal, it’s instantaneous now like before. Thank you!

Restart of the host seems to have done the trick! Shows as asleep/complete now!


So to get ZwaveJS2MQTT working you need to already have a MQTT server up and running?

Thank you for this guide - it’s greatly appreciated! For devices which are showing as dead nodes but you know aren’t dead - is it reasonable to hope that they’ll eventually check in with z-wave controller? Or should I do the refresh node? I have zwave blinds that are in windows 20 feet up, not the easiest for me to get a ladder out and hit a button.

I’d wait a bit and see if they wake naturally on a cycle.

1 Like

Will do - thank you again. I was afraid to take the plunge but this guide gave me the guts to try it.

One thing that was weird - I had a new ZWave JS integration that was discovered when I restarted. When I tried to add it, it was prompting me for USB path and network key. I entered it and it obviously couldn’t connect because the USB stick was already paired to ZWaveJS2MQTT. I also had ZWave JS showing up as an installed add-on. I uninstalled it and restarted HASS and magically the ZWave JS appeared on its own in the Integrations. Seems to be working fine so I started renaming devices.

Verify that you dont have Zwave JS Addon and ZWaveJS2MQTT Addon installed. You may have accidentally installed it by answering a question in for the integration incorrectly. I haven’t added that to the guide yet.

Hi, my core.config_entries file shows null for my network_key, is that ok? Can I still proceed with following this migration guide?

Here is what is looks like:

                "entry_id": "84b4aa336beb413b8f705e57ffdf37a5",
                "version": 1,
                "domain": "zwave",
                "title": "Z-Wave (import from configuration.yaml)",
                "data": {
                    "network_key": null,
                    "usb_path": "/dev/ttyUSB0"
                "options": {},
                "system_options": {
                    "disable_new_entities": false
                "source": "import",
                "connection_class": "local_push",
                "unique_id": null

Yep, just leave it blank.

1 Like

I’m pasting in the key but it tells me: “Key not valid. Must contain only hex chars”
Do we need to reformat it somehow?
I’ve removed , and any spaces but still no dice.

remove the 0x’s before each character set. I.e. if it’s 0x32 0x34, you’ll end up with 3234


Thanks - Waiting for devices to be discovered now. Also the configuration screenshot on here doesn’t match what I saw.
There was no toggle for WS Server, so I can’t turn it on?!
Running this all on a virtual machine on a QNAP

Ah ok, yeah then the toggle is in the ‘HomeAssistant’ section of your settings.

1 Like

Make sure to turn off the MQTT portion too.

1 Like

Thanks, sloooowwwly they’re all appearing (Like, 3 out of about 80 devices) and weirdly the one I’ve manually woken up hasn’t shown up yet. But will keep an eye on this all!

Well, you’re on a new server with a new cache file so you’ll have to wake it up again :expressionless:. Sorry, it can be a pain, but it’s zwave, I swear!

I’ve woken it up about 10 times whilst sat here refreshing the devices view, no luck yet! :man_shrugging:t3:

when in doubt, restart the container! Just wait for everything to appear so the cache file is whole. If you remember how ozw works, it’s very similar. The difference is that zwave_js tends to be faster in this regard.

1 Like

More devices appearing so I’ll let it do it’s thing for now.
Really stupid question, what’s the container? I’m still getting my head around the whole Virtual Machine, Base OS, Core, Supervisor, HA, Haas etc ! :slight_smile:

So how are you running ZwaveJS2MQTT? Did you install it in docker?