Switching from Zwave 1.4 (Deprecated) to ZWave JS UI (formerly ZwaveJS2MQTT)

I went to add ons, and installed it from there.
So now I have 2 questions. What is the container and what is docker? :rofl:

I basically installed everything from the virtual appliance image on my VM that runs on the QNAP.

Ok, so then the UI must have changed for everyone. I’m basing my comments of my memory. Last I remembered my stand alone copy of zwavejs2mqtt had a different UI from what was provided with the zwavejs2mqtt addon. The addon must have been updated. So just ignore my lingo and I’ll continue talking as if you’re using the addon instead of the container.

1 Like

So when you say restart the container, should I be restarting HA from the web interface? Or restarting the add-on?

Second battery device here (Aeotec Wallmote) and it’s sat here flashing away for the last 5 minutes but is yet to appear in the web interface

Yes this.

does the web interface have it as a node?

It has the node ID, is Awake but stuck on ProtocolInfo and never progresses from there.

does it have parameters?

Debug info shows:

{
  "id": 123,
  "deviceId": null,
  "manufacturer": null,
  "manufacturerId": null,
  "productType": null,
  "productId": null,
  "name": "",
  "loc": "",
  "values": [],
  "groups": [],
  "neighbors": [],
  "ready": false,
  "available": false,
  "hassDevices": {},
  "failed": false,
  "lastActive": null,
  "interviewCompleted": false,
  "firmwareVersion": null,
  "isBeaming": false,
  "isSecure": false,
  "keepAwake": false,
  "maxBaudRate": null,
  "isRouting": null,
  "isFrequentListening": false,
  "isListening": false,
  "status": "Awake",
  "interviewStage": "ProtocolInfo",
  "_name": "NodeID_123"
}

This is happening for all my battery devices (Of which I pretty much have just Fibaro Motion Sensors and Aeotec Wallmote) Assuming they are supported?

I’m not sure if they are supported. But even if they aren’t, they should show up with basic information as a node without the manufacturer identified. And most of all, they should work. I have 1 fibaro device that did that and I haven’t bothered to refresh the node because it works properly.

It’s strange - All my fibaro wired devices are fine (wall dimmers) but it’s literally anything with a battery.
Connecting one to mains (some can charge via USB) and that still doesn’t appear either. Odd.

OK so I have parameters showing up for some of the devices, looks like it’s just taking some time! Still no device information, but I can see parameters under them now. :raised_hands:t3:

I’ve loaded up the ZWave JS Integration and it’s brought 80 Devices across, but only 12 Entities for some reason. Doesn’t look like those numbers are going up either. Another case of just be patient?

What does the healthcheck in docker-compose look like? Is it something like this?

    healthcheck:
      test: curl http://192.168.1.200:8091/health -H "Accept: text/plain" || exit 1
      interval: 60s
      timeout: 5s
      retries: 3

I am running dockers images of HA (2021.2.2) and ZwaveJS2MQTT (1.1.1) on a Synology NAS. Both are working and I can see all my Zwave devices in the ZwaveJS2MQTT control panel.

I have configured ZwaveJS2MQTT to the recommendations above, ie. Disable MQTT Gateway and enable WS Server on port 3000.

When I try to add the Z-Wave JS integration from HA, I have to submit the URL, which defaults to ws://localhost:3000. When I hit the submit button, I get Failed to connect. I’ve tried the actual IP address as well, as various different ports. I cannot get it to work.

Any thoughts anyone? Thanks in advance.

Try the docker container label listed in the official docs. https://www.home-assistant.io/integrations/zwave_js/#installing-and-configuring-the-z-wave-js-integration-in-home-assistant

I had same issue. It got connected when I added “network_mode: host” in docker file.

Thanks petro and aghbar. I figured out what I did wrong. I forgot to turn on ‘Use same network as Docker Host’ when launching the docker image. Everything seems to be working now.

A post was split to a new topic: Zwave 1.4 missing after update to 2021.2.3

Any way to tweak the settings for particular devices, as one could do fairly easily by editing the Open Z-wave files on the old integration? In my particular case, ZwaveJS2MQTT does not expose the configuration parameters for my Zooz ZSE29 motion detector, even though the device otherwise seems to function well.

hi all. after installing the integration I can see the devices, but no entities. any ideas?

Hi all. I have a similar issue as already mentioned here. I have the devices in the integration, but the battery-powered ones, do not have entities. Despite in the Control Panel, they have some values. They are not perfect, but more or less OK. What I have recognized these battery powered devices, do not have device ID.