Sylvania Smart+ WiFi

So as others have mentioned it’s definitely Tuya inside these bulbs, signing up for the Sylvania app even tried to use my Tuya password… although they are clearly separate accounts… I tried running wireshark but it appears to be https and I’ve never used wireshark in my life … I know there is some method to see encrypted traffic but no idea how… I feel like it must be some super subtle/simple change that prevents them from working across platforms… hopefully someone with more knowledge can dig into these someday.

This is the reply I got from them:

“We haven’t published any API’s yet. You might want to check back next year to see. If we ever do this, it will be on our website.”

man, these things suck. probably will just end up trashing them I guess :frowning:

Anyone know of a similar WiFi connected smart bulb that does have an API (ideally locally without a trip through the cloud)?

check this out:

Great news!

I have successfully added my Sylvania Smart+ Wifi Bulbs to HA using LocalTuya.

A Tuya IOT Development Account is needed but the instructions in the Add-On are very good.

Just note that you will lose the ability to control the lights using Amazon or Google or the Sylvania App. Only able to control with Home Assistant after connecting them to LocalTuya.

Once I got LocalTuya configured and got the Device ID and key using tuya-cli I was able to add the bulbs to my configuration.yaml. What follows is just one of my bulbs. A new host entry is needed for each bulb. Hope the following helps:

  - host: <Local IP of Bulb>
    device_id: <Device ID from tuya-cli>
    local_key: <Local Key from tuya-cli>
    friendly_name: Sylvania Smart+ Wifi
    protocol_version: "3.3"
    - platform: light
      friendly_name: LR Door Light
      id: 20 # Usually 1 or 20
      color_mode: 21 # Optional, usually 2 or 21, default: "none"
      brightness: 22 # Optional, usually 3 or 22, default: "none"
      color_temp: 23 # Optional, usually 4 or 23, default: "none"
      color: 24 # Optional, usually 5 (RGB_HSV) or 24 (HSV), default: "none"
      brightness_lower: 10 # Optional, usually 0 or 29, default: 29
      brightness_upper: 1000 # Optional, usually 255 or 1000, default: 1000
      color_temp_min_kelvin: 2700 # Optional, default: 2700
      color_temp_max_kelvin: 6500 # Optional, default: 6500
      scene: 25 # Optional, usually 6 (RGB_HSV) or 25 (HSV), default: "none"

Thanks for posting this! I attempted to do this before but fell on my face trying to find the device Key. Which method did you take to find this? I realize it’s documented here, but I couldnt get this to work previously. I’ll give it another go later tonight though

edit: the step that I’m stuck on is

Click "Link devices by App Account" and scan the QR code from your smart phone/tablet app by going to the 'Me' tab in the app, and tapping a QR code / Scan button in the upper right. Your account will now be linked.

Do you happen to be using the Sylvania app? Or were you able to get the bulb to register with a different tuya app? I don’t seem to have this option in iOS

@jon102034050 I use the Sylvania App but I removed all my devices from that app and linked them using the Linking a Tuya device with Smart Link section of the config. So the bulbs no longer show up in the App which is fine.

I then enabled the Emulated Hue functionality and exposed the LocalTuya Devices via the Emulated Hue Bridge so I could control them with my Alexa again.

@jon102034050, I just tested it on one of my Tuya Smart Devices and only the Tuya Smart App can be linked to the Developer account. But that allows all the devices in the Tuya App to be retrieved without removing them from the Tuya App but still getting the Secret Key to allow Local Control.

I have everything configured and it’s working great. I’ve even enabled the Circadian Lighting extension and it’s working great as well.

Happy to help if I can. Let me know.

Thank you so much for posting this!! I got my first bulb to work following the readme you mention and what you posted for code and it works perfectly! The bulbs have more features now with the added effects and more color options!

I did have an issue with the cli registering it at first from my Mac, but tried on a Windows box and got it. I think what I did wrong was leaving it in pairing mode too long trying to get the cli setup, because it failed my first try on the Windows box too. So I turned the bulb off/on and tried again once it started flashing the colors again and it worked within about 10 seconds.

Thanks again for figuring this out!

Nice!!! Thanks for posting this, as I said earlier, I’d previously attempted this method, but their API was throwing some auth errors, I must have just screwed it up or something. I added 2/4 bulbs with no issue!

One thing I did notice with every bulb is that they would not work the first try, I had to power cycle each one after the first try and then it would work. One I had to power cycle a couple times. Weird behavior, but just happy it works.

I’ve got one bulb up and running using this technique, thanks for sharing it @quagmirert!

I noticed that the “Cloud” product in Tuya’s developer portal is on a 3 month free trial, and then is $300 a year to keep using it. Does anyone know what happens when the trial is over? Will we be able to keep using the bulbs / add new ones?


All methods below require you to install the CLI tool before proceeding.

Where do we install the CLI tool? On the Home Assistant host? On any linux machine on the network?

Any machine, doesn’t have to be on HA host

Hm, I was able to pair 2/4 with no problems, but the other 2 are really giving me a hard time. just keeps timing out. what mode was your bulb in when you paired? Ive tried the fast flashing mode as well as the slow flashing mode

I just power cycled them all a few times and they started flashing fast. I think if they are flashing slow they are still connected to something. I did get that with one bulb that I had forgotten to remove from the Sylvania app first, and it showed online on the app but was flashing slow. I removed it from the app and power cycled a few more times and it started blinking fast and then I was able to connect. I do believe I had to power cycle one more time after the first connection attempt failed though (even with it flashing fast).

Thank you @quagmirert for posting your method with LocalTuya! I was able to get all 4 of my bulbs working after resolving a few issues. Adding my bulbs to the developer account worked every time. Ensuring that the bulbs were in the fast flashing pairing mode and deleted out of the Sylvania App was key. The problem that I was having was controlling the bulbs with HA. The key enumerated after pairing SOME of the bulbs to the developer account is not the correct key needed for local control. Not entirely sure, but there must be a difference between the key and the local_key. Simply running the tuya-cli wizard command enumerated a different key than the original pairing output. After changing this in the configuration.yaml file, HA was able to control the bulbs without a hitch.

Just catching up with this chain. If I understand it correctly, individual will need to create a Tuya Developer account which would cost $300 at some point! Just confirming because that is a pretty steep ask, why not just get Philips hue lights at that point.

I manged to get one light connected using the “Linking a Tuya device with Smart Link” section. But I can see how it’d be technically easier to link it to Tuya Smart or Smart Life instead, plus you get the added bonus of having cloud & local access.

This whole process has been pretty spotty for me though. Using the previous method, the one light I connected manged to connect after about 7-8 tries, I’d get timeouts or the light would half connect (Turn white then time out before registering with the cloud). When it finally connected tuya-cli failed, it didn’t output an id/key pair, but it was registered on my developer app. I was able to pull the key manually using tuya-cli wizard.

For a second bulb, I wanted to try using the phone app. For the life of me, I can’t seem to get this to work. I set the bulb to fast flashing (pairing mode), not slow flashing (access point mode). The app sees a bulb ready to pair, I tap “Go To” and wait the 1 minute or so, it always times out, however the light does turn white.

I’ve also tried access point mode with a little more luck. When I try pairing with that mode, the light also turns white, but the app tells me “this device is not supported by this app”.

I also tried the Smart Life app with similar results.

@quagmirert did you have to do anything tricky to get these to work in the Tuya app? What version of the app are you using & what kind of phone? I’m wondering if maybe there was an app/firmware update that kills our ability to pair these to the Tuya app.

It would be awesome to get a custom firmware working on these. I’d gladly ditch all this horribly hacked together cloud junk for a piece of hardware I own fully.