Synology DS 218+ installation problem


#1

Hi guys,

At the moment I’m running Hassio on a Pi 3 B + with SD card and further a standard setup. I’m facing a lot of problems due to SD corruption. I installed Home Assistant with Docker on an Synology DS218+ this was no problem. But of course the Hass.IO is missing. In the Docker register you can find 3 Hassio supervisor add-ons. If I’m correct this will add Hassio to Home Assistant??

I have added:

homeassistant-aarch64-hassio-supervisor1

homeassistant-amd64-hassio-supervisor1

homeassistant-armhf-hassio-supervisor2

almost standard configuration. I only changed: automatic startup – volume all to the same /config folder – same network a Docker.

But the weird thing is none of the register add-ons will start….

homeassistant-aarch64-hassio-supervisor1

error: exec user process caused "exec format error"

homeassistant-amd64-hassio-supervisor1

error: (MainThread) [hassio.bootstrap] Can’t find SUPERVISOR_SHARE in env!

homeassistant-armhf-hassio-supervisor2

error: standard_init_linux.go:189: exec user process caused "exec format error"

does anybody manage to get Hassio working without use off SSH?

THNX


#2

Do you have Virtual Machine Manager on your DS 218+? You need to be using Btrfs file system though. If so you can use the virtual disk of HASSIO.

Otherwise you will need to use the non HASSIO version of Home Assistant in Docker.


#3

Hi Wills, Thanks for the reply!!!

I’m new with virtual machine mananager… can you please explain what I need to do?
Thank you.


#4

I can’t show the full progress as I am upgrading my Disks, so I have limited functionality.

Download the vmdk from here:


Load Virtual Machine, select Image on the left, find the VMDK you just downloaded.


Select the storage. I can’t proceed any further step on this part due to upgrading my disks.


On the left select Virtual Machine, then next to Create click the Arrow and Import.


Select the Disk Image you just created.


GIve it a name and allocate some resources. On mine I have allocated 1 CPU core and 2GB RAM, then press next a few times.


I selected UEFI BIOS type. Then follow the rest. Hopefully you should be able to start it up and connect.


Is there a Hassio for Synology (Docker)?
#5

Wills, thanks for the clear explanation!! I have 2 gb of RAM in my synology. I can select a maximum of 176 mb during the proces as mentioned above. can it be possible this is to less to run Hassio?
please see the error log.


#6

Yea you don’t have enough RAM, you can easily add another 4GB or 8GB DDR3 SODIMM will cost you about £48 or equivalent currency for an 8GB Stick. Something like this here at Amazon Worth the upgrade!

Also ask a friend, they may have upgraded a laptop and have a spare 2GB or 4GB stick?


#7

Tried above, but when give connect:
Welcome to Hassos
Hassio Login

There the problems begin! what to use to login?


#8

How are you trying to login?

Are you using http://hassio.local:8123 or have you found the IP address through your router interface?

VMM (Virtual Machine Manager) will create a new IP address for the HASSIO Machine, so it will be different to your Synology IP address.


#9

Oh, sorry, i just had to wait for a few minutes, now it works. And indeed as i looked at my fritz box i got a brand new ip adres.


#10

Does anyone have Zwave (Aeotec 5gen) installed with Hassio on VMM?


#11

I don’t have any devices to try. But have you tried selecting a Virtual USB controller and passing the device though? Under other settings.

I am guessing you should see the device there like you can see my USB HDD


#12

Ah i also thought there was a problem with the usb port. I finally found the setting but, i can not change it! Yust as by you there is a blue i it tells there could be compatibility issues between usb3.0 devices. Yeah but i needed it, as my Zwave stick is usb.

Could it be enabled when i installed the VMM again?


#13

Have you tried stopping the Virtual Machine first before changing the setting?


#14

yes, i have also changed disk size from 10 to 30GB but finally after again installing VM with the Aeotec usb port i tried to start Home Assistant with
192.168.178.33:8123 or hassio.local:8123 now for 60 minutes i got only this:


#15

finally after reinstalling and again 20 minutes i got Hassio working, now i got an extra serial port (usb) /dev/ttyACM0 but again, after giving /dev/ttyACM0. Now i got 1 everspring AN158 (i got 3 of them) so it should be working, but i can not go into the configuration menu of zwave. When i push config on zwave i got: there is already one instance of zwave (last item of the row). I only got the zwave menu earlier when zwave was not the last thing in the row!


#16

Did you try and add the Z-Wave config before knowing the USB port number?
If so at the top of that page under:
Configured

Do you have Z-Wave listed?

If you have got it listed there have you tried to delete the entry and then re add it?

You could try a manual setup?


#17

No, the last minute i got zwave listed see picture. It seemes that i have te reset my other 2 Eversprings.