Synology DSM 7 2fa problem

I am trying to get this integration to communicate with home assistant.

I have a ds220+ with DSM 7 on it.
I followed This how-to and created a user on DSM with 2fa setup and admin rights.
I installed the integration and it asks for address of my DSM, username, password, port and then prompts me for 2fa code.
After that it gives me this error on the integration page.

‘api’: ‘SYNO.API.Auth’, ‘code’: 403, ‘reason’: ‘One time password not specified’, ‘details’: 'Two-step authentication required for account

Not sure what I am doing wrong as I put in a 2fa code and it accepted it.

Thanks for any help.

Anyone else having this problem?

Just to be sure on the steps:

  1. you created a new user on DSM with 2FA
  2. You logged-out, and logged in again with that new user
  3. You were following the steps to create the 2FA config, and added that config, for that user, to whatever 2FA app you’re using
  4. when configuring HA, you entered username, password and current 2FA for that user

Yes that is the steps I took.

Same problem with my new installed DSM 7.0:‘SYNO.API.Auth’, ‘code’: 403, ‘reason’: ‘One time password not specified’, ‘details’: 'Two-step authentication required for account:

Same here…
Account set up as admin, 2FA configured. I can log in via PC (Edge and Chrome) as the HA user I created using user name, password and entering the 2FA code, no problems.
When setting up in HA, enter the user, password and host/port, then get asked for the 2FA code. Enter the current code and recieve the same message.

Core log and HA log both show:

2021-07-05 16:52:50 WARNING (MainThread) [homeassistant.config_entries] Config entry '192.168.xx.xx' for synology_dsm integration not ready yet: {'api': 'SYNO.API.Auth', 'code': 403, 'reason': 'One time password not specified', 'details': 'Two-step authentication required for account: HomeAssistant_NAS'}; Retrying in background.

What’s odd is that DSM us showing HA as logged in from the HA IP???

I am not sure which version of the API the integration is using for logging in, but seems like support for v2 was dropped for the login by DSM (although not mentioned in the documentation of DSM 7).

I am having a similar issue with my HomeSeer plugin.

Yes, I have the exact same problem after upgrading to DSM 7.0.

I found this on GitHub: -

I’m not sure how to go about asking for this fix to be released.

1 Like

I have the exact same issue and error message as @liamp when trying to install the Synology DMS integration. Does anyone has an update on this?

It looks like everybody has this problem with DSM7, so same here…
Could be cool to fix it soon.

Good news, this issue is resolved with updated HA.


Yes, I can confirm after updating my Home Assistant to version 2021.8.4, the Synology DSM configuration with 2fa worked like a charm. It took about 10-15 seconds after providing the 2fa code, but then the integration worked.

guys… what did you do to make it work? I keep getting error in 2FA, although code is definitely correct, even HA says so.

Steps i do:

  • after restart HA i get new integration synology - i press configure
  • i enter local IP of Synology, username (the one with admin rights!), password, https port, enable ssl
  • i enter 2FA code
  • i get "succesfully configured

BUT after that i immediately get error that 2FA supposely didn’t pass . But why then i get “succesfully” message from HA?

I even created a new user in Syno (with admin right), same thing…

What’s interesting is that Synology log center says that Home assistant was succesfully connected…?
While HA log says:

Config entry '' for synology_dsm integration could not authenticate: reason: Two-step authentication required for account: home_assistant

EDIT: i “kinda” solved it by disabling 2FA for that account. Not very secure, but… all i could do is to disable all access to apps, files… for this account. It seems that 2FA is again a problem in HA…

Confirmed, Protoncek, same issue over here, 2FA is successfully re-configured but a failing message appears in the integration while the configuration passes. This happens in my Home Assistant 2021.12.8

1 Like

Hi @Protoncek and @JohanHardy

on which DSM version is your NAS running?
Did you do an update in the near past?

I’m on DSM DSM 7.0.1-42218 (without update 2!) and everything works as expected.

I’m on DSM 7.0.1-42218 Update 2. In this case maybe the “update 2” is the culprit…
In any case, it works if you create a user and remove permissions from ALL folders and ALL applications (and disable 2FA, sure). So, i guess it’s not a big security risk, sincer such user can’t do anything anyway.

I’m on the same DSM version (i.e. update 2) as Protoncek, same symptoms. No way to reconfigure the integration with 2FA. The DSM version juste before was working nominally.

same issue

1 Like

Same issue

Same issue :frowning: