Synology SRM kb/s sent / received stopped working

Im using this platform thing:

And its not working correctly. I’m using the sensors for my Synology’s kb/s sent and recieved data, and they worked initially. I added them to my Home assistant config yesterday, where they both worked. However after a few hours the Download sensor stopped working, and today the upload sensor stopped working.

Is this a known thing ? Is there any other way i can get these two things out of my Synology router?


1 Like

Same happens to me.
Any luck on fixing?

Nope. Never got it fixed. :frowning:

Haven’t tried for a while though, but guess that since you have the same issue it still hasn’t been fixed. I’m not even sure where to report such things as the Github page is for all Home assistant which i don’t think is the correct place

I found this which will connect to the API to get the data, but doesnt seem to be in HA.
I dont know how to raise as a feature request or a bug either.

OK it has been raised but no one voting for it.

I ended up making the integration myself:

… I finished this in Feb … then 2.5 months after was told they had just updated their standards and were no longer going to accept this because it requires the config.yaml.
Feel free to use it though; it will still work.

Awesome, thanks.
Works a treat.
What does it need doing to get it into the release?

I will take a look at this later today. Looks great! Hope it gets into the official release somehow, maybe we can help each outer out?

So just upgraded to Home Assistant 0.109.3 and @i00 integration not working now.
Dont know why yet, was working great beforehand.
Let me know if you want me to test any new releases of this Kris (@i00) .
Thanks in advance.

I’m having the same issue. Sensors for packets/s and total B sent/recieved are working but the KiB/s sensors report nothing.

I’m new to HA so it’s not clear to me if there’s a different way to do this now. Can anyone help me find the right way to do this?

@i00 do you by any chance have an updated version of your integration? It currently stopped working for me. I also had an issue with packet sensors. Anyway, you can upload it to hacks or here?

Thanks so much!