System is not ready with state: setup

The other night my virtual machine that’s running HAOS shut down/restarted itself. Since then I cannot get it to fully start back up. Right now when it starts up I don’t have access to the front-end for anything. It’s also not running at all because I have time based automations and they aren’t running either.

Looking at the command line, there is an error Error returned from Supervisor: System is not ready with state: setup. I’ve given it several hours (overnight) and it didn’t resolve it. From another thread some people suggested typing in banner but that doesn’t work for me; I just come right back to that error. I can’t get most commands to work because it just keeps returning that error (tried supervisor repair or even just logs ands they still report that same issue). I have restarted the VM several times and it always comes back to this.

I’m running HAOS from a VM in a Synology NAS. I can’t remember exactly what versions I have but I know I’m about 1 month behind on the latest versions. I have recently been rebuilding from a corrupted system and just about had everything fixed back to how it was before, with a bunch of improvements, and would HATE to lose all of that because I hadn’t backed up yet. Is there anyone who can help me out?


Maybe a bit late for you, but I had the same issue today on my Synology with the HA VM.
I managed to get to the CLI and did a repair, check the repair function via help in the CLI.
After this I had the following issue:

System is not ready with state: setup

So I typt banner in de command line and after a minute or so the web gui worked again. :slight_smile:

Brand new Odroid M1 with homeassistant pre-loaded in eMMC, same error.
I have homeassistant running on an isolated VLAN.
I don’t want my LAN of THINGS to have Internet access.

I made an exception for the M1 Controller and now the error cleared, and the supervisor loaded.
Not a great sign for a system that is supposed to function locally.

Maybe it just needed to initialize its RTC. Dunno.

Raspberry Pi 4B 8 GB, HAOS, same problem, completely stuck. Getting these long-term stability problems and unreliable update issues resolved is more important for the success of HA project than fancy features.