System Monitoring - How does yours look?

mine… (heavy work in progress.) It is a popup with browser_mod and dwains theme :slight_smile:


I am using:

  • Open Hardware Monitor for two Windows clients,
  • Netdata for Raspberry Pi #1 (libreelec),
  • System monitor for Raspberry Pi #2 (with Home Assistant in Docker).

So far it works. The only visible problem is that Netdata client on RPi sometimes becomes “unhealthy” and does not respond.

Just heard about Glances. Has anyone compared Glances with Netdata?

very nice and very well done @NdR !
I’ll use your view as a template :wink:

how did you define the control/status bar on the left?

Hello, I have an Intel Nuc and would like to monitor my Raspberry Pi on the Raspberry is running RaspberryMatic (Homematic Server) someone may have advice on how to query the sensors

Check out this topic:

Hi, thanks for the quick response. Where do I have to install the pyhton libaries on the Nuc with Hassio?

On the pi.

How can I find out the name of the wired network interface to be used with systemmonitor? Using (learning) NUC with HA OS. I’ve tried various names found by going through severals topis and attempts, i.e. eth0, ens18, if20, link/ether, eth0@if20…

It used to be listed in Supervisor / Sysyem / Host / … / Hardware but that’s just a mess now.

Try ifconfig at a command prompt (SSH terminal addon).

Thanks for the tips. Hadn’t checked this Supervisor / … / Harware before, but unfortunately it doesn’t show network related info.
Tried ipconfig (familiar with that from the Windows side) already before, but it is not installed in HA OS. Wonder if I can install more commands to HA OS? Also lm-monitor might give more interesting info, like more detailed CPU temperatures.

ifconfig not ipconfig. This is a Linux based system.

(obviously need more sleep, but this is just too addictive)
ifconfig gives ‘eth0’, but using that with the systemmonitor doessn’t show anything.

Have a look in your Supervisor / Host log. I have a bunch of logs where eth0 is renamed.

That’s it, thanks @tom_l . Browsed the logs and found ‘eno1’, which works.
This is endless, though… would like to get all the four CPU core temperatures, but that doesn’t seem straightforward to achieve.

Try this for the package temp. Not sure how to get each core temp.

I’m having the same issue on my NUC, eth0 nor eth1 is working to give the throughput stats. There are multiple entries in the host log similar to the below, but they all have eth0 or 1 renamed from a different number…

veth2772fa9: renamed from eth0
eth0: renamed from veth74c79b0
eth1: renamed from veth9779081

It’s all over the place… any ideas @tom_l

ifconfig suggests it should be eth0

It’ the same here, so likely you could find out the one to use by browsing the logs. Search for ’ eth0’ (I had several tens of occurrances) and see the one that differs from those multiple entries veth… I had this line
e1000e 0000:00:1f.6 eno1: renamed from eth0. Tried ‘eno1’ and it works.

I tried a search but didn’t get any hits other than the ‘vethxxxx’ type stuff

Have you tried just hassio for interface name? I was struggling for ages to find interface name in my VM running on ESXi and found this trick somewhere in the forum… Funny is that it is not listed by any system command as valid interface name… But it is working for me :slight_smile: