T-Mobile Home Internet Gateway

I run my home assistant through my raspberrypi4 using Cox internet and a net gear modem router combo box without any issues. The rp4 is connected to the netgear box through Ethernet.

Yesterday I switched my internet to T-Mobile Home Internet that uses a gateway modem router combo box. I plugged my Ethernet cable in and connected my rp4 to my gateway box but it didn’t show up on the device list. I called T-Mobile and they said raspberry pi is out of their domain so the device is not compatible. They recommended calling the manufacturer to update the firmware.

It’s been about 6 months since I’ve updated the firmware but I don’t know if it’s available now. Does anyone have any work arounds? If not does anyone know of any devices that are compatible to run HA and connect to the T-Mobile gateway?
Thanks

Hi Brian,

Your raspberry pi is just a computer like any other device you might connect to your network so compatibility isn’t a consideration. To me it seems like the pi and/or the ha instance have a static IP rather than dynamic.

Most likely the new router is serving a different network to your old router.

What is the IP network you connect to now & did you happen to note the IP of the pi when it was working or did you only connect via http://homeassistant.local?

Cheers

Hi Nick thanks for the reply. On my old router I setup port forwarding to a static IP address.

Forgive me for being a beginner. What do you mean by
“Most likely the new router is serving a different network to your old router.”

Also not sure what exactly you mean by this, “What is the IP network you connect to now”

The static IP of the rp4 was 192.168.0.16 but now that doesn’t load anything.

What is the IP of the router? I’ll bet: 192.168.1.1, which is a different network.

192.168.12.1

http://192.168.12.1/

What does that mean if it’s a different network?

Almost all of our LANs are 24 bit. In my case IP addresses from 192.168.1.0 to 192.168.1.254. I can’t see anything outside of that range even if they are both on my router. In your case 192.168.0.xx and 192.168.12.XX are different network ranges.

I do not use static IP in any of my devices, including servers. If I want an IP to remain unchanged, like my servers, I do it in the router. In my case, a Verizon FIOS router, it’s called a permanent lease. (Some routers call it static IP or fixed IP.) When you give an IP address a permanent lease, this means every time the router sees the MAC address of your device, it assigns the same IP address to that device.

In your case, you can’t simply change the static IP of your Raspberry unless you know the new assignment is outside of the DHCP address range of the router. If you pick an address within the DHCP range for your Raspberry IP, you risk the router assigning the same IP to another device later, then neither of them will work.

1 Like

@BrianLane - Yes. Your router is at 192.168.12.1, so most likely your clients (think laptops / phones / xbox etc) are all under the 192.168.12.xxx network, when they connect to your t-mo router.

Yet, your RPi has/had a static IP at 192.168.0.16. So unless you did some extra routing config with your t-mobile router, your phones / laptops would not be able to talk to your Pi4.

If I were you, I would find a laptop with a LAN port, (temporally) change the laptop IP into a static one, and LAN to LAN cable directly to your rp4.

And then connect to your home assistant from your laptop, and change the rp4 static IP into something else (that is reachable / compatible).

1 Like

Hi Brian,

Have you tried accessing your HA instance via name instead of the old ip address? For example, by default a new HA installation (depending on how old) will default it’s name to “homeassistant” and it will existing a domain named “.local”. So try http://homeassistant.local:8123/ in your browser to see if your HA device has automatically been assigned a new ip address in your new network.

Also, don’t forget that HA exists on a default port of 8123. So that means you would have in the past been using http://192.168.0.16:8123/.

Have you rebooted or power cycled your HA machine since you installed your new network router? Might be a good idea to do that if you still can’t access HA via the URL above.

If you have already restarted since the new network came online then you might have to simply pull the plug on your HA rpi machine & power back on (generally not advised but might be the simplest way forward here). As mentioned by others already, the better option would be to change the IP address of your computer to be something like the HA ip address. So for instance, you said your HA was on 192.168.0.16, then manually set an ip of a computer to something like 192.168.0.2 with a mask of 255.255.255.0. Then plug your computer via ethernet cable directly into the rpi. Then try accessing in the browser again. If you get that far & that works for you then you will be able to change the HA ip settings. There are heaps of online articles about various ways to do that.

Also, do you know if you had backups turned on? and did you by chance have the google drive backup add-on included? If you can find a recent backup somewhere you might, as a last resort, have to consider installing HA from scratch & restoring a backup.

Cheers
Nick

Thanks for the ELI5! Any way to make sure the last problem described doesn’t happened?

Ok good to know! I don’t have a Laptop with Ethernet capabilities but I’ll try to find another way to change the IP

Yes I have tried but the confusing part comes in when my rp4 does not show up on the devices list for my t mobile router. I’m assuming this is because of the static IP making it on a different network. I have tried to power cycle without success but I guess the last part is always an option since I do have my google drive back ups

A LAN to LAN cable is called a crossover ethernet cable. Or you can use a standard Ethernet cable with a crossover adapter on one end.

OP- If you were using DHCP this would never have happened. This is why I don’t like static IPs.

  1. Find, borrow or buy an old router with Ethernet.
  2. Set the router IP to 192.168.0.1.
  3. Plug a PC or laptop with Ethernet into the router.
  4. Plug the Raspberry into the router.
  5. Log on to the Raspberry and change the IP to DHCP.

I guess you could use your new router for step 1, but if something goes wrong we may never hear from you again.

After step 5, plug the Raspberry into the new router and it will be on your LAN. If you really must have a static IP for the Raspberry then do it in the router.

1 Like

How can I use my old router for this? Does it need to plug into my new router via Ethernet port?

Step zero. Ignore the new router. You need a router on the IP range of the Raspberry.

This way you can SSH into the Raspberry and change its IP to DHCP. (you did turn on SSH?) Then plug everything back into the new router.

If you have a crossover cable or adapter, you can skip the temporary router altogether.

DHCP eliminates these problems. If you really need a static IP, you can do it in the router.

1 Like

If you did not change it. It looks like the T-moble router DHCP range is set to only give out 50 IP address (default is pool is 192.168.12.100 - 150). Also have you tried something like Advanced ip scanner or Fing on your phone to scan for the PI?

Ok thanks! I do have 2 Ethernet cables but I don’t believe I have a cross over cable. I’m not sure what that is. Why would I need a cross over cable? Why can’t I just connect the rp4 to my laptop?

Interesting!! The router has an interface that displays all connected devices so I never thought of trying to do a scan in addition. Also what does that mean after 50 devices are connected?

The wires in a crossover cable connect the output on one computer to the input of another.

Like hdmi?