Tado Smart AC Control V3+ cannot be set to heat/cool/fan

Hi!

I cannot seem to be able to control a Tado Smart AC Control. On the thermostat card, the only controls that work are “Auto” and “Off”. Heat, cool, dry, fan do not work; if set via the 3-dot-menu, they get reset to “Auto” or “Off” after a second or two.

If set to heat, cool, dry or fan via the Tado app, the card will however display the current mode correctly.

Thanks.

Does the same thing happen if you try to adjust the temp?

Have you disabled fallback mode in the home assistant tado integration settings? As this causes similar issues if enabled.

Yes, if I try to change the temperature, it gets reset to the current temperature after a second or two. Disabling fallback mode doesn’t seem to have any impact.

Thanks.

I’ve been having the same issue with the integration. The only command that works is turning the AC off.

Having the same issue, disabled fallback, removed all schedule blocks from tado app but HA can still only set it to off, anything else will revert in a few seconds.

I have experienced the same thing. From what I have read the integration has not yet fully incorporated the smart AC. I have used the Home Kit Controller integration to use the smart AC and can set the cool and heat functions together with temperature.

I’ve created a ticket on Github here.

Any up for this? I have a same issue. only with tado control i dont get a good result.

Is there already a solution for this problem? I got the same problems but didnt find a solution.
Thanks!

Same issue here. Just switched from my switchbot AC control to the tado one for HA integration and it also doesn’t fully work :frowning:

@michelangelo Hello, can you explain how you did that. I can´t integrate the smart AC. Home Assistant demands a Code in the format XXXX-XX-XXXX but the V3+ only have an 4 digit Auth-Key,some other numbers and a QR-Code, neither of them get accepted.

Hi

Have a look at Pairing with an insecure setup code.

I think the format in this case is xxx-xx-xxx.

One of the good things with Home Kit setup is its local so no reliance on cloud service I think.

Cheers

Hmm also check you are using the HomeKit setup code not the Auth Code. It’s a different one.

Thanks @michelangelo, I got it connected now.
The trick is to first enter 123-45-678 as the Code, than the option for “unsecure Codes” appears and with that checked you can enter the number from the backside of the device in the format xxx-xx-xxx

Got this same issue with my Tado thermostat a few months ago. I moved everything to a NR integration and haven’t had an issue since.

Me too. Posted here to get notified if anyone finda a fix. Incidentally, my two older ones running formware 60.1 have a ‘thermostate mode’ which works properly. My new one which runs v101 does as described above. Anyone know if you can downgrade the firmware?

OK, I think I’ve cracked this. I contacted Tado technical support who enabled ‘thermostat’ mode on my new device. I then went through the setup process again and Home Assistant then works properly. However, with thermostat mode you lose the ability to remotely set swing and the only modes you have are off, cool , cool, heat and auto. But I’m very happy now