Tailscale, anyone using it?

Anyone using Tailscale with Homeassitant? I installed it this morning, it is just awesome. Really zero-config. Just install and that it. It even comes with Tailsdrop, which also works just like wifi-direct and apple airdrop. Thanks, @frenck. Now I am confused between Tailscale and Zero-tier. Using both.
I am behind a CG-NAT but these both just work.

wondering the same thing… new tailsafe addon? zero-tier (never tried)? wireguard add-on? or NGINX with SSL and portforwarding…

which way is the best and safest?


Wireguard and NGINX doesn’t work behind CGNAT, but both Zero-tier and Tailscale do work.
I have found Tailscale to be faster of the 2 and easier to setup.
Zero-tier give you more options


Installed it today, after I read about this YT vid.
I missed the DNS setting at first, but after setting it to my routers’ local IP it works like a charm.

Did anyone tried setting up HA as subnet router with tailscale. I want to remotely access my printer and router through my Home assistant. Subnet routers and traffic relay nodes · Tailscale

How does the companion app work with this? Do you have to keep tailscale running in the background for sensor updates? I’m on android as I know wireguard has an on demand option for apple.

In zero-tier I had to enable it from the companion app. While in tail scale you just have to enable it from the app and forget. it will remain connected with tail scale network until you disable it.
I am using it with android.

1 Like

I tried to port-forward on my rpi4 running HA.
I got the following read-only error

  OS Version:               Home Assistant OS 6.3
  Home Assistant Core:      2021.9.4

  Home Assistant URL:       http://homeassistant.local:8123
  Observer URL:             http://homeassistant.local:4357
➜  ~ echo 'net.ipv4.ip_forward = 1' | sudo tee -a /etc/sysctl.conf
net.ipv4.ip_forward = 1
➜  ~ echo 'net.ipv6.conf.all.forwarding = 1' | sudo tee -a /etc/sysctl.conf
net.ipv6.conf.all.forwarding = 1
➜  ~ sudo sysctl -p /etc/sysctl.conf
sysctl: error setting key 'net.ipv4.ip_forward': Read-only file system
sysctl: error setting key 'net.ipv6.conf.all.forwarding': Read-only file system
➜  ~
➜  ~

How to proceed?

Which terminal are you using? You may need the one in the community addon store with protection mode disabled, not the regular addon, for elevated permissions.

actually, I ssh using putty.

Edit: Tried official ssh addon same result

protection mode is in fact disabled.

ipv4 forwarding is already enabled, you can see it with
sysctl net.ipv4.conf.all.forwarding

ipv6 is not but you need to enable the debug mode for this, see this post:

The subrouting / exit node issue was described and closed here but not fixed for everyone:

The follow up issue is here:

I don’t need ip6 portforwarding.
I just want to access my router and modem using HA as exit node.

Yes portforward is working on ipv4

sysctl net.ipv4.conf.all.forwarding

Has anybody for the range forwarding to access other devices local to HA?

For example I have printers and my router on the 192.168.1.* range at home but I can’t access them when connected. I can connect to HA’s 192.168.1.* address.

I can ping the 192.168.1.* addresses from the HA SSH command line so that can communicate.

use https://github.com/tsujamin/hass-addons/tree/main/tailscale add instead of offical if you want to use subnet. https://github.com/hassio-addons/addon-tailscale/issues/22#issuecomment-921036402

1 Like

Thanks, it works great (both access to LAN and exit node) on Home Assistant OS when checking userspace_networking.

using which add-on offical or tsujamin?

tsujamin, there is no userspace_networking option in the official addon.
That’s even worse since I am not able to start it anymore on HA OS.

Yeap, just moment ago installed it on few of my devices. After tons of time spent on DDNS, Google Domains, ddclient, router configurations etc. With tailscale everything just works out of the box! And for free(in my case). Seems very good.

I need help installing Tailscale on my rpi with Home Assistant Core without the add-on.
Can anyone help me? :grinning: