Tank Utility Configuration

Following the documentation to add the Tank Utility component, it says to get the device id string from the Tank Utility device page, but I can’t find that page. I’m thinking they have changed their website.

Has anyone configured this component. I searched and found no topics…I can’t be the only one using this component.

Got this to work and just wanted to leave this update here if anyone in the future wanted to add this component.

I could not find the 24 character device id string, where the documentation had described. I emailed tech support and they sent it to me. Added it to my config file like this:

- platform: tank_utility
    email: tankutility_email #your email login for the tank utility sign on page
    password: tankutility_password #your password login for the tank utility sign on page 
    devices: "xxxxxxxxxxxxxxxxxxxxxxxx" #your 24 digit id string in quotes

I thought I was the only one who used this component.

How you do like Tank Utility?

This worked like a charm - thank you. Just got my sensor hooked up today. So far so good!

Just wanted to say thanks for posting this! Just got my new Tank Utility delivered and was having trouble figuring out how to set it up per the Integration’s instructions.

This worked perfectly! I don’t know how, or if anyone can just edit and update the instructions, but someone that’s able to edit the page should make this new method known.


Amazing, I just installed everything and even though a little on the expensive side, it saves me a trip across the yard to check the level. I won’t tell my wife the cost though :smiley:

I figured out something interesting today when trying to set up my tank monitor. If you go into the app and hit the delete button for the sensor it will ask for confirmation. When it does it shows you the 24 character device ID, then you can just cancel the delete and enter that number into the tank utility setup in HA. saves some time going through all the token retrieval stuff. Hope this helps someone.

Greetings. Does this still work for you? I have tried to add this and for the life of me I can’t seem to find any new sensor created. I see no errors in the logs. Aside from the entry for the sensor in the YAML file am I missing a step somewhere else? Thanks

Yes I had the same problem. Put quotation marks around your sensor number and the magic will happen. I fought that for 2 days before I figured it out.

I’m assuming you mean the device ID … and I do have quotes. :frowning:

There must be other people having issues with this? Anyone know how often HA queries the tank utility API?
This is important to me as my current setup will email my propane provider when my tanks hit 15% but the integration seems be not up to date.