Tesla Smart Thermostatic Valve TV100 - Unknown switches and binary input

Hi there !
I bought these Tesla Smart Thermostatic Valve TV100 and I have successfully integrated it into my Home Assistant / Zibee Home Automation, but there are three switches for each of these thermostatic valves, which I have no Idea what they are doing. :face_with_monocle:Tried to tinker with them a bit, but still have no clue what they switch… Also there is one Binary Input also uknown to me.
Usually the name of the entity gives you a clue, but here its just SWITCH. :grimacing:

Any Idea what are these switches for, or how can I come to any conclusion regarding their fuction?


TempOffset

1 Like

Hi there (Ahoj),

I discovered a functionality of first two switches. The valve shows at least basic information on display when you turn the switch on.

Switch 1) Turbo (This could tell the valve to reach the wanted temperature faster with higher risk that the temperature will exceed the configured level for some time)
Switch 2) Parental lock (locks buttons to avoid children to use it)
Switch 3) Still unknown to me.

I found the Switch 3 is sometimes switching on independently. I suspect it could be some inner logical variable used by this valve. (Not confirmed)

I hope it helped

1 Like

Thank you very much! This helps a lot.

Hi guys,

I am glad to see, that someone else is using the same thermovalves as I am, because I have problems with it. I am using couple of TV100s under the zigbee coordinator using ZHA (zigbee home automation) in Home assistent OS running on Raspberry Pi4.

Everything seems to be working quite fine, but if I check the history of actual temperatures from the thermovalves, i see the constant value, from the date and time, when I pair the particular TV100 with the coordinator. If i repeat the pairing process, the actual temperature value is refreshed and seems to be correct in the time of pairing, but it is again no more refreshed in the following minutes and hours.

If I try to use the TV100 with Tesla zigbee hub and their native Tesla smart app, everything seems to be working properly, but i didn’t find the way, how can I integrate this hub into HA.

Do you have the same behavior with your TV100s under HA? Which zigbee coordinator are you using? Don’t you know, what can be wrong with my integration?

Many thanks for any advice.

Josef

Hi, did you solve this problem with the temperature update? For me the device connects using CC2531, but then stops communicating…

Hi Lolcoman,

unfortunately not. Now I am using the thermovalves outside of HA with the original application Tesla Smart and zigBee hub from Tesla smart.

Since the actual temperature is visible in the original app, I see the only chance in the support of Zigbee Home assistant…

Ahoj Josefe,
I have these TV100 for a while now and they seem to be working correctly…at least for now.
Maybe to compare this with your entries in HA? Maybe you have some different version?
I’m running my HAOS on my old Laptop, with SONOFF Zigbee 3.0 USB Dongle Plus V2 and I’m using the Zigbee Home Automation Integration.

Home Assistant

  • Core2023.12.0
  • Supervisor2023.11.6
  • Operating System11.2
  • Frontend20231206.0

Zařízení - informace

TS0601
od _TZE200_lnbfnyxd
Zigbee info
IEEE: 84:fd:27:ff:fe:6d:c5:3d
Nwk: 0xd417
Device Type: EndDevice
LQI: 152
RSSI: -62
Naposledy viděn: 2023-12-07T17:59:17
Zdroj napájení: Battery or Unknown
Zvláštnost: zhaquirks.tuya.ts0601_trv.ZonnsmartTV01_ZG

Attached is my graph of actual temperatures in my Grafana…

What Zigbee dongle are you using? I have been using CC2531 with my RPi 2B and Zigbee2MQTT and NodeRed, but that was before I purchased the TV100 so I cant tell about them, but for other device I have I noticed that instead of 4 sensors, it shows me only 2 in Home Assistant. But I’m not sure if that is because of HA + ZHA or because I’ve changed also the Zigbee dongle… I’m suspecting the ZHA because I’ve read some posts on this forum that few users were reporting incompatibility issues with ZHA and that they moved over to Zigbee2MQTT AddOn… Maybe worth trying?

Ahoj, hello z čech.
I am using thermostatic valves from another manufacturer, with the same asks.
You can read my post here

I found the same thing with those switches.
The first is BOOST, it increases the heating for about 5 minutes.
The second is LOCK and locks the warhead.
I don’t know what the third one is for.
I don’t know what the binary input is for either.
But after integrating 5 warheads via ZHA into HA, there are some intricacies.
All 5 heads work fine, but the switches only work for me on the last integrated head.
First I integrated 2 heads. The switches worked on the other one. Then I added 3 more heads, and those switches only work on the last fifth one.

Today I probably found the function of the third switch with the help of zigbee device management.
Operating this mysterious switch changes the value

ZONNSMARTWindowDetection/present_value
Bool.false
Bool.true

It’s probably turning off the open window detection.

You look to this link

Here is interesting informations about refresh data from valve, if valve not send temperature data, you can send from HA by automation command for ON/OFF periodically and get actual data.

Yes, I also think it could have something to do with the “Open window” detection.

I found, the valve sometimes changes its value on her own. So it might not be a switch for enabling the open window detection, but the open window detection status itself (unfortunately, not working reliably).

It all works in a weird way. It’s not finished.