Texas Residents: Access your Smart Meter Texas readings with Node-Red and MQTT

I know this won’t apply to many on here, but if you are a Texas resident and can access your meter through Smart Meter Texas, I have created a Node Red flow and HA package using the unofficial API (which doesn’t require jumping through a bunch of hoops) to allow you to access your meter readings. You can check it out here: stmrocket/ha-smartmetertexas

5 Likes

Never knew about smart meter Texas!!

1 Like

@smccoy whenever I try to import the JSON I get an error: “Invalid flow: Unexpected token > JSON at position 5”. Any thoughts? Your JSON is much too long for me to know where to start looking haha

I’m not sure. I just trued importing the JSON from the repository and it imported without errors. Make sure you are clicking Raw on GitHub and copying the raw text as that can sometimes cause issues.

Yeah I just realized I had accidentally ended up with some HTML hiding at the top.

Actually now I am stuck as I keep getting a YAML error on the yaml file. “mapping values are not allowed in this context”
end of the stream or a document separator is expected at line 123, column 73:
… r-bar top-0 left-0" style=“width: 0%;”>

keeps sending me into safe mode and can’t seem to fix it

even if I take that “style” bit out though then I get another error further on…am I missing something about how I used this file…?

yep, I’m an idiot, still was pulling HTML…doh! Sorry and thanks for this integration!

Glad you got it working! I’ve been burned by that when copying from GitHub before. Let me know if you have any other questions!

Hello! Very nice integration youve made here! I do have a question however; since I deployed this, my numbers are only showing zero. My mqtt config is set correctly and the credentials are also inputted as saved in bitwarden, but Im not getting any readings. Am I missing something? Because I did follow all instructions in github. Thanks for your understanding and appreciate the hard work!

Thanks for the kind words. Mine stopped reading early this morning (interestingly, my local Zigbee monitor also stopped around the same time and required a reboot). I finally was at my desk when a read request was sent to watch the debug output. The server is accepting the authentication but when a read request is sent, it responds that the server is temporarily down. I’ll keep an eye on it to see if it comes back up and if not, do some checking to make sure the endpoint hasn’t changed.

I will report back here with an update…

Interesting that you mention that. I actually set up this on my end today at around 1 am, and wasnt getting any readings aside from 0. So in another words, it must be the same thing you mentioned. Perhaps it occurred at 12 am today? A server side switch?

It does appear to have been some sort of server switch. Mine started working intermittently last night and has been reading hourly again this morning. I’ll keep an eye on it to make sure, but it looks like they got the problem solved on the server side.

As an aside, how do we get our state to implement such an API? Is this a state mandated endeavor? My smart meter information can only be downloaded in PDF form through my electric providers website with no API.

Hmmm interesting. If it is working for you, then that must mean I have configured mine incorrectly. But it is good to hear that the system is working so I should in theory get a result with some trouble shooting.

Im not sure if its a state mandate. I think there was a debate around these smart devices in the texas legislature a long time ago. If it helps at all, the api “is not done” for anyone, according to the website. Only way to get readings before was to send your public ip, and an encryption certificate to open the details for setting up your end to read the data. Then there is also this, which so much easier and convenient.

Update: I kept my debug logs rolling and discovered that the meter number was incorrect. Apparently there were two spaces in the config file that threw it off. Im getting meter readings now! Ill post back if there are any other issues. Thanks again for cooking something awesome!

Great! I was going to suggest switching on the debugging nodes as their servers are pretty verbose when something is wrong. I’m glad you got it all working now. Please ask if you have any other questions!

Hi I got my account set up with Smart Meter Texas and I installed Node-Red from the Add On store in HASSIO. However, when importing it, I get the following message.
Imported unrecognised types:

  • https-node
  • config
  • credentials

Those are the nodes listed as prerequisites for the flow. You need to install the following in Node-Red:

  • node-red-contrib-config
  • node-red-contrib-https
  • node-red-contrib-credentials

I am having the same problem with all 0s. Can you give more details on how you resolved it? I’m not even sure what log you were looking at or where you fixed it.
The “build JSON” portion of the flow seems to work. If I put a bedug anywhere else in the flow beyond the inject nodes I get nothing.