The Docker Version of Home Assistant Supervised on UNRAID

Tags: #<Tag:0x00007f7394719a58>

This post is to share what I did, get comments from more experienced HA and UNRAID users, and suggestions on pitfalls I may not have encountered yet.

Having the typical issues with SD card dying every 8-12 months or so on my RP4 setup I have been looking at HA on other platforms.

I am am so far very pleased with @digiblur your UNRAID template for HA supervisor. So this is a docker version of HA Supervised rather than a VM approach. I see @digiblur mention a funny in the install in this video and others mention various issues but so far all is working for me. I suspect the HA developers maintenance of these docker containers have somehow fixed issues others’ noted in the video comments as I have not encountered much trouble.

Why go this way…for me docker containers are easier than VMs and lighter weight. I am a novice. Also, one issue I have is there are a few addons I have they I dont see available without the add on stores (Pentair control via MQTT and nodejs library addon for one) so I am wanting a supervised version of HA.

I ran accross @digiblur video on youtube where he made a unraid docker template for HA supervisior.

Here are my steps:

(1.) followed the video installing on unraid,
(2.) unlike the video mine installed many addon containers at once, I wasnt sure I needed to but I did make the minor change the video suggests and restarted the supervisor
(3.) My UNRAID IP:8123 then prompted the typical HA is setting up please wait
(4.) a few minutes later fresh install of HA with supervisor tab.
(5.) Backups for hassio on in the UNRAID appdata share, but when I went to copy my recent HA backup to it permissions prevented it.
(6.) I went to UNRAID . I first tried opening up permissions on appdata share but lower level folders where still inaccessible.
(7.) As a hail mary I noticed…UNRAID…Tools >New Permissions…selected ALL for both drives and shares…clicked start
(8.) then I could copy the snapshot file there to /mnt/user/appdata/hassio/backup
(9.) I restored it without samba and SSH…but including grafana, influx, esphome, mosquitto, nodred, maria db, HACS, and all kind of other customization.
(10.) all work right away (after I stop my HA on PI) with the exception of (1.) Maria DB which houses my state data, sensor data goes to influx and that is working…so history, logbook, recorder failed to load (2.) The pentair pool addon that makes want to stay with supervised which runs in a container of its on on my PI and sends data to MQTT broker.
(11.) When I look into docker tab for UNRAID I see all the HA addons as their ownb running containers for things that are working.
(12.) For the 2 items that I know are NOT working (pentiair add on and maria DB) I see orphaned containers‚Ķreferred to as ‚Äėorphan image‚Äô

So questions…

A.) Can anyone advise how to troubleshoot this ?
B.) More generally…assuming I can get these 2 functions working and its stable I plan to move to this permanently…can anyone forsee a pitfall here?

As extra data…The HA Supervisor system log I see has the following relevant entries…:

20-06-17 16:54:08 INFO (SyncWorker_5) [supervisor.docker.addon] Start Docker add-on hassioaddons/node-red-amd64 with version 6.3.0
20-06-17 16:54:08 INFO (MainThread) [supervisor.addons] Detect new Add-on after restore a0d7b954_nodered
20-06-17 16:54:15 ERROR (MainThread) [supervisor.addons.addon] Can't restore origin data: [('/data/tmp/tmphc6v8rkp/data/databases/mariadb.err', '/data/addons/data/core_mariadb/databases/mariadb.err', '`/data/tmp/tmphc6v8rkp/data/databases/mariadb.err` is a named pipe')]
20-06-17 16:54:15 ERROR (MainThread) [supervisor.snapshots.snapshot] Can't restore snapshot for core_mariadb
20-06-17 16:54:36 INFO (MainThread) [supervisor.api.security] /host/info access from a0d7b954_nodered
20-06-17 16:54:41 INFO (MainThread) [supervisor.api.security] /dns/info access from a0d7b954_nodered
20-06-17 16:55:54 ERROR (MainThread) [supervisor.api.security] Invalid token for access /info
20-06-17 16:56:00 ERROR (MainThread) [supervisor.api.security] Invalid token for access /services/mqtt
20-06-17 16:56:00 ERROR (MainThread) [supervisor.api.security] Invalid token for access /services/mqtt
20-06-17 16:56:00 ERROR (MainThread) [supervisor.api.security] Invalid token for access /discovery
20-06-17 16:56:00 INFO (SyncWorker_4) [supervisor.docker.addon] Start Docker add-on homeassistant/amd64-addon-mosquitto with 
1 Like

For the love of God - remove hass.io from the title. We are trying to move away from this confusion and this just perpetuates it.

@DavidFW1960 I can see I have unintentionally caused you undue stress, sure…what would you like it called that still conveys intent?

I over-reacted a bit. At first I thought this was a how-to, not a request for assistance. It’s just that using the old term for this, hassio in the title just perpetuates that old name and it’s easier to avoid confusion for noobs by not highlighting the old name in the title. Anyway I was suggesting you remove hassio from the thread title (not in the post)

I have been consideraing moving from vm on my main unraid server to docker on unraid on a powerful NUC equivalent (dell 9020m SFF).
I did a quick test the other day and everything restored but I didn’t play with it for long to see if addons were working correctly.

I run MariaDB as well so I might try specifically to see if that works for me when I get some time in the coming weeks.

If MariaDB doesn’t work as an add on another option is to run it as a normal docker image. Or go back to the inbuild db (the next release sounds like it has some major work in this space).
Link to beta release notes.

Well since this original post things worked very well however everytime I would update issues would arise. Restoring from snapshot got everything working but it was the older restored version of everything…

Mariadb worked in this mode.

I also used a seperate container for mariadb setting up database user and password with mysql commaonds from console link within unraid manually.

I also tried to build these database with -e variables in unraid template as per the linuxserver container notes for mariadb container. That method did not work for me.

At present I have given up on the supervised version and I am running the Core container for home assistant as a test slowly adding functionality from my Pi setup which is also running.

Maria DB as a separate container works here too but again I had to crease the database user and password with mysql commands from console window. The config seems to be in appdata folders to seems like a one and done thing you have to do.

Let me know if you are able to reliably run the supervisor version in docker. If you can I may switch back as there is an addon I dont see a container for. (Pentair)

And @tinglis1 thanks for the the note on teh databse updates in HA. Sounds very encouraging. Maybe go back to default.