The Supervisor joins the party

So execute that command in the ssh addon and then restart the supervisor?


So this has opened a can of worms! Now losing DNS on HA host, also losing ssh access. NM picking up dhcp DNS configs even though interface is set to static…think I’ll turn NM off again.

I agree core users should have a choice, which is why I would like to see it offered as an option on core.

I don’t understand what you want. There are options, install debian and the Home Assistant Supervised on top and there you have the supervisor.

HA OS is one ecosystem. Supervisor is one part of HA OS, and Core is another part.
It can kind of be duplicated by running a Supervised install because it all uses docker but that is still more “in spirit” . You don’t add Supervisor to core. It runs alongside it.

Is the ability to upload snapshots to restore directly from the supervisor snapshots page (without having to install SAMBA or SSH) on the roadmap?


It is being worked on, yeah.


Did you manage to fix the NM issues and get it working in static mode?

Weird. I edited /etc/NetworkManager/NetworkManager.conf as you did, and restarted the Proxmox VM and it shows the IP now where it should (shows it as using DHCP which would be correct as I use router reservation) No problems with ssh addon.
Going to apply to my main NUC now.
NUC seems ok as well. I had to restart the Supervisor container in Portainer… the ha su host reload command isn’t recognised…

ha su host reload isn’t the command. It should be ha su reload

If you want to reboot the host itself it would be ha host reboot

Thanks. Yeah. That was the command Ludeeus posted on the github issue. I wasn’t sure if he was wanting to reboot the host or the supervisor. In the end, reloading the supervisor didn’t make it work so I had to restart the container… maybe a coincidence? Reloading supervisor would be equivalent I would have thought…

Am also very eager to understand how I can use a Bluetooth speaker in Homeassistant… Digged through the fora, but couldn’t find any simple way to achieve it…

1 Like

Hi David, I thnk my real issues stem from the fact I’m running MS DNS & DHCP for my Active Directory and bind DNS a forwarder/DNS & some HA. Self-inflicted overcomplication come back to bite.

1 Like

None of them, ha host reload is what I meant to write :see_no_evil:

1 Like

I have the updated supervisor v245 and HA 0.115 on Debian 10 and i cant see the IP Address Change.

Right, you need to actually be using NetworkManager to manage your interfaces for that to show.

So wait for it… Where is the network manager and how to turn it on?

Edit : Sorry i am using Debian 10 server.

@balloob @ludeeus

Great release lightning fast and lots of goodies :slight_smile:.
Is there maybe also the long awaited new Google Nest API in the celebration box?

I saw a twitter tweet of this a few months ago and was wondering if you had some more news about it?

If you did not upgrade NetworkManager (still running the version that came with Debain 10 (1.14.6)) don’t bother setting it up just yet, it will not work.