TP-Link HS110 Smart Plug disappears after latest firmware update

Possibly but I think it’s a bit odd that the earlier HW revisions also got a firmware update yet still work with Homeassistant

I just did a test on the plugs i have here to see what is listening on different types and firmware versions.

Port scanning a HS110 with hardware version 1.0 and firmware 1.2.6 shows it has port 9999 open.
Port scanning a HS110 with hardware version 4.1 and firmware 1.1.0 shows it only have port 80 open.

So it does look like the 1.1.0 firmware on the newer hardware version of the plugs is what shuts down the 9999 local port and instead runs a webserver on port 80.

1 Like

Wonder if it uses a similar control scheme as the tapo ones.

When I have enough free time I might see If I can setup an AP connected to a switchport that’s mirrored to a machine running a packet sniffer and see if I can capture the conversation between the Kasa app and the plug.

They can still be controlled locally it seems as I blocked one from the internet and put my phone on my IOT VLAN and was able to still control it.

1 Like

Got a sensible but disappointing reply from them now.

So it looks like we were right. Bye bye TP-Link for me…


No more TP-Link hardware of any kind for me!

That said, I think one point may have been missed in this discussion.

I never created an account on the TP-Link server using the Kasa app. I was able to detect and set up my HS110s from the app on my internal WiFi network. I think this means the devices were never given a Kasa account which they would need to access the TP-Link servers. At any rate, my HS110s do not appear to be auto-updating their firmware.

Within the Kasa app there’s an option to identify available firmware upgrades, and to upgrade my devices. I have not done that and the devices aren’t updating on their own.

Obviously I can’t use the Kasa app outside my network (that’s what HA is for!) but maybe not associating the devices with a Kasa account at setup time is what saved me. Maybe it’ll help someone else.

Yes, I think you are correct. I didn’t have an account, so I manualy upgraded the firmware from the Kasa app. There was no notification that it was available, I checked because I was looking for a fix for the spurious power figures I was getting.
However, my other HS110s are staying in their boxes for now, just in case.

Anyone have any recommendations for UK plugs which support MQTT as an alternative?

Sonoff S31 flashed with Tasmota works great in the US. Maybe they make an equivalent for the UK?

The sonoff s26 has a UK version and is flashable with tasmota or esphome.

I think he wanted a device that could also monitor power.

You may want to check out Lists all tasmota supported devices.

Thank you! I had one HS100 HW 4.1 with the old firmware still in the box, and now activated it without an account. Hopefully it’ll remain that way.

I also saw this:

I don’t know enough about HA and coding to understand what he’s saying, but if it works, maybe someone can dumb it down for me with an example. :relaxed:

Bummer, I was wondering why all my routines for my HS110 didn’t work anymore. Have put a block on their IPs as one HS110 hasn’t been upgraded but this ‘update’ is unfortunate.

Anyone recommend any other smart plugs for the UK? I see Hive have some, as I have their heating system are they any good?

I just ordered a couple of sonoff s26 plugs which i plan to flash with ESPhome and manage locally only. They don’t do energy monitoring but for a couple of specific use cases i have it is a start.

I got some of these, Gosund UP111, and they’re now running ESPHome successfully:

Flashed with tuya-convert (first time I’ve used it) and had a few gotchas along the way:

  • tuya-convert can’t install its dependencies on a Ubuntu live USB
  • My laptop doesn’t want to run Ubuntu properly without lots of messing about
  • Putting a RaspberryPi OS card into my HA Pi was far simpler and worked perfectly
  • The default tasmota it installs will only allow firmware updates when connected to your WiFi, but it has weird restrictions on both the network name and password. Max 32 chars and only letters and numbers for both! Took most of yesterday afternoon to figure out the hyphen in my network name was the problem. Grrr.
  • ESPHome needs lots of config and the energy monitoring needs calibration (apparently my mains is 630V at the moment!) - luckily this page has a great walk through and template config that worked with minimal modification.
  • I did add a fallback AP to the WiFi section (copied from the config the esphome wizard produces) and I was grateful because…
  • The plugs seemed unreliable with DHCP and needed to be set up with static IPs

So not anywhere near as simple as the TP-Link plugs but it works and will hopefully keep working indefinitely.

Just need to find the time to calibrate the energy monitoring and replace the automation that use it, but I’ve got one which doesn’t depend on power measurements in and working so far.

How recently did you buy them? I bought four in March 2019 and tuya convert worked great with them. I bought two more in August 2019 but Tuya convert failed on them and they didn’t have power monitoring.
I believe they no longer include the power monitoring hardware, but newer versions of Tuya convert do work.

Ordered on Thursday. They definitely have energy monitoring and were advertised as such. While searching I did notice that the Teckin plugs previously recommended in various places are no longer available with energy monitoring, so are presumably the newer version which does not work with tuya-convert.

Handily, these came in a box with no seals on, so if they didn’t convert it would be easy to send them back as unused.

One thing I did notice while testing with a heater to calibrate the energy monitoring is that they got noticeably warm with 2kW running through them, and definitely warmer than the TP-Links. I would be wary of running them with any high power devices, despite the 13A rating.

Not a problem for the dehumidifier and subwoofer that I currently have hanging off them, but I don’t think I’ll be using them to alert when the washing machine finishes.

Thing that puts me off a lot of the plugs that can be flashed with ESPHome or Tasmota is they are often from no-name companies you’ve never heard of and with the amount of dangerous junk being pushed out by some of these companies who then disappear at the first hint of trouble.

It’s probably ok if you know what you are looking at and can open them up and verify the design but I’m not confident to do that so it becomes really difficult to tell dangerous ones from the safe ones. It’s a shame because not all companies/sellers on these platforms are putting out unsafe junk.

At least with someone like TP-link assuming you haven’t got a fake you can be fairly confident they’ve at least passed all the required testing to be legally sold in the UK.

If you have connected your Kasa plugs to the cloud and have access to a Hubitat hub there is an excellent community driver that can be used to unbind them so there cannot auto-update. That is exactly what I did when I first heard about this. All of my devices are still working.