TP-Link HS110 Smart Plug disappears after latest firmware update

I was having problems with this plug giving occasional spurious power readings, so I checked for a firmware update on the app. There was an update to 1.1.0 available so I installed it.
It seemed to install OK, and the device reappeared in the app. However, it’s no longer available in HA. I tried removing the integration and re-installing it, but it still doesn’t find it.
I haven’t tried intalling the integration manually as I don’t want to reboot my system.

1 Like

I tried setting it up on my test system in configuration.yaml and I’m getting errors:

2020-11-11 14:36:11 WARNING (SyncWorker_9) [homeassistant.components.tplink.common] Unable to communicate with device 192.168.16.51: Communication error
2020-11-11 14:36:11 WARNING (MainThread) [homeassistant.components.switch] Platform tplink not ready yet. Retrying in 60 seconds.
2020-11-11 14:37:11 WARNING (SyncWorker_35) [homeassistant.components.tplink.common] Unable to communicate with device 192.168.16.51: Communication error

I can ping the device OK and I can see it in the Kasa app, so the only thing has changed is the firmware. Another victim of the dreaded device lockdown syndrome?

Mine has disappeared too. So I removed the integration to add it again, and now it can’t even find the plug on the network. Kasa app works fine.

What firmware version are/were you both using?

My two HS110s show their firmware version as 1.2.5, and the app says I can update to 1.2.6.

The hardware version is 1.0. So far they seem to be working well in HA 0.117.5 with the TP-Link integration.

Now: firmware 1.1.0, hardware 4.1. That for a HS100, U.K. plug.

Ahh, OK. I guess we’re not going to be able to compare notes. Sorry!

I’ve got exactly the same problem. HW v4.1 and firmware 1.1.0 got automatically installed on one of my plugs that I had forgotten to block from the internet in my router.

After a bit of sleuthing I found this description of the protocol: https://www.softscheck.com/en/reverse-engineering-tp-link-hs110/ and it appears that the new firmware does not have port 9999 open while my unupdated plugs do. Worryingly, the description for the 1.1.0 update offered for another plug says “Enhanced total encryption and security”. Does TP-Link not want us using their plugs with HA?

Yep, same here. It’s a UK style plug and I still have two other which I thankfully hadn’t gotten around to updating.

I’m in the UK too, for what it’s worth.

I’ve emailed TP-Link support to ask if they can fix it or tell me how to downgrade the firmware. Not expecting much but it’s worth asking!

Otherwise, what’s a good smart plug with power monitoring available in the UK that works with HA?

Most of my plugs are Teckin SP23s that I got on Amazon UK last year. I’ve flashed them with ESPhome and they work great, but you have to calibrate the voltage and current settings.
Sadly, I ordered some more a few months ago, and they no longer include power monitoring so I sent them back and got the TP-Links instead!

Wow, that’s disappointing. The TP-Link devices are a pretty good value for both control and monitoring. Most options in this price range only offer on-off, not voltage.

But if they’re moving away from allowing HA (and presumably, any other third-party system) from using them, they are no longer an option as far as I’m concerned.

I wonder if that’s the “fix” for the “critical security flaw” Which? said to have found on the plugs.

1 Like

Well spotted, that looks like the source of the problem.

PSA: If you own a Hubitat hub you can use the TP-Link app to unbind the TP-Link devices from the cloud so you’ll never have to worry about them updating. The downside is that you can no longer use the app. (not an issue at all for me)

I have the same problem. In the UK and bought a pair of HS100 to use for my Christmas lights this year. Upon installation of the plug using the Kasa app it performed a firmware update to 1.1.0. I have been wondering why the new plugs were not being discovered by home assistant (my other 6 work fine). Looks like it is this firmware level which broke it.

Does anyone know which DNS names to block so all my other plugs cannot get the update?

I just checked my other plugs and it appears that the HS110 devices which are on firmware 1.2.5 and some on 1.2.6 I am still control via HA fine. (Hardware version 1.0)
Any of the HS100 which are on firmware version 1.1.0 are not discovered and not able to be controlled from in HA. (Hardware version 4.1)

I’m using the german version of HS110
It shows HW 2.0 and Firmware 1.5.6
Not sure when the last update was but it is still available in HA
as soon I get an firmware update I will not install it

1 Like

Copied from my post at Tp-link HS100 H/W 4.1

I have a few HS100 plugs that were purchased at different times, so I happened to end up with different H/W versions.

H/W V1 Firmware 1.2.6 - Works
H/W V2.1 Firmware 1.5.10 - Works
H/W v4.1 Firmware 1.10.0 - Communication Error
KP303 - HW 1.0 Firmware 1.0.4 Also works.

So oddly whilst the older H/W versions also got a new firmware they still seem controllable by Homeassistant

Annoyingly the 2 I use most often ar the HW 4.1 ones :frowning:

I’m in the same boat, one of my plugs is on hardware version 4.1 and firmware version 1.1.0 and I can no longer see the device in HA. Blocked the other plugs in my network from connecting to the internet so hopefully those will continue to work in HA. This is very annoying.

How did you do that? I’ll have to do the same for the hs100 I still have untouched in a box. Ta!