TP-Link Kasa - adding new device? No auto-discovery?

I cannot for the life of me remember how to add a new device. My TP-Link integration has been working fine for ages (and I’m sure I’ve even done this before), but the new HS100 switches that I finally got round to opening won’t show up in HA.

They work fine in the Kasa app, and Alexa found them immediately through its Kasa skill, so why won’t HA?

I can’t find any reference to a setting for auto-discovery of new devices or how to force the integration to scan for new devices on the network. Am I missing something obvious? I’m on the latest HassOS 4.11 and there are no pending updates to Home Assistant, so I assume I’m on the latest there too.

1 Like

You might just need to restart home assistant for it to pick them up.

Haha, thanks. That’s all it was. Two hours wasted trying to find a non-existent configuration setting. :roll_eyes:

1 Like

Shouldn’t the ability to launch the discovery of devices be an option? This seems like a very basic function.

I think the inability of the HA integration to do this is a big part of why these devices keep going “unavailable” even though other apps like Kasa have no trouble connecting (or re-connecting, as the case may be.)

1 Like

for someone whom is considering buying some kasa devices, a question i have is… are these usable without setting up cloud function? i’d prefer to keep everything locally controlled if at all possible

There are two parts to that question:

  1. Yes, you can use them without the Kasa cloud. The Kasa app works locally, connect over your LAN with no account on their servers. Once set up, no need to ever run the app again, except…

  2. No, they’re not fully functional in HA. The Kasa app works fine, and I’ve heard that the SmartThings hub works fine. But the HA integration can’t handle any network disconnection or instability. You may have to regularly re-start HA to get it to pick up the TP-Link devices. It’s a bug, but HA is a volunteer project and no-one has volunteered to fix it. Anyone willing to give it a shot is more than welcome!

I setup a Kasa KP303 power strip using a github-sourced python library - this one I think. No Kasa / TP-Link app, no account, no cloud.
I’ve configured it within HomeAssistant using the UI and blocked it’s external access except for NTP and it works without issue **

**I’ve had a single instance of it becoming unavailable in HA (after 0.112.4 update I think) - I deleted the integration and re-added and it’s been stable since.

thanks for the information guys. i’ve just been looking at low buck, zero cloud, alternatives. i do like z-wave, but it gets pricy so anything that is a reliable smart device, with minimal effort(family time takes priority over DIY projects) as a plus for me!

Despite my disappointment with the HA integration, I think you’ll find that if you can maintain a rock-solid IP connection to each device, you’ll probably be OK with the TP-Link stuff. And they are a lot cheaper than anything comparable for Zigbee or Z-Wave.

The problem is that WiFi networks tend to be somewhat dynamic. For example, if the power goes out, my router and my neighbors’ routers, as well as some other devices nearby, tend to pick new channels to use. After that, the fringes of my network might suddenly experience interference they didn’t before. Since the HA TP-Link integration is more sensitive to dropped connections than just about anything else I’ve ever used, I’m always tweaking the network to keep it happy.

Per this thread…
I am unable to see my HS100 smartplugs. Within the past couple/few releases TP-Link Kasa stopped working. Unable to see them after repairing.

Will be trying to port them through smartthings hub next
UPDATE: If you have smartthings, I recommend using it as a workaround. How to configure the Kasa device to work with SmartThings APP | TP-Link Adding them this way reconnected everything (sensor names stayed the same also).

1 Like

+1 to this… TP-Link integration has a lot to be desired, but I have 60 TP-link devices in my house, varying levels of firmware, purchased over the last 2 years, and they all work perfectly with HA, with ONE caveat.

Occasionally, when I reboot HA, the tp-link devices will ALL show unavailable, or MANY will be unavailable, and they will never return, until I go to the integrations tab and reload that single TP-link integration. Once. Then all the devices come back and stay back.

I reckon this is a timing issue, some of the lights or the cloud or whatever is unavailable when HA boots and it gives up, but upon a second try, everything is ready.

Anyway, all that to say, in my opinion, TP-Link integration is “good enough” to warrant using these very fine and inexpensive devices to control your plugs and switchs. You will have some issues, and if you are wanting local only – no cloud even to set them up – this isn’t for you.

Yes, I have seen the same thing. I agree that the hardware is pretty decent, and as long as there is a local option, I can accept that it has cloud capability, too.

What I’m finding is that I’m getting away from IP stuff and leaning more toward Zigbee lately. IP seems more fragile, flakey, more cloud-dependent or at least cloud-impacted (think, breaking updates.) It requires good network design and a strong signal throughout the house, and more setup and maintenance. Obviously YMMV.

We are on a similar journey it seems! :slight_smile: I have shied away from Zigbee even though I am an amateur radio operator and the technology makes a lot of sense in that spectrum. As a router engineer, naturally, IP seems great, my home network is rock solid, and that was the obvious choice, so I implemented nearly 100 TP-Link devices.

Now, as I put some Hue’s and other zigbees in, I’m seeing the benefit of keeping my IP network free of the IOT switch chatter, so I can indeed be completely cloud indepentant and control my own destiny, so to speak.

As you said YMMV! :slight_smile:

1 Like

Yes, jwhowa, I thought IP devices were the way to go at first, and I too have a background which includes networking.

But I’m finding that I really like the plug-and-play nature of Zigbee. Sure, I can do all the network design and administration tasks required, but with Zigbee, I don’t have to. It self-configures pretty well. And with a few well-placed mains devices, I’ve extended it well beyond the area I want to light up with WiFi. Plus I’ve kept a lot of IoT devices off my IP network.

I guess you could say I’m becoming a fan.

Look like nothing new on this front… tried adding the TPLink Kasa integration again… I have several Kasa devices and only 1 shows up which is odd. Wish this worked better.

EDIT/UPDATE; Turns out this is due to my KASA devices being on a different subnet that HA, I created a wifi network for my IoT devices, now it is working.

This is the way to force “auto-discovery” or manually pickup a new device with a static IP address:

1 Like

Had the same issue and was able to resolve it. None of the suggestions in this thread worked for me but here are the steps I took:

  • Assigned a static IP to one of my TP Link wifi smart plugs from my router. I’m using a unifi network system so it was pretty easy to do.
  • Power cycled said smart plug to get it to take the new IP.
  • HA immediately recognized every smart plug other than the one I had assigned a static IP to (???)
  • Disabled the static IP assignment to the one plug and power cycled it to give it a DHCP address
  • HA picked up the last plug after it booted back up.

It might have just been a matter of power cycling the one plug as I did not try that before assigning a static IP. I randomly chose a plug to do that to as HA wasn’t recognizing any tp link plug on my system. I’m not sure how to recreate the issue to test but if they all drop out again I’ll report back on my findings.

The other tips didn’t work for me. I had restarted HA many times, verified that the devices were on, working via the tp-link app, etc. The python lib didn’t help either…

The thing that did it was to go into the unifi dashboard > devices > select the TP-link device > settings > reconnect device. Immediately the devices were discoverable via HA > Add Integration.