TP-Link Switches going "Unavailable"

Last Year I purchased a number of TPLink smart switches (HS100 and HS110) and they worked fine for a while - but earlier this year (May I think) they started to go “Unavailable” after a while. I first noticed this after a power cut, and it’s been an issue since.

As they are all in the same room I have tried putting them on their own WiFi network which is limited to the single Access Point in that room and 2.4GHz only (as they are 2.4GHz only devices), and have also put them in their own VLAN on my UniFi controller (My WiFi network is UniFi and no other device has issues staying connected). I have also changed WiFi Channel.

In the Kasa App you can see the devices switch between Availalble, Unavailable, and “Local Only”.

If I reboot the Switches themselves, my UniFi Switch (and by extension both Access Points), or the Single UniFi Access point they connect will often work flawlessly for a day or so, or maybe longer if I’m lucky. But then semi randomly they will start going through the available/unavailable toggle - when they are unavailable pyhs100 is also unable to connect. They never vanish from the UniFi controller (shows them connected for days unless I’ve reset/rebooted)

It might be a coincidence but on one occasion I noticed all of them suddenly started toggling when YouTube updated on my LG Smart TV (it turns WiFi on when it does) and they often start throwing a strop when I wake up or return home after being okay all day, or in the early hours (I notice a similar model of TV we have at work turns on for a minute or so around 02:00 - presumably to scan for Freeview changes). However this may be a red herring as they still did it when the TV was away for repair - so it might be Chromecast related, or even me being in the room. May may also be key as that is when we switched from a prolonged winter into a perpetual heatwave (room being between 20 and 32’c since then, 13 and 22 until then).

Any ideas on what might be going on, and how on earth I can fix it? I Don’t have issues with anything else (e.g. Hue only go unavailable when the light switch is turned off).

Bizarre. One of my TP-Link switches (HS100) just stopped responding today too. The other one still works fine. :confused:

I have the same thing happening now and then with one HS105 and one LB110 - but as all the others are working fine, I thought it was an issue with my WiFi because I have a Emerson Sensi thermostat that keeps dropping off infrequently as well.
Tried to find a solution together with Ubiquiti - I have 3 Unifi APs - but could not get it resolved.

1 Like

Hmm, I dug out my old DD-WRT Router (used as an Access Point) on Thursday night - renamed its SSID to be the IoT one (and disabled that on the UniFi controller) and connected it to a port on the switch assigned to the IoT VLAN and it’s been rock solid since.

(Well not 100% rock solid on one TP-Link switch, but that’s down to a weak WiFi signal, hence why I switched to UniFi in the first place)

I’m now wondering if the constant drops coincided with a UniFi update that I only happened to notice after the power cut!

Hi @kevjs1982 - did you go back to your UnifiAP?

I just saw this in my history earlier today:

While MPlug3 stayed online all the time, MPlug4 dropped off the network 7 times between midnight and 8am.
They are both the same model (HS105), both on the same firmware version (V 1.5.1), both in the same room and I actually bought them together as a 2-pack :confused:
The only difference I can see is that the WiFi signal at MPlug3 is -39dBm while the one at MPlug4 is -46dBm - but that shouldn’t cause any issues.

Na, still using the Buffalo for the HS100s and HS110s and they are staying connected fine - the one with the weakest signal drops off for less than a minute around once a day. For all practical purposes they are now 100% reliable.

Next time I update my UniFi gear I’ll give them another crack on the UniFi gear.

I just installed a HS200 switch in my garage and am seeing the same thing. I’ll bet it went unavailable 100 times in a 16 hour period. It’s in my garage, but I have great wi-fi signal in the garage. I’m using a Asus RT-N66U router.

I also get this error in my log each time.

Could not read state for Garage Lights: Communication error

Did you find out what your problem was?

Haven’t seen any of my switches going ‘unavailable’ lately, but my LB110 is throwing a fit at the moment :frowning_face:

Reset it completely, upgraded it to the latest firmware, gave it internet access, etc. but nothing helped so far.
I get loads of messages in my log like you do, plus these ones in the Logbook:
2:53 PM Patio Light changed to unavailable

I may have solved this. I assigned the TP-Link switch a static IP address in my router. I’ve now gone about 14 hours with zero unavailable messages.

1 Like

I keep the :crossed_fingers: for you - all my ‘oh so smart’ devices have a fixed IP already.

Nevermind, that didn’t fix it. It’s now constantly going unavailable again. I think I’m going to throw the switch away and get something else.

Sorry to hear that.
i have a few HS105 and one of them kept disconnecting just like my LB110 does - it now stays connected reliably, no idea why.

I am seeing this on all TP-link devices, an HS100, HS110 and HS200. They all suffer from the same problem. I also noticed that they actually go unavailable from the Kasa app as well, so this seems to be related to the devices themselves, maybe not a home assistant issue. Very annoying

I have a hs100 used to switch on my lamp. It has a static ip address, yet sometimes twice a day HA can’t communicate with it (unavailable) for a couple of mins then comes back again.

Problem is it sometimes happens When automation are set to trigger

I’m having the same issue with 3 TP-link bulbs. LB110 x2 and LB130 x1. One of them seems to go unavailable hundreds of a times a day while others off and on but enough for me to see it in the mobile site or on my tablet when I check.

Tried resetting, static IPs… nothing seems to make a difference. :confused:

EDIT: I just changed the channel on my router to 11 and all the signals have improved. It’s only been about 15 minutes but no unavailable issues so far. Prior to that it was every few minutes if not more on a the one bulb so I’m hoping this does the trick.

I had the issue after a firmware update to my tp-link bulbs. I am using a single ubiquiti AP for my IoT devices. The AP was on channel 11 and my sonoffs and tp-links were getting a lot of wpa association timeout failure/retires. Eventually the sonoffs would reboot. I changed the channel to 6 and it seemed to level out the devices having issues. My LiFX and ledenet bulbs never had an issue.

Crossing fingers it stays that way :slight_smile:

Just bought a HS110 as I thought these things were reliable but am seeing the same problem. The device keeps going ‘unavailable’. Any solutions yet?

Take a look here

I solved it by adding an extra (old) router to extend/boost my wifi. Haven’t had the problem since I did this.

1 Like

I have two UniFi APs in my house. Never had a single issue with WiFI with anything until I bought this.

Tips I’ve seen elsewhere are to ensure that the devices can only connect to one Access Point, with simple ASCII characters, and on Channel 13, and ensure the SSID is 2.4 GHz only. Since doing that and updating the firmware on the AP to version the problem seems to have vanished. Current controller version is 5.10.17, but it worked well on a 5.9 version for a few months

1 Like