Trouble Installing Coral Drivers

I have Home Assistant OS running on a Dell Optiplex 7040 PC with an i5 processor. I’ve starting using Frigate and like it, so I purchased a Coral. The Coral is PCIe, so I installed it using a PCIe to PCI adapter card. I tried setting up frigate.yml to point to the Coral, but its not detected. On my PC’s BIOS, it is showing that a device is recognized in the PCI port, and is calling it “unclassified”.

Based on the below link, it appears I need to install the drivers for Linux:

I’m following the procedure, which involves interfacing with the Linux PC via command line interface, which I am accomplishing using the SSH addon in HA. Based on the instructions, I need to perform the “workaround to disable Apex and Gasket”, which are explained here:

This is the step where I’m having trouble. As instructed, I made a file blacklist-apex.conf with Notepad on my Windows PC, and copied it to the config folder on the HA PC using the Samba addon. Then I copied it from there to the proper folder /etc/modprobe.d using Linux commands via SSH. After copying, I can confirm the file got copied into the folder using the Linux command “ls” to list out the files. However, when I reboot, the file disappears, and the workaround is not accomplished. This is where I’m stuck at the moment. I’m thinking that I’m doing something wrong regarding copying the file in Linux, mainly because I know very little about Linux. I suspect I’m make a novice error on the command line. Here is the commands I am entering to copy the file from /config to /etc/modprobe.d:

cd …
cd config
cp blacklist-apex.conf /etc/modprobe.d
cd …
cd etc
cd modprobe.d
ls

The last command lists the files in the /etc/modprobe.d folder and it shows that the new file is indeed there. However after a reboot, it disappears.

I appreciate any help you guys can provide.
Vance

You only need to do the blacklist if you have apex installed before step 1. It is normal to have it, once you followed after step one, cause it will install apex and gasket.
What do you get when you run
lspci -nn | grep 089a

1 Like

-bash: lspci: command not found

That was step 5.
Which step did you skip?

I stopped at step 2 listed here:

Step 2 said I needed to do the workaround to disable Apex and Gasket. I did not try proceeding with the rest of the steps yet. Since I can’t get the Apex and Gasket disabled.

Did you find a solution? I’m at the same crossroad.

I am stuck at step 2 also. it does seem that modprobe.d directory is being reset before HA is starting. this is why blacklisting apex is not working :frowning:
But what to do next any ideas?

Just to bring closure to this thread, I did get my Coral working. What I found out is that with Frigate, you don’t have to follow the steps on the link I posted above (with the Linux command-line stuff). All you have to do is create the configuration yaml file in HA and it should work.

What I did to get mine working, was I changed to a different “version” of Frigate. When you install Frigate you have to choose between “Frigate NVR” and “Frigate NVR (Full Access)”. I don’t recall which one I started with, but I uninstalled it and switched to the other one and the Coral was detected. I think I started with “full access”, but I’m not sure. Hopefully this helps someone struggling with the same issue.

1 Like

Thanx man, struggling with the same. Went from full accsess to regular frigate. Works!