Troubleshooting Z-Wave - Unable to pair device

I’m after some trouble-shooting pointers. Given the current Covid-19 lockdown situation I’ve decided to move from OH to HA. My Z-Wave was working fine on OH, on HA I just can’t add my switch.

AEON Labs ZW090 Z-Stick Gen5
Fibaro FGS-213 Switch
HA Installed on VMware ESXi 6.7 using this guide. OH was on same setup different VM.

Clean install
Supervisor > System > Hardware
Confirmed /dev/ttyACM0 device:

Configuration > Integrations > Add > Z-Wave
Used /dev/ttyACM0 and created a random key (from here)

Configuration > Devices
Lists “AEON Labs ZW090 Z-Stick Gen5 AU”

Configuration > Z-Wave > Nodes
Also lists the same stick as Node:1 Complete:

Click “Add Node Secure” in HA, and cycle S1 three times on the FGS-213.
Wait 15 seconds, click Heal Network
Nothing in OZW Log that shows anything about a remote device even communicating:

2020-04-27 22:31:35.654 Detail, Queuing (Controller) Add Device
2020-04-27 22:31:35.654 Info, Add Device
2020-04-27 22:31:35.654 Detail, contrlr, Queuing (Command) ControllerCommand_AddDevice: 0x01, 0x05, 0x00, 0x4a, 0xc1, 0x0a, 0x7b
2020-04-27 22:31:35.654 Detail, Notification: ControllerCommand - Starting
2020-04-27 22:31:35.655 Detail,
2020-04-27 22:31:35.655 Info, contrlr, Sending (Command) message (Callback ID=0x0a, Expected Reply=0x4a) - ControllerCommand_AddDevice: 0x01, 0x05, 0x00, 0x4a, 0xc1, 0x0a, 0x7b
2020-04-27 22:31:36.365 Detail, contrlr,   Received: 0x01, 0x07, 0x00, 0x4a, 0x0a, 0x01, 0x00, 0x00, 0xb9
2020-04-27 22:31:36.365 Detail,
2020-04-27 22:31:36.366 Info, contrlr, FUNC_ID_ZW_ADD_NODE_TO_NETWORK:
2020-04-27 22:31:36.366 Info, contrlr, ADD_NODE_STATUS_LEARN_READY
2020-04-27 22:31:36.366 Detail, Node001,   Expected callbackId was received
2020-04-27 22:31:36.366 Detail, Node001,   Expected reply was received
2020-04-27 22:31:36.366 Detail, Node001,   Message transaction complete
2020-04-27 22:31:36.366 Detail,
2020-04-27 22:31:36.366 Detail, contrlr, Removing current message
2020-04-27 22:31:36.366 Detail, Notification: ControllerCommand - Waiting
2020-04-27 22:31:36.366 Info, WriteNextMsg Controller nothing to do
2020-04-27 22:32:26.151 Detail, Node001, Queuing (Controller) Request Node Neighbor Update
2020-04-27 22:32:26.151 Info, WriteNextMsg Controller nothing to do

In an attempt to rule out anything OpenHAB I’ve also factory reset both devices, and started again with a fresh HA instance, but same results, just nothing shows up and nothing in the logs. Using “Add Node” rather than Secure has the same results.

Anything obvious I’m missing here / where else should I look?


Note - I replaced the device and the replacement worked instantly after clicking “Secure Pair” - So I was obviously dealing with a faulty piece of hardware.

Don’t know why it worked in OH and not in HA but I can’t get it to pair outside of HA now anyway… So in the bin it goes.

Did you try excluding it (Remove), then include again?

Yep, multiple times. Also started fresh with zwave2mqtt on a RPI4 and had the same issue. When the new gear arrived it paired instantly on HA. Pretty confident I had a faulty switch.

I think my original comment around it working perfectly in OpenHab was wrong. It definitely used to, but I hadn’t actually used it for a long time, and I didn’t test it before I wiped OpenHab (my bad).

So hearing you, but I’m 99% sure this was my problem / faulty hardware rather than an HA problem.

The replacement one and other Z-Wave devices I’ve added have worked flawlessly since. I’m still using the standard/legacy/whatever HA Z-Wave too, not the zwave2mqtt.

Now that you know it’s not likely to be HA’s fault are you now willing to walk that statement back a bit?

I’ve been using zwave with HA for over three years and almost never have an issue with it.