Trying to configure IFTTT, but HA says I'm not accessible from the internet

I’m trying to configure the IFTTT integration from the integrations tab on the configuration settings page, but I get the error, “Your Home Assistant instance needs to be accessible from the internet to receive IFTTT messages.”

Now strictly speaking, HA doesn’t know it actually is contactable from the internet, because I have access to it reverse proxied through nginx with an SSL frontend. It would be nice to be able to say, “Hey, you are actually accessible, please let me do this.” Or perhaps just allow me to tell the configuration the URL to use to get at HA.

Is there a way around this issue, or am I stopped dead? I’m using v0.80.0.

You need to configure a baseURL in config yaml. I ran afoul of this as well.

Awesome. Worked like a charm. Thanks!

Created an account just to thank you for this response!

It’s something that’s obvious in hindsight, but I wasn’t having any luck figuring out what needed to be done to get this working. Maybe some help text or rewording to make it more clear this is necessary.


1 Like

I cannot make it work. I am trying to set:






but nothing helps:frowning:
I have also reloaded whole software after every change. Any ideas what’s wrong?
The only option you didn’t list lol.

Thank you for your answer!
I tried the last option but it did not help as well. I am pretty sure that my config is correct (just uncommented the http part). The only idea I have is that maybe the apache proxy is messing it up? I have followed the guide.

Maybe… Someone posted an article about using nginx and caddy (reverse proxies) with the new auth.

I have tried with Caddy and Nginx but it still doesn’t let me connect IFTTT. I have also changed to subdomain of duckdns :frowning:

Edit: my bad, I had two configuration files and the docker was using the other one. Thank you for your help @DavidFW1960


same problem for me. (ifttt says : Your Home Assistant instance needs to be accessible from the internet to receive IFTTT messages.)

i have a nginx reverse proxy set up in front of home-assistant:
(nginx.tld:443 => homeassistant:8143)

i can access to my HA instance from internet, my configuration.yaml is :

base_url: https://nginx.tld

i can’t figure what’s wrong in my configuration… :confused:

Im in the same scenario. The only thing different in my config is that I don’t have the protocol specified.

base_url: nginx.tld


i use a subdomain i dont know if it’s the reason but it doesnt work either:

base_url: ha.domain.tld
-> KO

Whatever is in the browser address bar when you got the Hass website, minus the protocol specifier, that’s what goes in that config setting. I.e.,

If you’re using nginx, then put in the name of the URL that is accessible from outside the proxy.

that’s the one… :confused:

I’m having the same issue.
I have my base_url set.
I have port 80, 443 and 8123 all forwarded to 8123.
If I try I receive a 401: Unauthorized error so I know it’s accessable.
Other integrations do not report the Aborted error.
I noticed after a fresh install it actually tries and shows a spinning circle then after it fails it just instantly fails from then on.

I’m not interested in getting SSL to work until I know this will actually work.

pretty sure you need ssl to make that work and the url will be https. Not sure why you forward 80 to 8123…

Put the port number on a separate line in your configuration.yaml file

  server_port: 8123
1 Like

I forwarded 80 to rule out variables. Can you confirm you actually need SSL or is that just a guess? I had issues getting SSL to work thus why I wanted to see if it was even necessary before I work through that.

Thanks for the suggestion, I tried that but same issue.

99% sure. I’m not using it but when I added it, it wouldn’t even add until I set a https url for the base url.

i’ve upgrade to 0.81.1 but same problem.
base_url is up from outside and reverse proxy is working just fine (i can connect to my HA instance from work)

is there any way to put some debug mode on this ?