Tuya devices are slow to react - no changes to HA

A day or two ago my few Tuya devices (4-5 dimmers) started acting up. They mostly react to commands from HA (on/off/brightness) but the Lovlace rockers/buttons do not follow - turning on a light will flip the rocker, then it will return to off and most of the time (not always) it will return to on after some 30 seconds. Sometimes the rockers will never detect actual light status and thereby go “stuck” with no way of turning on or off a light that is already in the other state. Brightness sometimes work and sometimes not at all.

Operating directly on the dimmers work perfectly as do using the Tuya dedicated app.

I was on core-2021.10.5 and tried to remedy the problem late last night by upgrading to core-2021.11.4 and OS 6.6 but the behaviour was exactly the same.

My take is that there is something wrong with the Tuya cloud/API side of things. Anyone else experiencing this?

I’m slowly changing all my Tuya devices to pure Zigbee ones. This problem is making me speed up the process.

Video (I press the ‘Guest room’ rocker at the bottom ONCE): Video Link on Vimeo

4 Likes

I literally just signed up to ask this exact question. I’ve been using H.A for about 3 weeks, but the last day or two I’ve noticed my floorplan very slow to react (10-20 seconds). Is doing the same thing with toggle switches, reverting back to old state until the 10-20 seconds for it to update. My Tuya app is working perfectly though.

3 Likes

I have the same issue here, I have noticed that toggling on the dashboard is slow to react but changes from automations often never update without a reload. On the tuya mobile apps my iPad works fine but on Android tapping on some devices to go through to the more detailed view just gives a spinning wheel, others work fine. I am on the central european data centre.

2 Likes

I filed a service/support ticket on the Tuya dashboard (service.console.tuya.com). I don’t know if there’s going to be a response/fix and/or even if that’s the correct channel for this but bug feedback is really obscure on the HA platform for integrations and other issues. Maybe someone from HA reads the community to pass problems on?? I don’t know. I’m already the laughing sock in my family for non working lights and switches at home so any help on this is appreciated (it was working a record 3 weeks before this incident).

2 Likes

Still a major problem!

I got the following back some 4 hours ago from the Tuya Service Support:

when you check the log, you can see that the closing and opening are all operated by the device itself. Please try to unbind and reassign network binding, and then test the switch on the APP to see if there will be such problems again

I never got any response to my follow up questions about what log they are referring to, what network binding to reassign, which APP to switch on and/or on inside of and if they are working on the problem still…

Not really sure what they are on about, sounds like a canned response though. I have repaired devices, changed their wireless network, deleted and reinstalled the integration, even changed the hardware of the Home Assistant all to no avail. Pretty sure this is a problem their end. Even the android app i have reinstalled, and repaired devices. Oddly it works on my iPad, I wonder if they updated the Android app to their new API but not the iOS version yet.

1 Like

Sounds like you really tried everything! But just to be clear, my Tuya Smart app works flawlessly, It’s the Home Assistant app and Interface that malfunctions i.e. the Tuya connection/integration inside of HA. I think (not 100% sure) the HA interface is the same no matter which device or app you are running - especially in regards to integrations.

My devices started to show silly responses… the door sensor is open on lovelace for 3 hours which is nonsense and this situation ruins the whole automations. Everything was fine 2 days ago…

1 Like

I just opened an issue on Tuya devices are slow to react - no changes to HA · Issue #59911 · home-assistant/core · GitHub

I’ve also noticed this problem of slow response, but when I try to reload the tuya integration, it will respond quickly for a few minutes. could be something on the reply of tuya server?

1 Like

I’m with the same problem.
I have a huge delay from the moment I press a button on HA and tuya switch make for example turns on the light or even though I press the button on HA and nothing happens.

This behaviour has no more than 3/4 days.

For all comments here It seems to be a problem with Tuya server.

2 Likes

I have the same problem.
Thanks

Following.

I just installed updated Tuya integration after HA upgrade, super slow response. Android APP is responsive.

(edit)

Further work with this, it seems the entities are Lovelace are not responsive (erratic?) or being updated, yet my automation by area seems to be working well and are responsive. For example, my Tuya entities in area “Office”, respond to automation that refers to an area in a timely manner.

Same problem here. It’ really frustrating.
HA stable core-2021.11.5

Just to say I have the same problem too, upgraded to 11, rolled back to 10, re-upgraded to 11.
I tried to remove and remake the integration, but then it says that my ip is outside the specified region on Tuya IoT (it is not true, of course) and the only way to get back the integration was to roll back to the backup.
On HA commands pass through, I can turn on, off and change the color of my led strip, but the status almost never updates.
On Tuya IoT I removed and re-authorized “Device Status Notification”, the name seamed to imply something :sweat_smile:
Android APP is NOT working flawlessly, too.
I’m positive it is a problem on their side.
I’m on HA 2021.11.4

Also having this problem, and having just switched everything over to the HA Tuya integration, I was doubting I had done it correctly. I’ve removed / re-added with no success, there’s an 8-10 second delay with updates, trying to run an automation in this 8-10 period on the same device causes nothing to happen. Very frustrating. The Smartlife app works fine every time.

Can confirm. Also have (fresh integration) delay…

It is was so bad. Response can be like 10 seconds.
I have reverted all my devices to LocalTuya. Really had high hopes for official integration, but…

I am also having Tuya issues. Makes everything feel sluggish and/or non-responsive.

I am using HA 2021.11.5 on an RPi4. HA OS 6.6. stable build