Tuya Heater shows as a switch instead of a climate entity

I don’t see how I could possibly alter this via my configuration but thought I’d would ask before filling an issue.
Got a Tuya heater setup in Smart Life and in app has climate controls. The device brought into HA only acts as a switch.

1 Like

Looking for a solution too. I got a Heat Storm HS-1500-PHX-WIFI Infrared Heater. It is all setup in the Smart Life app with temperature control, etc. However, when using Tuya integration within HA, it only shows as a switch on/off.


Did you guys end up finding a solution? Same issue here, with same heater, Heat Storm HS-1500-PHX

Shows up as switch in HA, but completely controllable in Smart Life app. I have a second Heat Storm heater (different model) that works fine in HA with the Tuya integration

Have not, but that is quite interesting that your other heater is feature complete in HA. I might take a poke around the Tuya integration then

If it helps, the heater that is working perfectly fine in HA is Heat Storm HS-1000-WX-WIFI.
It does have less features in the app vs the HS-1500.

The HS-1000 only lets me control power on/off, set temperature, and child lock in the Smart Life app.
The HS-1500 however lets me set the same as above, plus modes from low/auto/high, and adjust screen brightness.

Not sure if any of this will be useful at all but figured the more info the better!

Do you have the HS-1000 working with the newest (2021) version of HA and via the Tuya Integration? I had it working before the Integration was added via yaml config. A couple of versions back I added the Integration and removed the yaml config. It worked the same as the yaml config but without any control options displayed in the Integration panel. After doing a doing a HA update in December, it started working will full functionality in the Integration panel. The climate card also displayed the proper colors and function icons. I decided to do a fresh HA install in my VM with the latest 2021 HA and now I can’t make it work with a yaml config or Integration. Everything else is running very well. Thanks!

Oh interesting. Yeah, I have it working with the newest version but only as a switch still. I haven’t had a chance to look at the integration to see if there was something that might explain why the HS-1500 is working while the HS-1000 is not as a climate entity. I set it up via the UI

I checked out the Tuya HA library at https://github.com/PaulAnnekov/tuyaha (based on HA Tuya Integration documentation). I created and ran the python script and it doesn’t appear that the HS-1000 is supported in the API. Sent an e-mail off to Tuya and asked them to add it to the Home Assistant API. Still not sure why it worked at one point and now it doesn’t. I will keep you posted. Thanks!

I have the HS-1000 working fine with the Tuya integration (no yaml) and full climate control. Running the latest version of HA.
In my setup, it’s only the HS-1500 that functions as a switch instead of climate

Interesting! Response much appreciated. I guess I could also check my network and HA VM to make sure that something is not blocking the API. Are you located in the US?

Right, I got myself turned around. The HS-1500-PHX-WIFI is what I have as well and only shows up as a switch.

Located in Canada, used my SmartLife app for credentials in Tuya integration

Disregard all - I have it working. Thank you for your time. Did a hard reset on the heater, added the device back to the Smart Life App (iPhone). Added the HA Tuya Integration with the heater turned off (blue light showing on power button) and blue wifi signal strength indicator visible. Had to wait for about sixty seconds for API to update in the Tuya Integration panel.

Just bought a Heat Storm HS-1500-PHX-WIFI as well and can only integrate it as a switch via the Tuya integration. Would love to have full climate control. Located in Canada.

@iantrich did you poke around in the Tuya integration by chance?
I would poke around myself, but apparently I would need to actually know what I was looking at in order to be helpful :rofl:

The 1500w heater is a much nicer heater to than the 1000w, but the missing integration for HA sucks :frowning:

This is an issue with the Tuya API, not with HA. Adding details here to clarify the issue for anyone else.

You can check this for yourself by looking at the dependency that HA uses to interface with the API. The developer has kindly added instructions and sample code to test the devices associated with your Tuya account. I added the script to https://repl.it/ and used my credentials to get the following API response:

  "header": { "code": "SUCCESS", "payloadVersion": 1 },
  "payload": {
    "devices": [
        "data": { "online": True, "state": True },
        "dev_type": "switch",
        "ha_type": "switch",
        "icon": "https://images.tuyaus.com/smart/icon/ay1526350714842WhQoy/158823718162c5c0cccd6.png",
        "id": "0151206798f4abc1b25c",
        "name": "Studio Heater"
    "scenes": []

As you can see, the API is setting the type as switch instead of climate.

It appears that lots of people have these kind of issues with different Tuya devices and the developers are not actively maintaining the API, but I am still going to email [email protected] to request them to update this device response as suggested here. If anyone else would like to do the same, perhaps there’s a small chance of getting it fixed!

1 Like

I have a Heat Storm heater and it is now supported by Home Assistant via the new Tuya V2 integration.
The available attributes are:

hvac_modes: []
min_temp: 39
max_temp: 99
target_temp_step: 1
current_temperature: 64
temperature: 81
current_humidity: 0
friendly_name: Shed Heater
supported_features: 1

I’ve added a couple of current temperature based automations and it responds reasonably quick. When I adjust the temp via HA, the change is reflected in my SmartLife app instantly.

Does anyone know what the attributes “target_temp_step” and “supported_features” are? I’m not sure what they are for or if they can be used for anything.

1 Like

What model are you using?

Can anyone else confirm theirs (please provide model) is fully working currently?

I have recently set up a new heater. I can toggle it on and off, set a target temp but it does not correctly reflect the actual temp.

1 Like

Just purchased 2 of the 1500w models.
They show up in HA like this:
I can toggle the heater on and off.
One thing that is backwards is the child lock switch… BLUE would represent it is engaged/active/on… however looking at the device will see the lock is turned off. So need to figure out how to reverse to logic

Would be nice to see the low/auto/high toggle come through and maybe the brightness selector. The timer also would be nice