Tuya Integration error: code: 2406 | msg: 'skill id invalid'

I’m not sure why this happened out of nowhere.
Maybe I upgraded my HomeAssistant Jail (via terminal within TrueNAS dashboard).

Retrying setup: {‘code’: 2406, ‘msg’: ‘skill id invalid’, ‘success’: False, ‘t’: 1566557984948, ‘tid’: ‘xxx’}

Any idea why and how to resolve>?

1 Like

I also got this problem today after enabling 2 disabled tuya devices again.

I confirm this problem. Happened about 3 hours ago. Seems like HA Tuya integration can’t connect to Tuya IoT cloud. Tuya app on Android is still working.

yep just getting this now as well

Retrying setup: {'code': 2406, 'msg': 'skill id invalid', 'success': False, 't': xxxxxxxx, 'tid': 'xxxxxxxxx'}

I had the same issue after updating to 2022.10.3.

I had to create a new project with Tuya, and basically redo the Tuya configuation and then login again with the Tuya integration.

Seems to be working now.


Same here, creating a new project did it for me.


Yes I have exactly the same issue. At first devices would turn on, but not off. So restarted HA and got the same message.

Have logged into the Tuya IoT account and all the devices are shown and no errors thrown.

Making the control of the house a little tricky at present…

1 Like

Following :sunglasses:

Same here. Now my lights do not work :frowning:

ditto here. annoying to say the least.

What do you mean by creating a new project and Tuya?

1 Like

I got the integration to work when I unliked my project then relinked it.

First this:

Then this, scroll down to LINK DEVICES BY APP ACCOUNT


*with Tuya.

Sorry, it was a typo.

Ugh, this is one of the reasons why it’s so hard to trust Home Assistant. Things just randomly break and then it’s a hassle to figure out how to get them working again. Starting to feel like it’s not worth the effort


I had the same issue with all tuya devices not working now. With code 2406. Without me doing anything or upgrading home assistsnt.

Thanks! This worked for me too

1 Like

unlink and relink the phone app on the IoT Platform works!


I woke up today to a working Tuya integration.
I guess it was a temporary problem on Tuyas side.

Thank you all for confirming.

It worked for me, thanks :slight_smile: