Tuya integration problem: "login error (1013): request time is invalid"

Hey!

I have couple of Tuya devices, that worked well with Home Assistant until I’ve reset to factory settings. After that home assistant lost connection with Tuya devices. When I’m trying to reconnect tuya account, there is error: “login error (1013): request time is invalid”. I’ve read in internet, that could be problems with the time settings, but I’ve checked time settings in my router and timezone settings in Home Assistant, and all correct. What can be reason of that error?

Tuya loT :thinking:

ScreenShot_20220130130207

There is my time zone in that section already

I am having the same issue worked ok last night but then I noticed this morning when I tried to relink it I am getting the same error as you reported above. I did add another Tuya account to IOT dev portal to check but no luck.

Hi, this happened to me yesterday.
Don’t know how to solve the issue.
Time zones are set correctly in both Home Assistant and Tuya platform.
I have tried also with LocalTuya, none of them work and I get the same error: “Failed to authenticate. Error 1013: request time is invalid”

Any idea?

OK, I got it. For unknown reason, hassos was configured to use ntp server from cloudflare which was late by 15 minutes. This made the link to Tuya API not accepted.
I changed the NTP server to ntp to 0.fr.pool.ntp.org in file /etc/systemd/timesyncd.conf.

Note: Changing NTP server requires having root access if you use HassOs. I used the procedure here to install configurator and then edit /etc/systemd/timesyncd.conf.

Everything came back to normal and time is now also overall OK in home assistant. And tuya integration works again !

2 Likes

Thanks, It really operate. I was fixed my home assistant on orangepi one

thank youu it solved my issue too, BTW in my case I needed chile NTP, you can use this link
https://www.pool.ntp.org/zone/cl
and get your country

It is not about the wrong time zone. Tuya LoT Core is free for the first 6 months. Then you must start paying or you can try to ask for another 6 months of Trial Period.

Thanks for the info, everywhere I looked for this error explained that was caused by timezone. I’ll try what you suggest.

My timezones appear to match, the app set to US Eastern and HomeAssitant (docker) set to GMT-5. I extended the trial period as well.

This sucks. Any ideas?

GMT+0 gibt es nicht.

This error is driving me crazy. Could you explain a little better how I can solve it?
Thank you so much.

II had the same issue.
On prod VM / VMWare, error message was: access denied
On test VM / Virtualbox error message was: request time is invalid
As proposed for solution on another forum, I just reset App password and problem was solved on both VM…