Tuya IoT account expired - unstable operation


I have followed the official Tuya guidance, and subscribed to the following Tuya trials to enable use of the Tuya V2 integration. This works, albeit buggy and requiring constant reloads of the integration.

As you can see, the IoT core integration has expired with a note stating “The service API calls will consume basic resources. Please make sure that there is a basic resource pack available under your account. You can subscribe to the IoT core service to get a free basic resource pack.”

The other services expire in 1 year. I have tried to re-subscribe to the IoT core service, but this states the trial has expired and I need to purchase a plan, starting at $5000 per annum (I think not!).

Does this mean that once the trial has expired of the other services, the Tuya integration stops working unless you pay the $5000 per year?

Do you know something I don’t?

1 Like

I have the same issue. Hoping to hear from someone that knows how to resolve this.

I went over to Tuya Local, fixed the issue and no more breaks as experienced with the new V2 integration.

1 Like

Wow! :stuck_out_tongue_winking_eye:

I hate Tuya sdk. I have a Google Mini Speaker and 2 Amazon echos, now I have to schedule google speaker TTS to say “Alexa, turn on all the lights”.

I’m having this same issue, any resolution on this? Would really like to get it working. I have an IR blaster from Tuya, that I don’t believe is compatible with local tuya integration, so I would like to figure this out.

I solved the issue!

There is a button that I was missing that allows you to extend the trial. This is different then Re-subscribing to the trial package, (which is what I was trying to do, but it would not allow you to and prompt you to buy $25,000 package instead lol)

When you click the “extend” trial button you will have to fill out an application. Mine was approved very quickly <2hrs.

You can extend the trial by up to one year. (hopefully I can re-extend after that, indefinitely)


Do we actually need this Iot Core trial for Tuya Local to continue functioning? The whole point here was to local operation, so I’m thinking I do not need this service going forward?

I’ve just received an email about my trial ending. Would have been nice on the Tuya integration page if it mentioned this. I’m not paying $25k or $50k for this.

Hopefully Tuya local doesn’t need this. Can anyone answer??

I allowed my Tuya account to expire and the integration still works fine.

I believe we only need the account to retrieve the DeviceID’s and Tokens. Once you have those you no longer need the account.

Ah, ok. So what happens if/when you add more devices after your account expires?

I am not sure. I vaguely recall seeing that worked automatically. I guess we can always sign up once more.

Cheers. Thanks for the reply. Guess I’ll just have to wait it out and see what happens.

I only have a few devices. I was just looking at flashing with Tasmota, seems the devices I have are not able to anymore except possible 1 power strip I have. Another is also a led strip, but I can just find something to replace the controller on that if need be.

yeah having issue to extend… in my case it allow me to extend 5 months only… TUYA is getting annoyed

Whenever Tuya based devices are getting reset (happens if i.e. there has been a power or internet outage), or in case you have to re-pair devices for whatsoever reason the Tokens of those devices will change. Without a valid account, how do you retrieve the new/updated Tokens?

I haven’t noticed changing device-ids. I had one device without power for 5 days. When it came back I reloaded the Tuya integration and they came back perfectly.

Time will tell. Overall the biggest problem I’m seeing here is the lack of documentation from HomeAssistant.

The Tuya device IDs remain the same. TuyaLocal uses this device ID and local ID, and these are persistent after power cycles.

The developer account would be needed to add new devices to an existing Tuya account.

Unfortunately as for LocalTuya (note, I speak for LocalTuya only) this is not entirely true.

The Device-ID (also called “Virtual ID”) indeed does not change anymore. This is correct.

We obviously have a naming discrepancy here about the definiton for “key”:

  • Andrew names it “Tokens” (my reply was directed to his post #10 and so I picked that naming up).
  • Russ Tech names it “local ID”.
  • LocalTuya names it “Local Key”.
  • tuya-cli wizard simply names it “key”.

The “Tokens”/“local ID”/“Local key”/“key” is changing after an extended power or internet outage and after every re-pairing of a Tuya based device. Additionally a “key” is generated when adding a new Tuya based device.

A active/valid “Virtual ID” is needed for logging-in into the developer account when running:
tuya-cli wizard
in addition to the saved API credentials for that account.

$ tuya-cli wizard

? Do you want to use these saved API credentials? xxxxxxxxxxxxxxxxxxxx xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx eu Yes
? Provide a 'virtual ID' of a device currently registered in the app: xxxxxxxxxxxxxxxxxxxx
    name: 'My Tuya Light Switch',
    id: 'xxxxxxxxxxxxxxxxxxxxxxx',
    key: 'xxxxxxxxxxxxxxxxx'

When changing or adding a Tuya device to TuyaLocal, a valid “Device-ID” and the referring valid “Local Key” is needed to complete the procedure successfully:

Hey guys, lol I just noticed a funny thing.
I, like many of you have an expired subscription, and have been getting the “Permission denied” error upon calling the API enpoint for

General Devices management > Get the device information

I applied for renewal but after 24+ hours still noting.

Little did I know, that there is another API under

General Devices management > Get Device Information

Notice the missing “the”. That API works even though my subscription is still expired and I was able to get the Local Key.

Hope this helps!

1 Like

I don’t know where to find this.